summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-16 02:16:12 +0000
committerSam James <sam@gentoo.org>2022-12-16 02:52:04 +0000
commit67eefb25d66a312e6d4ecdf3ff6bb4c7f4847137 (patch)
tree978a7ebbc50ffe8903d33461ec5cbef4cd5f7436 /x11-misc/colord
parentprofiles: unmask lcms (diff)
downloadgentoo-67eefb25d66a312e6d4ecdf3ff6bb4c7f4847137.tar.gz
gentoo-67eefb25d66a312e6d4ecdf3ff6bb4c7f4847137.tar.bz2
gentoo-67eefb25d66a312e6d4ecdf3ff6bb4c7f4847137.zip
x11-misc/colord: backport lcms 2 fix
Closes: https://bugs.gentoo.org/880865 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/colord')
-rw-r--r--x11-misc/colord/colord-1.4.6-r1.ebuild (renamed from x11-misc/colord/colord-1.4.6.ebuild)4
-rw-r--r--x11-misc/colord/files/colord-1.4.6-lcms2-corruption.patch33
2 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/colord/colord-1.4.6.ebuild b/x11-misc/colord/colord-1.4.6-r1.ebuild
index 6b1521b25a0a..58918a6d770d 100644
--- a/x11-misc/colord/colord-1.4.6.ebuild
+++ b/x11-misc/colord/colord-1.4.6-r1.ebuild
@@ -57,6 +57,10 @@ BDEPEND="
vala? ( $(vala_depend) )
"
+PATCHES=(
+ "${FILESDIR}"/${P}-lcms2-corruption.patch
+)
+
src_prepare() {
default
use vala && vala_src_prepare
diff --git a/x11-misc/colord/files/colord-1.4.6-lcms2-corruption.patch b/x11-misc/colord/files/colord-1.4.6-lcms2-corruption.patch
new file mode 100644
index 000000000000..4df6773cfb4b
--- /dev/null
+++ b/x11-misc/colord/files/colord-1.4.6-lcms2-corruption.patch
@@ -0,0 +1,33 @@
+https://bugs.gentoo.org/880865
+
+https://github.com/mm2/Little-CMS/issues/344
+https://github.com/hughsie/colord/issues/145
+
+https://github.com/hughsie/colord/commit/91a3cc2e994be587def3b70762f15461101d43a1
+
+From 91a3cc2e994be587def3b70762f15461101d43a1 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 15 Nov 2022 17:03:37 +0000
+Subject: [PATCH] lib: avoid destructing LCMS plugin twice with lcms 2.14
+
+lcms 2.14 contains a change to avoid a memory leak, but that change
+assumes correct API usage. It's not necessary to both cmsUnregisterPluginsTHR()
+and then cmsDeleteContext() -- we can just straight up delete the LCMS
+context instead (cmsDeleteContext()).
+
+So, follow upstream's suggestion & do that. This fixes memory corruption
+when building colord on x86, for example.
+
+Bug: https://github.com/mm2/Little-CMS/issues/344
+Fixes: https://github.com/hughsie/colord/issues/145
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/lib/colord/cd-context-lcms.c
++++ b/lib/colord/cd-context-lcms.c
+@@ -163,7 +163,6 @@ cd_context_lcms_free (gpointer ctx)
+ g_clear_error (error_ctx);
+ g_free (error_ctx);
+
+- cmsUnregisterPluginsTHR (ctx);
+ cmsDeleteContext (ctx);
+ }
+