summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/chromium/chromium-111.0.5563.110-r1.ebuild (renamed from www-client/chromium/chromium-111.0.5563.110.ebuild)1
-rw-r--r--www-client/chromium/files/chromium-111-InkDropHost-crash.patch25
2 files changed, 26 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-111.0.5563.110.ebuild b/www-client/chromium/chromium-111.0.5563.110-r1.ebuild
index d41b4c6b4d15..d83cbb6b2169 100644
--- a/www-client/chromium/chromium-111.0.5563.110.ebuild
+++ b/www-client/chromium/chromium-111.0.5563.110-r1.ebuild
@@ -342,6 +342,7 @@ src_prepare() {
"${FILESDIR}/chromium-109-system-zlib.patch"
"${FILESDIR}/chromium-109-system-openh264.patch"
"${FILESDIR}/chromium-111-ozone-platform.patch"
+ "${FILESDIR}/chromium-111-InkDropHost-crash.patch"
"${FILESDIR}/chromium-use-oauth2-client-switches-as-default.patch"
"${FILESDIR}/chromium-cross-compile.patch"
)
diff --git a/www-client/chromium/files/chromium-111-InkDropHost-crash.patch b/www-client/chromium/files/chromium-111-InkDropHost-crash.patch
new file mode 100644
index 000000000000..21dd8e41b8c8
--- /dev/null
+++ b/www-client/chromium/files/chromium-111-InkDropHost-crash.patch
@@ -0,0 +1,25 @@
+https://chromium-review.googlesource.com/c/chromium/src/+/2959890
+
+--- a/ui/views/animation/ink_drop_host.h
++++ b/ui/views/animation/ink_drop_host.h
+@@ -238,6 +238,11 @@ class VIEWS_EXPORT InkDropHost {
+ // Used to observe View and inform the InkDrop of host-transform changes.
+ ViewLayerTransformObserver host_view_transform_observer_;
+
++ // Declared before |ink_drop_|, because InkDropImpl may call
++ // RemoveInkDropLayer on partly destructed InkDropHost. In
++ // that case |ink_drop_mask_| must be still valid.
++ std::unique_ptr<views::InkDropMask> ink_drop_mask_;
++
+ // Should not be accessed directly. Use GetInkDrop() instead.
+ std::unique_ptr<InkDrop> ink_drop_;
+
+@@ -261,8 +266,6 @@ class VIEWS_EXPORT InkDropHost {
+ int ink_drop_small_corner_radius_ = 2;
+ int ink_drop_large_corner_radius_ = 4;
+
+- std::unique_ptr<views::InkDropMask> ink_drop_mask_;
+-
+ base::RepeatingCallback<std::unique_ptr<InkDrop>()> create_ink_drop_callback_;
+ base::RepeatingCallback<std::unique_ptr<InkDropRipple>()>
+ create_ink_drop_ripple_callback_;