summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/logstash-bin')
-rw-r--r--app-admin/logstash-bin/Manifest1
-rw-r--r--app-admin/logstash-bin/logstash-bin-5.6.15.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/logstash-bin/Manifest b/app-admin/logstash-bin/Manifest
index ea5184722c81..438a2a75a88c 100644
--- a/app-admin/logstash-bin/Manifest
+++ b/app-admin/logstash-bin/Manifest
@@ -1,4 +1,5 @@
DIST logstash-5.6.13.tar.gz 104517136 BLAKE2B c4f0ba5f8e1624ef0493e553166a3c18aab9c4d73a661a5f91988627ec8470dc8a1b52461673e27169c8c10b33dfdeffeef96e70e1a8a04b7ee4a1e71a9afb68 SHA512 df12877b8d28ce9392f9d9ec9414205dd1f628a8e927c8b31f0ad3c3c7b11108509fe6b44119faa3f1bab393ea7be74a3a7c5b5b6b49d6ff5b54ce31fd024a04
+DIST logstash-5.6.15.tar.gz 110086992 BLAKE2B 3047259c4bc5d71b072fa004c44953f84860ec53e051641c4efc903e38243e85b8fdebeaf093c01f5410c1f05a78a8d8aa2282fc45cf5fd784a41ea66ff5b196 SHA512 405039ff988aee8878cbeca96ef0fcbadba762f877eaec36c8a75b010e56a943c2951a8f83f9279d7d9fea99c4f8a200c705f784813a2733289336c58c34ca1e
DIST logstash-6.3.2.tar.gz 144211416 BLAKE2B 8471fd0a920b4ef06cd775ceaafde33e16e5d1898c89339f4a039262a7a6472d6cb8dd2017db8811d6a827395a5b1e7040d9759c8734de2ccd1fc7e615345813 SHA512 11507b9177aa6cd4172eb825e395571de71bae8b0e39d7f700fe27c7219b22bc2b9a493e39016eead2d54407dc5e5cc20a0c6e4453140d628cadea076453308f
DIST logstash-6.4.3.tar.gz 153936585 BLAKE2B efdcc4664587a3ab18e2e78136c92bc643e99989fa5ac1cd1daaeb48ca1f6fa57f122a5686ddcaab59d920a0ef0e59dc70f59c05a520b731347f37d8faa78c38 SHA512 39bab1b9b0c9f0006c2ad7aa152b3863179030352202ec0c4c4a887bdeb98d4c34127699655cfc7c5b9f44119b45de9629bfacc670d520dcf266b3298fdf2484
DIST logstash-6.5.4.tar.gz 160286824 BLAKE2B 6f76edee968566539670b0ffc5462a0a417d39dc8f7d3fab35704ace23c27503f7051a064fca2820d52b100a19818621841356f8e1df20a80c95902f4c1c7f95 SHA512 8dff51b3944219b462002d0ced4ae7050d8ab8f9335de1132be11ab8e7277731f319c5794601881ee94350152725c599093316c5ef55ddc95279697ec794cc57
diff --git a/app-admin/logstash-bin/logstash-bin-5.6.15.ebuild b/app-admin/logstash-bin/logstash-bin-5.6.15.ebuild
new file mode 100644
index 000000000000..635350ca2abb
--- /dev/null
+++ b/app-admin/logstash-bin/logstash-bin-5.6.15.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-pkg-2 user
+
+MY_PN="${PN%-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for managing events and logs"
+HOMEPAGE="https://www.elastic.co/products/logstash"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}.tar.gz"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
+
+RDEPEND="virtual/jre:1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN}
+}
+
+src_install() {
+ keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
+ keepdir "/var/lib/${MY_PN}"
+ keepdir "/var/log/${MY_PN}"
+
+ insinto "/usr/share/${MY_PN}"
+ newins "${FILESDIR}/agent.conf.sample" agent.conf
+
+ rm -v config/startup.options || die
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -rv config data || die
+
+ insinto "/opt/${MY_PN}"
+ doins -r .
+ fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"
+
+ newconfd "${FILESDIR}/${MY_PN}.confd-r1" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.initd-r1" "${MY_PN}"
+
+ insinto /usr/share/eselect/modules
+ doins "${FILESDIR}"/logstash-plugin.eselect
+}
+
+pkg_postinst() {
+ ewarn "The default pidfile directory has been changed from /run/logstash to /run."
+ ewarn "Please ensure any running logstash processes are shut down cleanly."
+ ewarn
+ ewarn "The default data directory has been moved from /opt/logstash/data to"
+ ewarn "/var/lib/logstash/data. Please check and move its contents as necessary."
+ ewarn
+ ewarn "Self installed plugins are removed during Logstash upgrades (Bug #622602)"
+ ewarn "Install the plugins via eselect module that will automatically re-install"
+ ewarn "all self installed plugins after Logstash upgrades."
+ elog
+ elog "Installing plugins:"
+ elog "eselect logstash-plugin install logstash-output-gelf"
+ elog
+
+ elog "Reinstalling self installed plugins (installed via eselect module):"
+ eselect logstash-plugin reinstall
+
+ elog
+ elog "Sample configuration:"
+ elog "${EROOT%/}/usr/share/${MY_PN}"
+}