summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-table-extra')
-rw-r--r--app-i18n/fcitx-table-extra/Manifest1
-rw-r--r--app-i18n/fcitx-table-extra/fcitx-table-extra-5.1.5.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-i18n/fcitx-table-extra/Manifest b/app-i18n/fcitx-table-extra/Manifest
index 78a5b058f9a5..9d57b2efc026 100644
--- a/app-i18n/fcitx-table-extra/Manifest
+++ b/app-i18n/fcitx-table-extra/Manifest
@@ -1,3 +1,4 @@
DIST fcitx-table-extra-0.3.8.tar.xz 3700736 BLAKE2B b8ce4b3aa04eba8b594b86958bb83e348758c30688828a4834643cf7bdd62852c2ca89bc4f75f0cb1b16ce969b0454c58e3abadff9c78318dc0953e0905c75fa SHA512 454798e9bd25c630ce98e2daf7296e82ba5fbc98027171038a5a7b9ac3169c153302a6703d9416718ec3a0b76db6d732caf3f03c6e6005841c9d7798702542df
DIST fcitx-table-extra-5.1.3.tar.xz 7557460 BLAKE2B c5a06cd79d19ad3794379da24f0fa2c41b7edba3b62a7e377d1b85c66844c10167e46bfbb7d79c3795f22b579eeac99b0c37e79e2778fb73fb92595495776b89 SHA512 14dc416c5d5936484fd0a940ee8e1e3ddd34064b48213e69d3e93ce63d60c95ceac727cf3925e2aa0457d001ef72276f647246b739b98a6480f27b47e356cc3b
DIST fcitx-table-extra-5.1.4.tar.xz 7506768 BLAKE2B 62082946e5e399eda6d4d44e3aaac7e96975da9ec39031735d775f526e7879718dae0fb8020364c65ca684bb186affcd1956a1fb87da9971d0135d9acd025da2 SHA512 c26007209706263d29f189a6bb8088d5bde81c322649b6dba21df76fda3dc1a6926066c950bdbd09f3392216bbf61aec8657f8182844b5656e4111554b5025bb
+DIST fcitx-table-extra-5.1.5.tar.zst 13837962 BLAKE2B 52d546636fb0520826d9b4e8df3a68a163edd71a57ac7cc720916ebdd7141d6a4ce194ecb3aa205a568b10a99ae611e607325c652ed293ba16bb783bfd64bfd3 SHA512 19cc8f45c26f4841b3c8a4724375f8926741a153757626d4f5a598abc9ea0e12133b0ef13c3a1893675360102f69dd91b8c9861849d8f1677242339f11f475fc
diff --git a/app-i18n/fcitx-table-extra/fcitx-table-extra-5.1.5.ebuild b/app-i18n/fcitx-table-extra/fcitx-table-extra-5.1.5.ebuild
new file mode 100644
index 000000000000..9a28c8eae2d4
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/fcitx-table-extra-5.1.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=fcitx5-table-extra
+
+inherit cmake unpacker xdg
+
+DESCRIPTION="Provides extra table for Fcitx, including Boshiamy, Zhengma, Cangjie, and Quick"
+HOMEPAGE="https://github.com/fcitx/fcitx5-table-extra"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.zst -> ${P}.tar.zst"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+LICENSE="GPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+DEPEND="
+ !app-i18n/fcitx-table-extra:4
+ app-i18n/fcitx:5
+ app-i18n/libime
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"