summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/patatt/patatt-0.6.2.ebuild')
-rw-r--r--dev-python/patatt/patatt-0.6.2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/patatt/patatt-0.6.2.ebuild b/dev-python/patatt/patatt-0.6.2.ebuild
new file mode 100644
index 000000000000..278156413472
--- /dev/null
+++ b/dev-python/patatt/patatt-0.6.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple library to add cryptographic attestation to patches sent via email"
+HOMEPAGE="https://pypi.org/project/patatt/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pynacl[${PYTHON_USEDEP}]"