summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-fchksum')
-rw-r--r--dev-python/python-fchksum/Manifest1
-rw-r--r--dev-python/python-fchksum/files/python-fchksum-1.7.1-md5-align.patch26
-rw-r--r--dev-python/python-fchksum/metadata.xml8
-rw-r--r--dev-python/python-fchksum/python-fchksum-1.7.1-r1.ebuild21
4 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/python-fchksum/Manifest b/dev-python/python-fchksum/Manifest
deleted file mode 100644
index a1361c2355c5..000000000000
--- a/dev-python/python-fchksum/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST python-fchksum-1.7.1.tar.gz 26724 BLAKE2B 63385862b770c30098f80912c37b9e559fa4a1f400dcc30777cc8af4fe8abc2f658e41fc33035d7c6f04624960b499b04ae03257656589cd24986cd7f8273f5d SHA512 59b561e2938c41bcda2b98eb3fa0670be3fd85f8cb67368132ce239cac21760a5e9a5a05be2429992fa480ccd2e2aa457df7b4a07e709acbe42be9b1559f3060
diff --git a/dev-python/python-fchksum/files/python-fchksum-1.7.1-md5-align.patch b/dev-python/python-fchksum/files/python-fchksum-1.7.1-md5-align.patch
deleted file mode 100644
index 1adfa627fdd8..000000000000
--- a/dev-python/python-fchksum/files/python-fchksum-1.7.1-md5-align.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-the alignment of resbuf is not guaranteed, so use memcpy to move
-the bytes in/out. on arches which can do unaligned accesses, this
-will generate the same code.
-
-patch by Mike Frysinger
-
---- a/md5.c
-+++ b/md5.c
-@@ -74,10 +74,13 @@ md5_read_ctx (ctx, resbuf)
- const struct md5_ctx *ctx;
- void *resbuf;
- {
-- ((md5_uint32 *) resbuf)[0] = SWAP (ctx->A);
-- ((md5_uint32 *) resbuf)[1] = SWAP (ctx->B);
-- ((md5_uint32 *) resbuf)[2] = SWAP (ctx->C);
-- ((md5_uint32 *) resbuf)[3] = SWAP (ctx->D);
-+ md5_uint32 swap;
-+#define set(i, c) { swap = SWAP (ctx->c); memcpy (resbuf + (i * 4), &swap, 4); }
-+ set (0, A);
-+ set (1, B);
-+ set (2, C);
-+ set (3, D);
-+#undef set
-
- return resbuf;
- }
diff --git a/dev-python/python-fchksum/metadata.xml b/dev-python/python-fchksum/metadata.xml
deleted file mode 100644
index 9e5274c5b4ae..000000000000
--- a/dev-python/python-fchksum/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
-</maintainer>
-</pkgmetadata>
diff --git a/dev-python/python-fchksum/python-fchksum-1.7.1-r1.ebuild b/dev-python/python-fchksum/python-fchksum-1.7.1-r1.ebuild
deleted file mode 100644
index f6c1e03a8d1d..000000000000
--- a/dev-python/python-fchksum/python-fchksum-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module to find the checksum of files"
-HOMEPAGE="http://code.fluffytapeworm.com/projects"
-SRC_URI="http://code.fluffytapeworm.com/projects/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND="sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-md5-align.patch )