summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtvirtualkeyboard/Manifest1
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.1.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-qt/qtvirtualkeyboard/Manifest b/dev-qt/qtvirtualkeyboard/Manifest
index 8b30d485e371..b8fee4e72ab2 100644
--- a/dev-qt/qtvirtualkeyboard/Manifest
+++ b/dev-qt/qtvirtualkeyboard/Manifest
@@ -1,3 +1,2 @@
DIST qtvirtualkeyboard-everywhere-opensource-src-5.15.14.tar.xz 10952936 BLAKE2B 258584cfe09100fa35b8b6293a6fb29f7d7631a7ca8e3b27d121bfa8a86e96c5a346dae1aed3aca6d80501210f5cc594f1c133adc41f12dcdfde6d12d2f91a0c SHA512 d6ff2770282e460a8d9fff3746225918cb21c65ef0d0d89e1c6876428ca1e860ecf45b44d57c9ef6e9a85cb050a4a67ecc1b20ae5c5be0a37d8b73ca439587c3
-DIST qtvirtualkeyboard-everywhere-src-6.7.1.tar.xz 3729484 BLAKE2B d5079f63f8c8dac1d5f364c7fc92477eb50f05c991ce9fbd2f5c7cde424348f9284b18b39bb0a22962aac5bdefdd890650356d65653ab20c68ab98b779e2a1cc SHA512 7d3baf735cac2906de5bc982fc3d1efa45c77d1d527ca3392cade59975cc8307ea85b0f7f018607cfc531742e8da6bfbc04f9ba4b523b2ebf1ebcde8f64befcd
DIST qtvirtualkeyboard-everywhere-src-6.7.2.tar.xz 3722296 BLAKE2B 316ee5e2204ebabd97c0d6ceb8bd9775bc456eb404f6ffee43a163823c43d86a94e900a06d8a1124506385aa8b17d67efd70caec64cded9dcd747d667186c9fd SHA512 016400a65e14a5ec960f20ecf6b2b7c32fa0c67d530c5046b423633b02efce200e0967642a072ff825c54c334dfe45be3e569c16d641a735f181d233fa414782
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.1.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.1.ebuild
deleted file mode 100644
index 7297597168fb..000000000000
--- a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 arm arm64 ~loong ~ppc64 ~riscv x86"
-fi
-
-IUSE="+spell"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[gui]
- ~dev-qt/qtdeclarative-${PV}:6
- ~dev-qt/qtsvg-${PV}:6
- spell? ( app-text/hunspell:= )
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- $(qt_feature spell hunspell)
- -DINPUT_vkb_handwriting=no # neither cerence nor myscript are packaged
- )
-
- qt6-build_src_configure
-}
-
-src_test() {
- local CMAKE_SKIP_TESTS=(
- # rarely randomly(?) fails even with -j1
- tst_layoutfilesystem
- )
-
- if use spell && has_version app-dicts/myspell-en; then
- # 99% pass but minor sub-tests fail with myspell-en, needs looking into
- ewarn "Warning: notable tests were skipped due to ${_} being installed"
- CMAKE_SKIP_TESTS+=(
- tst_inputpanel
- tst_inputpanelcontrols2
- )
- else
- einfo "tst_inputpanel can take >5mins, not known to actually hang"
- fi
-
- qt6-build_src_test
-}