summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mecab-ruby')
-rw-r--r--dev-ruby/mecab-ruby/mecab-ruby-0.996-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/mecab-ruby/mecab-ruby-0.996-r1.ebuild b/dev-ruby/mecab-ruby/mecab-ruby-0.996-r1.ebuild
new file mode 100644
index 000000000000..d3619d91fc81
--- /dev/null
+++ b/dev-ruby/mecab-ruby/mecab-ruby-0.996-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+inherit ruby-ng
+
+DESCRIPTION="Ruby binding for MeCab"
+HOMEPAGE="http://mecab.sourceforge.net/"
+SRC_URI="https://mecab.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="~app-text/mecab-${PV}"
+RDEPEND="${DEPEND}"
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_install() {
+ emake DESTDIR="${D}" install
+}
+
+all_ruby_install() {
+ dodoc AUTHORS README test.rb
+ dohtml bindings.html
+}