summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ccache/ccache-4.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-util/ccache/ccache-4.1.ebuild b/dev-util/ccache/ccache-4.1.ebuild
index 0e307b9c7221..11644f232e31 100644
--- a/dev-util/ccache/ccache-4.1.ebuild
+++ b/dev-util/ccache/ccache-4.1.ebuild
@@ -46,6 +46,14 @@ src_prepare() {
-e "/^EPREFIX=/s:'':'${EPREFIX}':" \
"${FILESDIR}"/ccache-config-3 > ccache-config || die
+ # Avoid non-ASCII double quotes as they fail on
+ # LANG=fr_FR.iso885915@euro: #762814.
+ sed \
+ -e 's/\xE2\x80\x99/'\''/g' \
+ -e 's/\xE2\x80\x9C/"/g' \
+ -e 's/\xE2\x80\x9D/"/g' \
+ -i doc/MANUAL.adoc || die
+
# mainly used in tests
tc-export CC OBJDUMP
}