summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/Manifest2
-rw-r--r--dev-vcs/git-cola/git-cola-3.12.0.ebuild111
-rw-r--r--dev-vcs/git-cola/git-cola-4.0.2.ebuild79
3 files changed, 0 insertions, 192 deletions
diff --git a/dev-vcs/git-cola/Manifest b/dev-vcs/git-cola/Manifest
index 036671e0e7f5..17a62a8b71c2 100644
--- a/dev-vcs/git-cola/Manifest
+++ b/dev-vcs/git-cola/Manifest
@@ -1,5 +1,3 @@
-DIST git-cola-3.12.0.tar.gz 1004892 BLAKE2B 9396768256341e59500dffc95136e710b2d3d1c9d5cb4d70fc7fba8e81e16a3656006b5558dae417fbbad7baf1373d953708006b96a8873f68502ea469462326 SHA512 4b8ec716f572682747f43ae1a9232612d95d44384d28bbf97ef461a93546cdfcc81125f816b4c8ea5efcf4d23f42edeb8a89df3c7167ceac4709eeeaf49965a9
DIST git-cola-4.0.1.tar.gz 1018819 BLAKE2B 523264bbee38526d12db5ad975d78c72ef6c0dae98566f5a8b5d51b115d222c8aa6daab838ba67fa4c697391c8f58d4b05ddb7920bf65913d217f562aabd352f SHA512 c02150997982c1f8ce65a5f021364fc4c346339f5be4104f82ba6f7688cc05bad3d764e2cf920a22c5f209dc4b857c789907ff58c0d2809bc7ca7c3481b045fd
-DIST git-cola-4.0.2.tar.gz 1022362 BLAKE2B 6f1d6aa6fa6c308f28150018eea8a110c2ceb35ac5e904844568a503e1ebfdb07d9d79b7fa6542aa734c62ae5e5b2e41bb26c99b23a7a84067c102598354cec1 SHA512 01a68caf12bff400b243a57a9b5a5f07c2c1bd1b90d50acc75806ffdd9377409a56dd591311667afab7508f1ff0d88e31744c1990db3f5f6ce9d977f3fa4068e
DIST git-cola-4.0.3.tar.gz 1131525 BLAKE2B 042ec4e0db5f9a9f947de3dcedc13c6dd2464ee29a9363f48b50622e88fbb878ed1034ff915e7a87b4a835f71dc11051e4649837e5f6de3ffe6bd84fea055d23 SHA512 06c032a9522dfefe4e95f64b00c79169da0bb68a4fc9966ac442da62cefc26a89155690b4b7bbe1fe79f8225d36e2459333bedb0cc0ef7e23521725607d9bc3b
DIST git-cola-4.1.0.tar.gz 1140393 BLAKE2B 3236e06f86d23a7311e3cd639cbf2adcecb18810abcae938d1ff7cf25b477d814e614fffa20ce39dd9a2c6ab4f8e6b6b67f3ad3144163abe6530ac227313ca98 SHA512 4d2617947d4dbf3273f02c072de5ede10a656981f3653273780e2c1b1d3d613cd359fbb93cfb0a1d5de24b0c90818503cd9041ad3fa1a05b2ecd2db305bbe1a0
diff --git a/dev-vcs/git-cola/git-cola-3.12.0.ebuild b/dev-vcs/git-cola/git-cola-3.12.0.ebuild
deleted file mode 100644
index 29c89753a8ec..000000000000
--- a/dev-vcs/git-cola/git-cola-3.12.0.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_SINGLE_IMPL=true
-DISTUTILS_USE_SETUPTOOLS=no
-inherit distutils-r1 readme.gentoo-r1 virtualx xdg-utils
-
-DESCRIPTION="The highly caffeinated git GUI"
-HOMEPAGE="https://git-cola.github.io/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/QtPy[gui,network,${PYTHON_USEDEP}]
- dev-python/send2trash[${PYTHON_USEDEP}]
- ')
- dev-vcs/git
-"
-BDEPEND="sys-devel/gettext
- $(python_gen_cond_dep "
- doc? ( dev-python/sphinx[\${PYTHON_USEDEP}] )
- test? (
- ${VIRTUALX_DEPEND}
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/mock[\${PYTHON_USEDEP}]
- dev-python/PyQt5[\${PYTHON_USEDEP},gui,widgets]
- )
- ")
-"
-
-python_prepare_all() {
- # make sure that tests also use the system provided QtPy
- rm -r qtpy || die
-
- rm share/git-cola/bin/*askpass* || die
-
- # don't install docs into wrong location
- sed -i -e '/doc/d' setup.py || die
-
- # fix doc directory reference
- sed -i \
- -e "s/'doc', 'git-cola'/'doc', '${PF}'/" \
- cola/resources.py || die
-
- # fix ssh-askpass directory reference
- sed -i -e 's/resources\.share/resources\.prefix/' cola/app.py || die
-
- # disable flake8 testing, it's not useful for ebuilds
- sed -i -e 's:--flake8::' pytest.ini || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- DISTUTILS_ARGS=( --no-vendor-libs --no-private-libs )
-}
-
-python_compile_all() {
- cd share/doc/${PN}/ || die
- if use doc ; then
- emake all
- else
- sed \
- -e '/^install:/s:install-html::g' \
- -e '/^install:/s:install-man::g' \
- -i Makefile || die
- fi
-}
-
-python_test() {
- GIT_CONFIG_NOSYSTEM=true \
- PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C.utf8" \
- virtx epytest cola test
-}
-
-python_install_all() {
- cd share/doc/${PN}/ || die
- emake \
- DESTDIR="${D}" \
- docdir="${EPREFIX}/usr/share/doc/${PF}" \
- prefix="${EPREFIX}/usr" \
- install
-
- # remove empty bin folder
- rm -R "${ED}"/usr/share/git-cola/bin || die
-
- use doc || HTML_DOCS=( "${FILESDIR}"/index.html )
-
- distutils-r1_python_install_all
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}
diff --git a/dev-vcs/git-cola/git-cola-4.0.2.ebuild b/dev-vcs/git-cola/git-cola-4.0.2.ebuild
deleted file mode 100644
index 4042b1f292ad..000000000000
--- a/dev-vcs/git-cola/git-cola-4.0.2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_SINGLE_IMPL=true
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 readme.gentoo-r1 virtualx xdg-utils
-
-DESCRIPTION="The highly caffeinated git GUI"
-HOMEPAGE="https://git-cola.github.io/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets]
- dev-python/QtPy[gui,network,${PYTHON_USEDEP}]
- dev-python/send2trash[${PYTHON_USEDEP}]
- ')
- dev-vcs/git
-"
-BDEPEND="sys-devel/gettext
- $(python_gen_cond_dep "
- test? (
- ${VIRTUALX_DEPEND}
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/PyQt5[\${PYTHON_USEDEP},gui,widgets]
- )
- ")
-"
-
-# right now, dev-python/jaraco-packaging is mask, so we cannot generate docs
-#distutils_enable_sphinx docs \
-# '>=dev-python/jaraco-packaging-9' \
-# 'dev-python/rst-linker'
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i "s|doc/git-cola =|doc/${PF} =|" setup.cfg || die
- sed -i -e 's:--flake8::' pytest.ini || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- cd "${T}" || die
- GIT_CONFIG_NOSYSTEM=true LC_ALL="C.utf8" \
- epytest "${S}"/test
-}
-
-src_compile() {
- SETUPTOOLS_SCM_PRETEND_VERSION=${PV} distutils-r1_src_compile
-}
-
-src_install() {
- distutils-r1_src_install
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}