summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/tuxanci/tuxanci-99999999.ebuild')
-rw-r--r--games-arcade/tuxanci/tuxanci-99999999.ebuild59
1 files changed, 23 insertions, 36 deletions
diff --git a/games-arcade/tuxanci/tuxanci-99999999.ebuild b/games-arcade/tuxanci/tuxanci-99999999.ebuild
index 8d85ddeeebb7..3d55994e39ee 100644
--- a/games-arcade/tuxanci/tuxanci-99999999.ebuild
+++ b/games-arcade/tuxanci/tuxanci-99999999.ebuild
@@ -1,24 +1,22 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-[[ ${PV} = 9999* ]] && GIT="git-2"
-EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
-
-inherit games cmake-utils ${GIT}
+inherit cmake-utils
DESCRIPTION="Tuxanci is first tux shooter inspired by game Bulanci"
HOMEPAGE="http://www.tuxanci.org/"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
else
- SRC_URI="http://download.${PN}.org/${P}.tar.bz2"
+ SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
fi
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
IUSE="debug dedicated +ipv6 nls opengl physfs +sound"
@@ -42,31 +40,20 @@ DEPEND="${RDEPEND}
"
src_configure() {
- local mycmakeargs+=(
- $(cmake-utils_use_with sound AUDIO)
- $(cmake-utils_use_build dedicated SERVER)
- $(cmake-utils_use_with nls)
- $(cmake-utils_use_with physfs)
- $(cmake-utils_use_with opengl)
- $(cmake-utils_use_enable ipv6)
- $(cmake-utils_use debug DEVELOPER)
- )
-
- mycmakeargs+=(
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DCMAKE_INSTALL_ICONDIR=${GAMES_DATADIR_BASE}/pixmaps/"
- "-DCMAKE_INSTALL_DESKTOPDIR=${GAMES_DATADIR_BASE}/applications/"
- "-DCMAKE_DATA_PATH=${GAMES_DATADIR}"
- "-DCMAKE_LOCALE_PATH=${GAMES_DATADIR_BASE}/locale/"
- "-DCMAKE_DOC_PATH=${GAMES_DATADIR_BASE}/doc/${PF}"
- "-DCMAKE_CONF_PATH=${GAMES_SYSCONFDIR}"
+ local mycmakeargs=(
+ -DWITH_AUDIO=$(usex sound)
+ -DBUILD_SERVER=$(usex dedicated)
+ -DWITH_NLS=$(usex nls)
+ -DWITH_PHYSFS=$(usex physfs)
+ -DWITH_OPENGL=$(usex opengl)
+ -DENABLE_IPV6=$(usex ipv6)
+ -DDEVELOPER=$(usex debug)
+ -DCMAKE_INSTALL_ICONDIR="${EPREFIX}"/usr/pixmaps/
+ -DCMAKE_INSTALL_DESKTOPDIR="${EPREFIX}"/usr/applications/
+ -DCMAKE_DATA_PATH="${EPREFIX}"/usr/share/
+ -DCMAKE_LOCALE_PATH="${EPREFIX}"/usr/share/locale/
+ -DCMAKE_DOC_PATH="${EPREFIX}"/usr/share/doc/${PF}
+ -DCMAKE_CONF_PATH="${EPREFIX}"/etc
)
-
cmake-utils_src_configure
}
-
-src_install() {
- cmake-utils_src_install
-
- prepgamesdirs
-}