summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.15.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index 5b64eb8883c8..a9eee44858d7 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1,2 +1,3 @@
DIST ksysguard-5.14.5.tar.xz 501624 BLAKE2B 1d2a19d268653768affce6c746340fc1ab3e5f77cca939e6ec58f9e4285d51bffb0026f65489db54d43799df95983288d6d59d38c52aec2f63f3d668b94757db SHA512 fb04538b500f3d3dd0a3f6fa1a0adf1d3a72e2647bb48eebff8fac2c00d5f3a1de18cf4ea35bb6daa210976514bfe3d8adf8a6785d279535b0e2b4b82f25ba67
DIST ksysguard-5.15.1.tar.xz 500012 BLAKE2B a5ed69cbf06e6a824a1c8afabe0e74f52e930f7f6fb7196f251812bc1dcde1120959685f08b301ffd7274f94a1db2b8ddcddeb31a529df51c10052fd7b38354e SHA512 954d17cdc12718630bce0ab4e2913c6831c46c0c2ea18662c76de9b0b76532c211a02ba898f11d196729834f6ebf7e65dbc05907f7c491b5024be5091c54833f
+DIST ksysguard-5.15.2.tar.xz 500568 BLAKE2B 2507c0abddfa48676c73aac9593f3b81e5f8d22a02e3608c9e84fc982f60e9390d0e009fd124b6a24076ff21e571f830b7f8e977be0ff646af33405b2bce7f06 SHA512 d7fdce9a4778150dcc6de3cca7aeb99803aa5323f0ea15a40b15635d437085dc8d77053c9016b999b71a9a0d40458199c0234f78754ea574e4871ec6961e6b62
diff --git a/kde-plasma/ksysguard/ksysguard-5.15.2.ebuild b/kde-plasma/ksysguard/ksysguard-5.15.2.ebuild
new file mode 100644
index 000000000000..dc21acd63e69
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.15.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}