summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/stem')
-rw-r--r--net-libs/stem/Manifest1
-rw-r--r--net-libs/stem/stem-1.8.0_p20211118.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/net-libs/stem/Manifest b/net-libs/stem/Manifest
index bd532469df80..3d4cb4c23200 100644
--- a/net-libs/stem/Manifest
+++ b/net-libs/stem/Manifest
@@ -1,3 +1,2 @@
DIST stem-1.8.0.tar.gz 2853802 BLAKE2B a275a38e53c5a4a3771a30528fd5781c51370352dd384a77ce27b31f034bece6fef448d74008adb82d2d909104b7338b5168a1a343c799637f9e12d39028bd09 SHA512 aa2033567b79aef960f8321e4c6cbc28105c59d6513ff49a9f12509d8f97b1a2e8a3b04dc28abb07fad59b0f6ba66443b92bbefa0d08b26038bbaf24f7f2846d
-DIST stem-1.8.0_p20211118.tar.gz 2862928 BLAKE2B 0c284be96332e11c011eb69d4448fab5c33cc59e4107abad44d7bc1186629112ca8658aade28e486c0eed873524e18ed87edf5920520d5c8dd854b2fec7867ea SHA512 b8afb5d2203b19930e8c1eaa3cad331c0df8b8bcffe4b224b8bab549866f53a5f06001d2141a0a8b7becfa8b7c1281ef5d9584423c8ba25dc4198cfaf07d3a14
DIST stem-1.8.1.tar.gz 2859634 BLAKE2B f78da079791583a17eb439a4e2459c7e0af454e45300202df1085d1b1ba150ee097cfa1b93df5ad0d7090644fad6e035604382c73b94744076cad490ab52459a SHA512 bad2f4f96e37caa3ee2928bb027318c4941ca3f6c0072c5f6e87fe647d2b68400ad352d9c27fa2a35c00f4f327aa9cc00e2907b21a9cbd26fab46ec21e2a038a
diff --git a/net-libs/stem/stem-1.8.0_p20211118.ebuild b/net-libs/stem/stem-1.8.0_p20211118.ebuild
deleted file mode 100644
index f409826d624a..000000000000
--- a/net-libs/stem/stem-1.8.0_p20211118.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Fails w/ 3.11: https://github.com/torproject/stem/issues/130 (breaks net-misc/nyx)
-PYTHON_COMPAT=( python3_{9..10} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1
-
-DESCRIPTION="Stem is a Python controller library for Tor"
-HOMEPAGE="https://stem.torproject.org"
-COMMIT="57364fae7269ec562c5fc8cdb073ff9463d9a0f0"
-SRC_URI="https://github.com/torproject/stem/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~riscv ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
- net-vpn/tor )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-RDEPEND="net-vpn/tor"
-
-DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
-
-python_prepare_all() {
- # Disable failing test
- sed -i -e "/test_expand_path/a \
- \ \ \ \ return" test/integ/util/system.py || die
- sed -i -e "/test_parsing_with_example/a \
- \ \ \ \ return" test/unit/manual.py || die
- sed -i -e "/test_parsing_with_unknown_options/a \
- \ \ \ \ return" test/unit/manual.py || die
- sed -i -e "/test_saving_manual/a \
- \ \ \ \ return" test/unit/manual.py || die
- sed -i -e "/test_sdist_matches_git/a \
- \ \ \ \ return" test/integ/installation.py || die
- sed -i -e "/test_connections_by_ss/a \
- \ \ \ \ return" test/integ/util/connection.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- ${PYTHON} run_tests.py --all --target RUN_ALL || die
-}