summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/glib-networking/glib-networking-2.76.1.ebuild7
-rw-r--r--net-libs/glib-networking/glib-networking-2.78.0.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/net-libs/glib-networking/glib-networking-2.76.1.ebuild b/net-libs/glib-networking/glib-networking-2.76.1.ebuild
index 63096b664380..b662291fbe8c 100644
--- a/net-libs/glib-networking/glib-networking-2.76.1.ebuild
+++ b/net-libs/glib-networking/glib-networking-2.76.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -58,6 +58,11 @@ multilib_src_configure() {
}
multilib_src_test() {
+ # Pretend the network is available so we get real libproxy parsing
+ # output rather than it giving up early in e.g. systemd-nspawn in some
+ # cases.
+ # https://github.com/libproxy/libproxy/issues/260 (bug #914382)
+ local -x GIO_USE_NETWORK_MONITOR=base
dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
}
diff --git a/net-libs/glib-networking/glib-networking-2.78.0.ebuild b/net-libs/glib-networking/glib-networking-2.78.0.ebuild
index d69dd2a0427c..725cbc323cd4 100644
--- a/net-libs/glib-networking/glib-networking-2.78.0.ebuild
+++ b/net-libs/glib-networking/glib-networking-2.78.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -58,6 +58,11 @@ multilib_src_configure() {
}
multilib_src_test() {
+ # Pretend the network is available so we get real libproxy parsing
+ # output rather than it giving up early in e.g. systemd-nspawn in some
+ # cases.
+ # https://github.com/libproxy/libproxy/issues/260 (bug #914382)
+ local -x GIO_USE_NETWORK_MONITOR=base
dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
}