summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/librsync/Manifest1
-rw-r--r--net-libs/librsync/librsync-2.3.4.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/net-libs/librsync/Manifest b/net-libs/librsync/Manifest
index efe932cfa246..90a4cb68b6c3 100644
--- a/net-libs/librsync/Manifest
+++ b/net-libs/librsync/Manifest
@@ -1 +1,2 @@
DIST librsync-2.3.2.tar.gz 194461 BLAKE2B 72f55c3809c35ee4eff4af03776aed6acfc33cf6109ea8e7fc5cdb4c3919e8f69f156d17ace4443bbb520cbdbe5220df7b5059f00173298839cbb86e0df491c7 SHA512 77d826dbaf02061b759d876a6b537238bad40379a08e4494ebfd3e380b2eb921b7b060bc570330aeac9424ef1a9d521f449d559c9ffa3be24acdef4ad530fe90
+DIST librsync-2.3.4.tar.gz 201307 BLAKE2B eb1f2cde347a6314f1dbcc72f326cd542005458294413bf473478c5665b4090b5ee133ab1059dcea932e41d57202795a057f52206ec3363b5d611ea1792079a8 SHA512 ac01413b875e774db9fec3888210a4b9a5f3d32c081f1ed5f2cf9dc29cfae6ecedf6eac42062631e6dcf188853313fce4520430549768a0f68993419b07e58d9
diff --git a/net-libs/librsync/librsync-2.3.4.ebuild b/net-libs/librsync/librsync-2.3.4.ebuild
new file mode 100644
index 000000000000..1a3139b85484
--- /dev/null
+++ b/net-libs/librsync/librsync-2.3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Remote delta-compression library"
+HOMEPAGE="https://librsync.github.io/"
+SRC_URI="https://github.com/librsync/librsync/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_LIBB2=OFF
+ )
+
+ cmake_src_configure
+}