summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ncp/files/ncp-1.2.4-fix-makefile.patch16
-rw-r--r--net-misc/ncp/metadata.xml1
-rw-r--r--net-misc/ncp/ncp-1.2.4-r2.ebuild40
3 files changed, 56 insertions, 1 deletions
diff --git a/net-misc/ncp/files/ncp-1.2.4-fix-makefile.patch b/net-misc/ncp/files/ncp-1.2.4-fix-makefile.patch
new file mode 100644
index 000000000000..54608a665417
--- /dev/null
+++ b/net-misc/ncp/files/ncp-1.2.4-fix-makefile.patch
@@ -0,0 +1,16 @@
+Never strip executable
+
+Patch by Michael Mair-Keimberger
+
+--- ncp-1.2.4/GNUmakefile 2005-05-13 19:17:17.000000000 +0200
++++ ncp-1.2.4-ng/GNUmakefile 2020-09-04 20:08:50.399902892 +0200
+@@ -53,9 +53,6 @@
+
+ ncp: ncp.o libsocket
+ $(CC) $< -o $@ -I. $(CFLAGS) $(LDFLAGS) $(LDLIBS) `cat libsocket`
+-ifeq ($(DEBUG),)
+- strip -R .note -R .comment ncp || strip ncp
+-endif
+
+ install:
+ install -d $(PREFIX)/bin $(PREFIX)/man/man1
diff --git a/net-misc/ncp/metadata.xml b/net-misc/ncp/metadata.xml
index 874363d1925d..17fb58cb0b1f 100644
--- a/net-misc/ncp/metadata.xml
+++ b/net-misc/ncp/metadata.xml
@@ -12,5 +12,4 @@
<longdescription lang="en">
"ncp" is a utility for copying files in a LAN. It has absolutely no security or integrity checking, no throttling, no features, except one: you don't have to type the coordinates of your peer.
</longdescription>
- <use><flag name="diet">Compile against <pkg>dev-libs/dietlibc</pkg></flag></use>
</pkgmetadata>
diff --git a/net-misc/ncp/ncp-1.2.4-r2.ebuild b/net-misc/ncp/ncp-1.2.4-r2.ebuild
new file mode 100644
index 000000000000..cb6d5545c438
--- /dev/null
+++ b/net-misc/ncp/ncp-1.2.4-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility for copying files in a LAN (npoll, npush)"
+HOMEPAGE="https://www.fefe.de/ncp/"
+SRC_URI="https://dl.fefe.de/${P}.tar.bz2"
+
+LICENSE="public-domain" # mail from author, bug 446540
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-libs/libowfat-0.28-r1[-diet]"
+
+PATCHES=( "${FILESDIR}/${P}-fix-makefile.patch" )
+
+src_prepare() {
+ default
+ rm Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I/usr/include/libowfat" \
+ LDFLAGS="${LDFLAGS}" \
+ STRIP="#"
+}
+
+src_install() {
+ dobin ${PN}
+ dosym ${PN} /usr/bin/npoll
+ dosym ${PN} /usr/bin/npush
+
+ doman ncp.1 npush.1
+ dodoc NEWS
+}