summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/paludis')
-rw-r--r--sys-apps/paludis/Manifest1
-rw-r--r--sys-apps/paludis/paludis-2.6.0.ebuild150
2 files changed, 0 insertions, 151 deletions
diff --git a/sys-apps/paludis/Manifest b/sys-apps/paludis/Manifest
index d4c05d5298da..0221a358b5e9 100644
--- a/sys-apps/paludis/Manifest
+++ b/sys-apps/paludis/Manifest
@@ -1,2 +1 @@
-DIST paludis-2.6.0.tar.bz2 1885055 BLAKE2B 55c979b0cf357be62093e7f7f774786843dc441cee8011663218550b43636b614b348f1979cd89c9e571e8439b0493e8e2399a0990c370eac765c48a61126dc1 SHA512 78a9c0a19703dbbc07934de389b749ab83365454e29b19c323d6c03304162e35ff4d92f7ac1f28067ad853057f2422be43418b3c6a57a193c4b8dd5a4e81eba4
DIST paludis-f8e58ee1d02d2476ae92ebc3737e42b8b6a36891.tar.xz 1004024 BLAKE2B 1c34c93815efa41298cc2916c4428971d1f54242cfd759c771972bdcde94986c6af03546372c7eda277a343851b38ee93c0a103e519457b42e48cc7bed87b755 SHA512 813592b6f164d7994000ff1740e003049e040e7d58832bb1393a1f4facf428806b57bbf97855b830f75acf4b20e963093e9993b110f76f44e25afb9a8a1eaa1e
diff --git a/sys-apps/paludis/paludis-2.6.0.ebuild b/sys-apps/paludis/paludis-2.6.0.ebuild
deleted file mode 100644
index 3b42a102df75..000000000000
--- a/sys-apps/paludis/paludis-2.6.0.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-# matching profile defaults for now
-RUBY_VER=2.2
-
-inherit bash-completion-r1 eutils python-single-r1 user
-
-DESCRIPTION="paludis, the other package mangler"
-HOMEPAGE="http://paludis.exherbo.org/"
-SRC_URI="http://paludis.exherbo.org/download/${P}.tar.bz2"
-
-IUSE="doc pbins pink python ruby ruby_targets_ruby${RUBY_VER/./} search-index test +xml"
-LICENSE="GPL-2 vim"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
-
-COMMON_DEPEND="
- >=app-admin/eselect-1.2.13
- >=app-shells/bash-3.2:0
- dev-libs/libpcre[cxx]
- sys-apps/file
- pbins? ( >=app-arch/libarchive-3.1.2 )
- python? (
- ${PYTHON_DEPS}
- <dev-libs/boost-1.63[python,${PYTHON_USEDEP}] )
- ruby? ( dev-lang/ruby:${RUBY_VER} )
- search-index? ( >=dev-db/sqlite-3 )
- xml? ( >=dev-libs/libxml2-2.6 )"
-
-DEPEND="${COMMON_DEPEND}
- >=app-text/asciidoc-8.6.3
- app-text/htmltidy
- app-text/xmlto
- >=sys-devel/gcc-4.7
- doc? (
- app-doc/doxygen
- python? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- ruby? ( dev-ruby/syntax[ruby_targets_ruby${RUBY_VER/./}] )
- )
- virtual/pkgconfig
- test? ( >=dev-cpp/gtest-1.6.0-r1 )"
-
-RDEPEND="${COMMON_DEPEND}
- sys-apps/sandbox"
-
-PDEPEND="app-eselect/eselect-package-manager"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
- ruby? ( ruby_targets_ruby${RUBY_VER/./} )"
-RESTRICT="!test? ( test )"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != buildonly ]]; then
- if id paludisbuild >/dev/null 2>/dev/null ; then
- if ! groups paludisbuild | grep --quiet '\<tty\>' ; then
- eerror "The 'paludisbuild' user is now expected to be a member of the"
- eerror "'tty' group. You should add the user to this group before"
- eerror "upgrading Paludis."
- die "Please add paludisbuild to tty group"
- fi
- fi
- fi
-}
-
-pkg_setup() {
- enewgroup "paludisbuild"
- enewuser "paludisbuild" -1 -1 "/var/tmp/paludis" "paludisbuild,tty"
-
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # Fix the script shebang on Ruby scripts.
- # https://bugs.gentoo.org/show_bug.cgi?id=439372#c2
- sed -i -e "1s/ruby/&${RUBY_VER/./}/" ruby/demos/*.rb || die
-
- epatch_user
-}
-
-src_configure() {
- local myconf=(
- --htmldir=/usr/share/doc/${PF}/html
-
- $(use_enable doc doxygen)
- $(use_enable test gtest)
- $(use_enable pbins)
- $(use_enable pink)
- $(use_enable python)
- $(use python && use_enable doc python-doc)
- $(use_enable ruby)
- $(use ruby && use_enable doc ruby-doc)
- --with-ruby-version="${RUBY_VER}"
- $(use_enable search-index)
- $(use_enable xml)
-
- --enable-vim
- --with-config-framework=eselect
- --with-environments=default,portage
- --with-vim-install-dir=/usr/share/vim/vimfiles
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- prune_libtool_files
-
- dobashcomp bash-completion/cave
-
- insinto /usr/share/zsh/site-functions
- doins zsh-completion/_cave
-}
-
-src_test() {
- # Work around Portage bugs
- local -x PALUDIS_DO_NOTHING_SANDBOXY="portage sucks"
- local -x BASH_ENV=/dev/null
-
- if [[ ${EUID} == 0 ]] ; then
- # hate
- local -x PALUDIS_REDUCED_UID=0
- local -x PALUDIS_REDUCED_GID=0
- fi
-
- if ! nonfatal emake -k check ; then
- eerror "Tests failed. Looking for files for you to add to your bug report..."
- find "${S}" -type f -name '*.epicfail' -or -name '*.log' | while read a ; do
- eerror " $a"
- done
- die "Make check failed"
- fi
-}
-
-pkg_postinst() {
- local pm
- if [[ -f ${ROOT}/etc/env.d/50package-manager ]] ; then
- pm=$( source "${ROOT}"/etc/env.d/50package-manager ; echo "${PACKAGE_MANAGER}" )
- fi
-
- if [[ ${pm} != paludis ]] ; then
- elog "If you are using paludis or cave as your primary package manager,"
- elog "you should consider running:"
- elog " eselect package-manager set paludis"
- fi
-}