summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
index f47e1b24c1e0..4c6ac9a06cb9 100644
--- a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
+++ b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
@@ -186,8 +186,9 @@ src_install() {
src_test() {
# 'meson test' will compile full systemd, but we can still outsmart it
+ python_fix_shebang src/test/test-systemd-tmpfiles.py
"${EPYTHON}" src/test/test-systemd-tmpfiles.py \
- "${BUILD_DIR}"/systemd-tmpfiles.standalone || die
+ "${BUILD_DIR}"/systemd-tmpfiles.standalone || die "${FUNCNAME} failed"
}
# adapted from opentmpfiles ebuild