summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild31
1 files changed, 17 insertions, 14 deletions
diff --git a/sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild b/sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild
index e42d81c1d8d8..9d5b1a167818 100644
--- a/sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild
+++ b/sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit flag-o-matic linux-info toolchain-funcs udev
DEB_REV=${PV#*_p}
@@ -11,6 +12,7 @@ DESCRIPTION="PCMCIA userspace utilities for Linux"
HOMEPAGE="https://packages.qa.debian.org/pcmciautils"
SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}.orig.tar.gz
mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}-${DEB_REV}.debian.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
LICENSE="GPL-2"
SLOT="0"
@@ -22,8 +24,6 @@ DEPEND="${RDEPEND}
virtual/yacc
sys-devel/flex"
-S=${WORKDIR}/${PN}-${MY_PV}
-
PATCHES=(
"${WORKDIR}"/debian/patches/no-modprobe-rules.patch
"${WORKDIR}"/debian/patches/remove-libsysfs-dep.patch
@@ -36,6 +36,19 @@ pkg_setup() {
linux-info_pkg_setup
kernel_is lt 2 6 32 && ewarn "${P} requires at least kernel 2.6.32."
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/CFLAGS/s:-fomit-frame-pointer::' \
+ -e '/dir/s:sbin:bin:g' \
+ Makefile || die
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUG
mypcmciaopts=(
STARTUP=$(usex staticsocket false true)
@@ -51,17 +64,7 @@ pkg_setup() {
STRIP=true
RANLIB="$(tc-getRANLIB)"
OPTIMIZATION="${CFLAGS} ${CPPFLAGS}"
- )
-
- use debug && append-cppflags -DDEBUG
-}
-
-src_prepare() {
- default
- sed -i \
- -e '/CFLAGS/s:-fomit-frame-pointer::' \
- -e '/dir/s:sbin:bin:g' \
- Makefile || die
+ )
}
src_compile() {