summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/chgres/chgres-0.1-r3.ebuild (renamed from x11-misc/chgres/chgres-0.1-r2.ebuild)21
1 files changed, 11 insertions, 10 deletions
diff --git a/x11-misc/chgres/chgres-0.1-r2.ebuild b/x11-misc/chgres/chgres-0.1-r3.ebuild
index 34ce121d6578..f3da79feafe0 100644
--- a/x11-misc/chgres/chgres-0.1-r2.ebuild
+++ b/x11-misc/chgres/chgres-0.1-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -12,21 +12,22 @@ SRC_URI="http://hpwww.ec-lyon.fr/~vincent/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXxf86dga
x11-libs/libXext
x11-libs/libXxf86vm"
DEPEND="${RDEPEND}
- x11-base/xorg-proto
- virtual/pkgconfig
-"
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/${P}-{flags,includes}.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-includes.patch
+)
-src_prepare() {
- default
+src_configure() {
tc-export CC PKG_CONFIG
}