summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/papirus-icon-theme')
-rw-r--r--x11-themes/papirus-icon-theme/Manifest1
-rw-r--r--x11-themes/papirus-icon-theme/papirus-icon-theme-20211201.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/x11-themes/papirus-icon-theme/Manifest b/x11-themes/papirus-icon-theme/Manifest
index 58058e033b00..e04e12eca000 100644
--- a/x11-themes/papirus-icon-theme/Manifest
+++ b/x11-themes/papirus-icon-theme/Manifest
@@ -1,2 +1,3 @@
DIST papirus-icon-theme-20210701.tar.gz 28129228 BLAKE2B cb4b8891607bfa2b245858c746e590d4a1aca973037669268be682a06ada5074e298666a1d9a9ee9ce66be92778fcf34d3cf306c9864332ea7ebc25f52568f30 SHA512 0ec131bac6a0804d0a61d0c01c30d8d55f4438e93e17849a5c3cb741c4d8aa050977b24101d7f33416a7d617b53c5dca28ce38316e52bd5f72d9034147983d4d
DIST papirus-icon-theme-20211101.tar.gz 30284589 BLAKE2B ce54660b6bb20b0f6ab22d6969e0611d2ff54130384f13de4707093c9ccafcdc8f857a5202a1478afa1ba2f58981203dcaffb18f999cee8fa232e3c9ef492a95 SHA512 13b8e0624d1cb0a39f5dbb407682766de942a31a19b683ca1429dc9c97b4f236e070176f1a5e6f37893d0587276d37c6b8e3cee2bea72bf535598ea84704f717
+DIST papirus-icon-theme-20211201.tar.gz 30608183 BLAKE2B 1af77049995fdbc4acfbf72df706faaae507cb1c07624993073bbcf053bad8fd8eaae7fc2e228b57919e3bac041a0056fae6a1cf693040459d72c3285b7725ad SHA512 746055e9db0ef11c996fd90892582ca5ffd3e7c77aa08a43de2dd162364e915c73b3e1ab139c8caa4295e0857b4b5a6e273606f41ae5ab91de9dd160598ec621
diff --git a/x11-themes/papirus-icon-theme/papirus-icon-theme-20211201.ebuild b/x11-themes/papirus-icon-theme/papirus-icon-theme-20211201.ebuild
new file mode 100644
index 000000000000..a66cddd5ee03
--- /dev/null
+++ b/x11-themes/papirus-icon-theme/papirus-icon-theme-20211201.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="Free and open source SVG icon theme"
+HOMEPAGE="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
+SRC_URI="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r Papirus{,-Dark,-Light}
+
+ # Install variants designed for elementary OS and Pantheon Desktop only
+ doins -r ePapirus{,-Dark}
+}