From c2573e676b89e938cd1a516c23d5e8e30da0509b Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Sat, 21 Oct 2023 05:28:50 +0200
Subject: dev-python/sqlglot: Bump to 18.16.0
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-python/sqlglot/Manifest               |  1 +
 dev-python/sqlglot/sqlglot-18.16.0.ebuild | 36 +++++++++++++++++++++++++++++++
 2 files changed, 37 insertions(+)
 create mode 100644 dev-python/sqlglot/sqlglot-18.16.0.ebuild

(limited to 'dev-python')

diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index e18f33070051..5c093df431b4 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -3,3 +3,4 @@ DIST sqlglot-18.13.0.tar.gz 8873766 BLAKE2B 4dfe6d3d6332bedf13229d2820a12ead44ff
 DIST sqlglot-18.14.0.tar.gz 8880297 BLAKE2B f5036816e165ca8f6d65ed21db618b216444578b5a0d403f4674d878a02fae6d9dfc5ce67cef3398d040f4cc44eaff7e5f62bcb1521f244a1fa5b9b127dd666a SHA512 1da34636a92238c0cf67230da3fb5551bd6b9e2a252f252e8fdb0a0b237c7bea2435ecd2852f66a4427628445b25ffe78cd86b46f3939a798612f72efd884148
 DIST sqlglot-18.15.0.tar.gz 8888074 BLAKE2B 22082ddd15eb6245c05495b4202e9fab5d3ab1085cc74139a5ba3f909fbde1487e2cd9501bb218efe9e72748e8b2f7d04a247e357c27e6a9027169b809fe7136 SHA512 25df8fdf1ba2e2022ed82ba7d7a6f2c861b96cc5e440bf23488b75f861ee93504ad1d706cd88cdb74a652070c328abe52e4790cc4020059f27129720c0fa4be8
 DIST sqlglot-18.15.1.tar.gz 8895777 BLAKE2B 7aa5d7269c2e9d17ed68130d0129cc0a5abcd101a28ce5b85f5636dfa215934309cf7bf2d56ab6c2a819fe1a6128cd33355b39b29f76db32f84ea88034098502 SHA512 487646147ed2084c54e93326ba8df0225ae26e780e1ed3375f3eb2fc7fc6c82f0a4bf41a1967ce7719df1bd92b09b0fc175cd70659fe692507b6bfc4eafe6791
+DIST sqlglot-18.16.0.tar.gz 8929202 BLAKE2B e47a86345eb3ff2422d45171fddda2ebe9994b5749bb91293253d83874df64f5e1d494c78c359c7c46b5f0b95d4bfe89b06fd0deb3a4d75cf379c3f98e8ae03f SHA512 b98837e947c75cdca2034bf09ee0474e908c8d69d5f5e8306381967b7e8d8b3a7e8d4027bbd436eae328d856abdbef7121a117f8486a949f0129fd3e06d6f87a
diff --git a/dev-python/sqlglot/sqlglot-18.16.0.ebuild b/dev-python/sqlglot/sqlglot-18.16.0.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-18.16.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+	https://sqlglot.com/
+	https://github.com/tobymao/sqlglot/
+	https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+	# Tests require pyspark or duckdb which aren't in the tree.
+	# Pandas would be a requirement normally, but it gets ignored by proxy.
+	"tests/dataframe/integration/test_dataframe.py"
+	"tests/dataframe/integration/test_grouped_data.py"
+	"tests/dataframe/integration/test_session.py"
+	"tests/test_executor.py"
+	"tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+	optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}
-- 
cgit v1.2.3-65-gdbad