From ca4eb0acc50c0bf41f1c5526b7b515df34e41258 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Sat, 14 Sep 2019 15:05:32 +0200
Subject: media-gfx/graphviz: Inline myconf comments

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
---
 media-gfx/graphviz/graphviz-2.42.1.ebuild | 35 +++++++++++--------------------
 1 file changed, 12 insertions(+), 23 deletions(-)

(limited to 'media-gfx')

diff --git a/media-gfx/graphviz/graphviz-2.42.1.ebuild b/media-gfx/graphviz/graphviz-2.42.1.ebuild
index 6a0e38d17e8a..a26f2b5c6df4 100644
--- a/media-gfx/graphviz/graphviz-2.42.1.ebuild
+++ b/media-gfx/graphviz/graphviz-2.42.1.ebuild
@@ -187,14 +187,6 @@ src_prepare() {
 src_configure() {
 	local myconf=(
 		--enable-ltdl
-		--disable-silent-rules
-		$(use_enable static-libs static)
-	)
-
-	# libtool file collision, bug 276609
-	myconf+=( --without-included-ltdl --disable-ltdl-install )
-
-	myconf+=(
 		$(use_with cairo pangocairo)
 		$(use_with devil)
 		$(use_enable gdk-pixbuf)
@@ -204,6 +196,7 @@ src_configure() {
 		$(use_with lasi)
 		$(use_with pdf poppler)
 		$(use_with postscript ghostscript)
+		$(use_enable static-libs static)
 		$(use_with svg rsvg)
 		$(use_with X x)
 		$(use_with X xaw)
@@ -215,35 +208,31 @@ src_configure() {
 		--with-libgd
 		--with-sfdp
 		--without-ming
-	)
-
-	# new/experimental features, to be tested, disable for now
-	myconf+=(
+		# new/experimental features, to be tested, disable for now
 		--with-cgraph
 		--without-glitz
 		--without-ipsepcola
 		--without-smyrna
 		--without-visio
-	)
-
-	# Bindings:
-	myconf+=(
+		# Bindings:
 		$(use_enable guile)
-		--disable-io
 		$(use_enable java)
+		$(use_enable perl)
+		$(use_enable python python2)
+		$(use_enable python python3)
+		$(use_enable ruby)
+		$(use_enable tcl)
+		--disable-io
 		--disable-lua
 		--disable-ocaml
-		$(use_enable perl)
 		--disable-php
 		--disable-python
-		$(use_enable python python2)
-		$(use_enable python python3)
 		--disable-r
-		$(use_enable ruby)
 		--disable-sharp
-		$(use_enable tcl)
+		# libtool file collision, bug #276609
+		--without-included-ltdl
+		--disable-ltdl-install
 	)
-
 	econf "${myconf[@]}"
 }
 
-- 
cgit v1.2.3-65-gdbad