From e2e04946ba31485ac196377edde9acb53d55d8e3 Mon Sep 17 00:00:00 2001
From: Zero_Chaos <zerochaos@gentoo.org>
Date: Fri, 6 Jul 2018 10:32:43 -0400
Subject: net-wireless/lorcon: bug #660494

whoops, re-add stable version

Package-Manager: Portage-2.3.41, Repoman-2.3.9
RepoMan-Options: --force
---
 net-wireless/lorcon/Manifest                    |  1 +
 net-wireless/lorcon/lorcon-0.0_p20150109.ebuild | 73 +++++++++++++++++++++++++
 2 files changed, 74 insertions(+)
 create mode 100644 net-wireless/lorcon/lorcon-0.0_p20150109.ebuild

(limited to 'net-wireless')

diff --git a/net-wireless/lorcon/Manifest b/net-wireless/lorcon/Manifest
index 94c11c88bc68..9b556bcf1876 100644
--- a/net-wireless/lorcon/Manifest
+++ b/net-wireless/lorcon/Manifest
@@ -1 +1,2 @@
+DIST lorcon-0.0_p20150109.tar.xz 259788 BLAKE2B e3bd188642f7ef49fa3b7361bd659fdd47d6449598b5248412ad3d8e85e5d0b9c0f8d73fdcd3d0822f19a0d069bf0eeb832bed7bb38c418970d617c03387d1ce SHA512 acbd88477317475ca8555d579a1483ea5e5d9eac0f86ef7bde2592e007025070ca56c6cd43e814560e28165ac7b40bd86f2703a466faeca1619b8373dc2b625b
 DIST lorcon-0.0_p20180409.tar.gz 506177 BLAKE2B d4bea3e91ce506c6ba56221b4fc2e25ffd5ba979b905e66166c570adefc513ca51229fab5706276dbbd1bea68ee2c2802adf4eeefb1e5f0c593fada6cb39ab51 SHA512 7273b68fa4aa7418d9bab8b4651b93e315b9ea55657efa7d14ef444fda7e0e036267d319cda6676951e54b661391a77cc848778f859249a50847d33dac0b8ea9
diff --git a/net-wireless/lorcon/lorcon-0.0_p20150109.ebuild b/net-wireless/lorcon/lorcon-0.0_p20150109.ebuild
new file mode 100644
index 000000000000..702bd34a3a2d
--- /dev/null
+++ b/net-wireless/lorcon/lorcon-0.0_p20150109.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A generic library for injecting 802.11 frames"
+HOMEPAGE="http://802.11ninja.net/lorcon"
+
+if [[ ${PV} == "9999" ]] ; then
+	EGIT_REPO_URI="https://code.google.com/p/lorcon/"
+	inherit git-r3
+	KEYWORDS=""
+else
+	SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+	KEYWORDS="amd64 arm ppc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="python"
+
+DEPEND="
+	python? ( ${PYTHON_DEPS} )
+	dev-libs/libnl:3=
+	net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}"/${P}
+
+src_unpack() {
+	if [[ ${PV} == "9999" ]] ; then
+		git-r3_src_unpack
+		cp -R "${S}/" "${WORKDIR}/all"
+	fi
+	default_src_unpack
+}
+
+src_prepare() {
+	sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' pylorcon2/PyLorcon2.c
+	use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+	default_src_configure
+}
+
+src_compile() {
+	default_src_compile
+	if use python; then
+		LDFLAGS+=" -L${S}/.libs/"
+		cd pylorcon2 || die
+		distutils-r1_src_compile
+	fi
+}
+
+src_install() {
+	emake DESTDIR="${ED}" install
+	if use python; then
+		cd pylorcon2 || die
+		distutils-r1_src_install
+	fi
+}
+
+src_test() {
+	:
+}
-- 
cgit v1.2.3-65-gdbad