From 6d1c8f4c4581ae6ebdabdd5615745c646910d062 Mon Sep 17 00:00:00 2001
From: William Breathitt Gray <vilhelm.gray@gmail.com>
Date: Thu, 8 Aug 2019 12:37:15 +0900
Subject: sys-devel/ucpp: Bump to version 1.3.5

Closes: https://bugs.gentoo.org/691656
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12640
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
---
 sys-devel/ucpp/Manifest          |  1 +
 sys-devel/ucpp/ucpp-1.3.5.ebuild | 26 ++++++++++++++++++++++++++
 2 files changed, 27 insertions(+)
 create mode 100644 sys-devel/ucpp/ucpp-1.3.5.ebuild

(limited to 'sys-devel')

diff --git a/sys-devel/ucpp/Manifest b/sys-devel/ucpp/Manifest
index 98decdb51e00..d8c1bac0241b 100644
--- a/sys-devel/ucpp/Manifest
+++ b/sys-devel/ucpp/Manifest
@@ -1 +1,2 @@
 DIST ucpp-1.3.4.tar.xz 274488 BLAKE2B be43b8c88de2cd32514ecf7dc429c0ca5e88150594c9868fd6d8c3d90a0aabfc6e0f0741d75e4f558de426df7d6c54a3bc7e8e362c5066672f5fe9096cbedc18 SHA512 f9ea88e8f53e728a5b0fcb9084d6d6e140737b00fe350a9c6bc53ef2bb5f7b09d3c9d9a4a2147f635d796247e1b920fd3fea0cdce3ec3f4578694162c2f4c2a6
+DIST ucpp-1.3.5.tar.xz 289468 BLAKE2B 6a038cc5d02f080747a321a55af66f2072503a5c0a554492ea8aed34ff9c3b7b85e3778114e18c3e09f06f1472a1479f39c96997404e0345153a1f84e3f9daee SHA512 3ded8f7bc2b238adb6e7f4162aee48e039dfe7cee31b700c38e8f147634d47cd1ceaf39c343549b0d4a58358e6b9743f7e84f87b253dc19c05e543d68ade24ce
diff --git a/sys-devel/ucpp/ucpp-1.3.5.ebuild b/sys-devel/ucpp/ucpp-1.3.5.ebuild
new file mode 100644
index 000000000000..6382f1c7fa33
--- /dev/null
+++ b/sys-devel/ucpp/ucpp-1.3.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A C preprocessor compliant to ISO-C99"
+HOMEPAGE="https://gitlab.com/scarabeusiv/ucpp"
+SRC_URI="https://gitlab.com/scarabeusiv/${PN}/uploads/79f08e39c676f15ed8a59335f6c9b924/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE="static-libs"
+
+src_configure() {
+	econf \
+		--disable-werror \
+		$(use_enable static-libs static)
+}
+
+src_install() {
+	default
+
+	# package provides .pc files
+	find "${D}" -name '*.la' -delete || die
+}
-- 
cgit v1.2.3-65-gdbad