From be9b45a4ed86180b62b386281dc59f3b20e410db Mon Sep 17 00:00:00 2001
From: "Jorge Manuel B. S. Vicetto (jmbsvicetto)" <jmbsvicetto@gentoo.org>
Date: Sun, 22 May 2016 22:31:33 +0000
Subject: www-apps/drupal: Add 8.1.0 and 8.1.1 releases.

Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
---
 www-apps/drupal/Manifest            |  3 +-
 www-apps/drupal/drupal-8.1.0.ebuild | 87 +++++++++++++++++++++++++++++++++++++
 www-apps/drupal/drupal-8.1.1.ebuild | 87 +++++++++++++++++++++++++++++++++++++
 3 files changed, 176 insertions(+), 1 deletion(-)
 create mode 100644 www-apps/drupal/drupal-8.1.0.ebuild
 create mode 100644 www-apps/drupal/drupal-8.1.1.ebuild

(limited to 'www-apps/drupal')

diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 99e2c499c3ac..54d4410b1e20 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,4 +1,5 @@
 DIST drupal-6.38.tar.gz 1113790 SHA256 46a6d7ec170e74f3c85b11fdf0fae74ce0691d4260b848bf5faff1f0f5f31d4b SHA512 ad8b0e04c15afa6e5b5f7d60478c7ac7f6123cd0735424588a4266a987d13df96d8349a8674bcdbcfc437a63847269477a6c836660b7dd990dbb1b844809ce14 WHIRLPOOL 87df66cb65bd9c97356f54d9ede14a6bec41aed49cdb5ae0f504077ce14f03cecb03ace863492c765c3b3837d8aa84c12bf11ed3ebf874afac1b69c21d31661b
 DIST drupal-7.43.tar.gz 3265824 SHA256 468c1e5864ad6a86e760108f0cb0eac6bf004a198c49e77117b99af31e31b16a SHA512 442348a8331788543750263437a2055308f4e45d5fa740c2578893e432878696de07956f0d76545aad4b1baf7bc463a08a620e3e5e29bf1f01ca90e6e62255e6 WHIRLPOOL c79f2bcb086544acfa1d69f54e52dbe39f5a9196156be7dc7258953bcd12af13c0640b9327fc85d1ee1603a0a269a2796626e3a1c21758937f6ae89bc45bb158
 DIST drupal-8.0.6.tar.gz 11782652 SHA256 4aa4310d5e6e7d8a932b158379f27ac226cd43d01bde71d4cc3229a491992baa SHA512 99b1192eb85e04ca14d8929dbea1cb658542027efa7f2a8c67a0572a2f6266ada375f700d176c6b6c858062fb1845fd0991e76c54929a2ca41a336f38cf0b492 WHIRLPOOL 07b3b09b272f404123733710738418eded39ea10a5afcbc39659c6eab5550deaa18b0d9f33be33cf1647fe47f36af905c5f5ade02ce031f81bfb23e543775a68
-DIST drupal-8.1.0-rc1.tar.gz 12459083 SHA256 df9742b45d7967061b8807be7ee2eb697c2401216ff7dd6400ae1ba394d96379 SHA512 572b9ca573323e490fe41dbfa5d1d82029b16ae8cf82c5f6ce981dd3d5c9a9381523446a64cc09bb1f16c164facb3f587a2c48d5d903856ea9e6da71f0f6ecab WHIRLPOOL 835a525e41d18c0dc916bfc0769316f156f047e6b5cbb14a18ca30451e68b6daaca419990cdd5b0b6c37caa22367d8b9ae3dc2766533726ed90552d578d4d357
+DIST drupal-8.1.0.tar.gz 12520120 SHA256 83b4b6d7adc7b0aaccc4f8fe7688dee0a773eaa95668b2aad8352a1a6eff3e55 SHA512 8071471d3e43590ddef09e664290d0ac2f6e8ce57054adfa2d76459569bbb6d89684bafc5d2618ec28859d240a4d8ebd0c7e0b4d52ec79a39fd174cfcca90144 WHIRLPOOL 072dfecf1ce94870f2b59ea9db719759419e71b5eaa671b98f1fe70e61af6c817b7a0d146ecf33c5a0ada024f0de690fcdbcf157f9569f5ad8dbec125294158b
+DIST drupal-8.1.1.tar.gz 12533960 SHA256 2d6644fcaa086a320cba0ba21473fbd1f8a21ceb27f91cf178df6fdb4a37ceab SHA512 1ab4b7a0a8a5049fa51eb1d529c0d286f81d650d7bd336b2c99e1ef0fd2e4a769d15316a5ce49df1359281a1caf3421a4d2a8c3a15573a361c6859aead25361e WHIRLPOOL d0daafa23338bb2b715e4937df4ea41813d9c8d56e51d4778bcd9fc4a49edae1d3bc6df3b6b0db2ffe8b81a7efd9df1ea344c02b41a0f70f3589181dc8bb31cf
diff --git a/www-apps/drupal/drupal-8.1.0.ebuild b/www-apps/drupal/drupal-8.1.0.ebuild
new file mode 100644
index 000000000000..0eab0019504f
--- /dev/null
+++ b/www-apps/drupal/drupal-8.1.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+	dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+	virtual/httpd-php
+	accelerator? ( ||
+		(
+			dev-php/xcache
+			(
+				>=dev-lang/php-5.5[opcache]
+				dev-php/pecl-apcu
+			)
+		)
+	)
+	uploadprogress? ( dev-php/pecl-uploadprogress )
+	mysql? (
+		|| (
+			dev-lang/php[mysql]
+			dev-lang/php[mysqli]
+		)
+	)
+	sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+	webapp_src_preinst
+
+	local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+		core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+	dodoc ${docs}
+	rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+	cp sites/default/{default.settings.php,settings.php} || die
+	insinto "${MY_HTDOCSDIR}"
+	doins -r .
+
+	dodir "${MY_HTDOCSDIR}"/files
+	webapp_serverowned "${MY_HTDOCSDIR}"/files
+	webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+	webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+	webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+	webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+	webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+	webapp_src_install
+}
+
+pkg_postinst() {
+	echo
+	ewarn "SECURITY NOTICE"
+	ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+	ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+	echo
+	ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+	ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+	echo
+	ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+	ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+	ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+	ewarn "reported by the setup."
+	echo
+}
diff --git a/www-apps/drupal/drupal-8.1.1.ebuild b/www-apps/drupal/drupal-8.1.1.ebuild
new file mode 100644
index 000000000000..0eab0019504f
--- /dev/null
+++ b/www-apps/drupal/drupal-8.1.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+	dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+	virtual/httpd-php
+	accelerator? ( ||
+		(
+			dev-php/xcache
+			(
+				>=dev-lang/php-5.5[opcache]
+				dev-php/pecl-apcu
+			)
+		)
+	)
+	uploadprogress? ( dev-php/pecl-uploadprogress )
+	mysql? (
+		|| (
+			dev-lang/php[mysql]
+			dev-lang/php[mysqli]
+		)
+	)
+	sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+	webapp_src_preinst
+
+	local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+		core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+	dodoc ${docs}
+	rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+	cp sites/default/{default.settings.php,settings.php} || die
+	insinto "${MY_HTDOCSDIR}"
+	doins -r .
+
+	dodir "${MY_HTDOCSDIR}"/files
+	webapp_serverowned "${MY_HTDOCSDIR}"/files
+	webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+	webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+	webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+	webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+	webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+	webapp_src_install
+}
+
+pkg_postinst() {
+	echo
+	ewarn "SECURITY NOTICE"
+	ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+	ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+	echo
+	ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+	ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+	echo
+	ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+	ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+	ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+	ewarn "reported by the setup."
+	echo
+}
-- 
cgit v1.2.3-65-gdbad