From 1d557df31533026ecba7c8c4b4a4fd8ee2d136a1 Mon Sep 17 00:00:00 2001
From: Thomas Bracht Laumann Jespersen <t@laumann.xyz>
Date: Wed, 23 Mar 2022 15:52:59 +0100
Subject: x11-plugins/gkrellm-leds: update EAPI 6 -> 8

Besides the EAPI bump, there's a bug for the referenced bug. The issue
seems to be simply a typo in src/Makefile.am resulting in a variable
@GK_LDFLAGS@ not being replaced appropriately.

Closes: https://bugs.gentoo.org/799176
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz>
Closes: https://github.com/gentoo/gentoo/pull/24729
Signed-off-by: Sam James <sam@gentoo.org>
---
 .../gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild      | 36 ++++++++++++++++++++++
 1 file changed, 36 insertions(+)
 create mode 100644 x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild

(limited to 'x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild')

diff --git a/x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild b/x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild
new file mode 100644
index 000000000000..fed6fcfc799b
--- /dev/null
+++ b/x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin autotools
+
+MY_P="${P/rellm-/}"
+
+DESCRIPTION="GKrellM2 plugin for monitoring keyboard LEDs"
+HOMEPAGE="http://heim.ifi.uio.no/~oyvinha/gkleds/"
+SRC_URI="http://heim.ifi.uio.no/~oyvinha/e107_files/downloads/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+	app-admin/gkrellm:2[X]
+	x11-libs/libXtst"
+DEPEND="${RDEPEND}
+	x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-r2-ldflags-typo.patch" )
+
+src_prepare() {
+	default
+	eautoreconf
+}
+
+src_configure() {
+	PLUGIN_SO=( src/.libs/gkleds$(get_modname) )
+	default
+}
-- 
cgit v1.2.3-65-gdbad