summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/joe/ChangeLog8
-rw-r--r--app-editors/joe/Manifest6
-rw-r--r--app-editors/joe/files/digest-joe-3.0-r1 (renamed from app-editors/joe/files/digest-joe-3.0)0
-rw-r--r--app-editors/joe/joe-3.0-r1.ebuild (renamed from app-editors/joe/joe-3.0.ebuild)21
4 files changed, 29 insertions, 6 deletions
diff --git a/app-editors/joe/ChangeLog b/app-editors/joe/ChangeLog
index c60aecdc3eca..6b5b56be76e8 100644
--- a/app-editors/joe/ChangeLog
+++ b/app-editors/joe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/joe
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.16 2004/04/23 22:18:54 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.17 2004/05/07 14:20:31 joker Exp $
+
+*joe-3.0-r1 (07 May 2004)
+
+ 07 May 2004; Christian Birchinger <joker@gentoo.org> joe-3.0-r1.ebuild:
+ Added minor config/manpage fix for bug #50271.
+ Display info about the new config file location.
*joe-3.0 (24 Apr 2004)
diff --git a/app-editors/joe/Manifest b/app-editors/joe/Manifest
index dd994318d91e..7c38818a76c1 100644
--- a/app-editors/joe/Manifest
+++ b/app-editors/joe/Manifest
@@ -1,9 +1,9 @@
-MD5 17880569d657c1497c30f49b36b80508 ChangeLog 2276
+MD5 b1d8c1a6bb4f77caf0ab8ca8e470b13d ChangeLog 2478
MD5 00633259847518bde188d48a0bb3ecd7 joe-2.9.5.ebuild 849
MD5 8adfaa8e8f0f139b4fce6316bff1f18d joe-2.9.8.ebuild 828
MD5 b4ab76dfa8ad207c491c059ecec6710f joe-2.9.8_pre1.ebuild 677
-MD5 ac4d92f95591bdeeaab6e4a8275a35a9 joe-3.0.ebuild 793
-MD5 8115b4ae2f2702a436c3008f32ae6ca4 files/digest-joe-3.0 59
+MD5 f3b4ec1903d9ea4bd61e47c7dba84344 joe-3.0-r1.ebuild 1234
MD5 2d0cff8feae94e95e4d345c184aedf2e files/digest-joe-2.9.5 58
MD5 d69aa486eb5c743045dd6323ceede7e3 files/digest-joe-2.9.8 61
MD5 26aed7d89377d2c69fa8915653718a0b files/digest-joe-2.9.8_pre1 63
+MD5 8115b4ae2f2702a436c3008f32ae6ca4 files/digest-joe-3.0-r1 59
diff --git a/app-editors/joe/files/digest-joe-3.0 b/app-editors/joe/files/digest-joe-3.0-r1
index c93bd5dd113f..c93bd5dd113f 100644
--- a/app-editors/joe/files/digest-joe-3.0
+++ b/app-editors/joe/files/digest-joe-3.0-r1
diff --git a/app-editors/joe/joe-3.0.ebuild b/app-editors/joe/joe-3.0-r1.ebuild
index 77480ccbda94..ea83cd80f1f9 100644
--- a/app-editors/joe/joe-3.0.ebuild
+++ b/app-editors/joe/joe-3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.0.ebuild,v 1.1 2004/04/23 22:18:54 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.0-r1.ebuild,v 1.1 2004/05/07 14:20:31 joker Exp $
IUSE=""
@@ -21,6 +21,16 @@ PROVIDE="virtual/editor"
# Bug 34609 (joe 2.9.8 editor seg-faults on 'find and replace' when compiled with -Os)
replace-flags "-Os" "-O2"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Fix bug #50271 (joe 3.0 documentation doesn't reflect new config file location)
+ for i in jmacsrc.in jpicorc.in jstarrc.in rjoerc.in joe.1.in
+ do
+ sed -e 's:@sysconfdir@/:@sysconfdir@/joe/:' -i ${i}
+ done
+}
+
src_compile() {
econf || die
make || die
@@ -28,5 +38,12 @@ src_compile() {
src_install() {
einstall || die
- dodoc COPYING INFO LIST README TODO VERSION
+ dodoc COPYING ChangeLog HINTS INFO LIST NEWS README README.cvs TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "Global configuration has been moved from /etc to /etc/joe."
+ einfo "You should move or remove your old configuration files."
+ echo
}