summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/tc2/tc2-0.5.6.ebuild')
-rw-r--r--dev-libs/tc2/tc2-0.5.6.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/tc2/tc2-0.5.6.ebuild b/dev-libs/tc2/tc2-0.5.6.ebuild
new file mode 100644
index 000000000000..438b36307dac
--- /dev/null
+++ b/dev-libs/tc2/tc2-0.5.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tc2/tc2-0.5.6.ebuild,v 1.1 2004/02/28 14:26:35 zypher Exp $
+
+IUSE="static debug"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TC2 is a library to simplify writing of modular programs."
+HOMEPAGE="http://tc2.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="OpenSoftware"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64 ~amd64"
+
+
+DEPEND=">=dev-libs/libtc-1.0.3"
+
+
+src_compile() {
+
+ local myconf
+ myconf="--with-gnu-ld"
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ use static && myconf="${myconf} --enable-static"
+
+ econf ${myconf} || die "configure failed"
+
+ make || die
+
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}