summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/bzr-explorer/bzr-explorer-1.3.0-r1.ebuild')
-rw-r--r--dev-vcs/bzr-explorer/bzr-explorer-1.3.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-vcs/bzr-explorer/bzr-explorer-1.3.0-r1.ebuild b/dev-vcs/bzr-explorer/bzr-explorer-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..42fb611e8c51
--- /dev/null
+++ b/dev-vcs/bzr-explorer/bzr-explorer-1.3.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr-explorer/bzr-explorer-1.3.0-r1.ebuild,v 1.1 2015/03/10 14:34:45 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+MY_PV=${PV/_beta/b}
+MY_PV=${MY_PV/_rc/rc}
+LPV=${MY_PV}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A high level interface to all commonly used Bazaar features"
+HOMEPAGE="https://launchpad.net/bzr-explorer"
+SRC_URI="http://launchpad.net/${PN}/1.3/${LPV}/+download/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+DEPEND=""
+RDEPEND=">=dev-vcs/bzr-2.5[${PYTHON_USEDEP}]
+ >=dev-vcs/qbzr-0.23[${PYTHON_USEDEP}]
+ gtk? ( dev-vcs/bzr-gtk[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}