summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kscd/kscd-3.5.1.ebuild')
-rw-r--r--kde-base/kscd/kscd-3.5.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-base/kscd/kscd-3.5.1.ebuild b/kde-base/kscd/kscd-3.5.1.ebuild
new file mode 100644
index 000000000000..7b42428484fe
--- /dev/null
+++ b/kde-base/kscd/kscd-3.5.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kscd/kscd-3.5.1.ebuild,v 1.1 2006/01/22 22:53:05 danarmak Exp $
+
+KMNAME=kdemultimedia
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE CD player"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+$(deprange $PV $MAXKDEVER kde-base/libkcddb)"
+
+KMCOPYLIB="libkcddb libkcddb"
+KMEXTRACTONLY="
+ mpeglib_artsplug/configure.in.in"
+
+KMCOMPILEONLY="libkcddb"
+
+src_compile() {
+ DO_NOT_COMPILE=libkcddb kde-meta_src_compile myconf configure
+ cd $S/libkcddb && make configbase.h
+ cd $S/libkcddb && make cdinfodialogbase.h
+ DO_NOT_COMPILE=libkcddb kde-meta_src_compile make
+}