summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/apt-cacher-ng/ChangeLog11
-rw-r--r--net-misc/apt-cacher-ng/Manifest18
-rw-r--r--net-misc/apt-cacher-ng/apt-cacher-ng-0.6.2.ebuild105
-rw-r--r--net-misc/apt-cacher-ng/files/confd2
-rw-r--r--net-misc/apt-cacher-ng/files/cron.daily15
-rw-r--r--net-misc/apt-cacher-ng/files/initd32
-rw-r--r--net-misc/apt-cacher-ng/files/logrotate15
-rw-r--r--net-misc/apt-cacher-ng/metadata.xml15
8 files changed, 213 insertions, 0 deletions
diff --git a/net-misc/apt-cacher-ng/ChangeLog b/net-misc/apt-cacher-ng/ChangeLog
new file mode 100644
index 000000000000..06da8d7f9d4f
--- /dev/null
+++ b/net-misc/apt-cacher-ng/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/apt-cacher-ng
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-cacher-ng/ChangeLog,v 1.1 2011/05/24 21:48:33 jer Exp $
+
+*apt-cacher-ng-0.6.2 (24 May 2011)
+
+ 24 May 2011; Jeroen Roovers <jer@gentoo.org> +apt-cacher-ng-0.6.2.ebuild,
+ +files/confd, +files/cron.daily, +files/initd, +files/logrotate,
+ +metadata.xml:
+ Initial commit (bug #265840).
+
diff --git a/net-misc/apt-cacher-ng/Manifest b/net-misc/apt-cacher-ng/Manifest
new file mode 100644
index 000000000000..d6db126b941f
--- /dev/null
+++ b/net-misc/apt-cacher-ng/Manifest
@@ -0,0 +1,18 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX confd 90 RMD160 d29e3c43d1b7856a5ac6a2e47249955b4aa0e467 SHA1 e60450e1261082df039aad6fe8367e22ee1846c6 SHA256 cabcc9da711514913e5136c82842c750bab8a9658aeeb88da5a266e0d69b29a1
+AUX cron.daily 459 RMD160 774e42915dc408831f088b87f8f5de9b15423e44 SHA1 09bae26f2752cb12d4f7fa9eff492b3bb24a360e SHA256 6ec7ceeead17ef5a84d5ec5472d38810d9e1478213643da5f3fd9863dde40094
+AUX initd 780 RMD160 740c4bd2eb8db1b6937ae912dfc8661b30553718 SHA1 87d529e43bff172aaeb48a9794310046faad633d SHA256 dbdbd14df1d3a83a887eb8f7d0d014efbad78e01ad6722627ca7c43fbe4025d5
+AUX logrotate 377 RMD160 ef3824ff3484b00195fad7153332ce33f702d937 SHA1 d5606fceb5f3296aff7a7111ffadb440761286f2 SHA256 6f1624d655383452a6d56d69327d41b80379cc667ad2d481ca94f8ea78f7a65b
+DIST apt-cacher-ng_0.6.2.orig.tar.gz 281548 RMD160 ef9c5601cbc73b56bb0db6f5c716e11e38060a07 SHA1 cf03095aaf97ffa1e40b97dfa092573e8787c2b5 SHA256 8e94ba2385b4dcf16f7c024f0308facef24378a677e54297e054f5a1e4d13ec1
+EBUILD apt-cacher-ng-0.6.2.ebuild 2858 RMD160 13e92801303d56c410cafd4624bc8c20040125a3 SHA1 f0e49ec131fe6ccd1c494d08f12db5f19822365a SHA256 7afe3fdb4d7e28abdd301bf533ddd227006a7b30707871fd100918782a831f1a
+MISC ChangeLog 443 RMD160 cda46f594ab727b8c41c8b0e5534942b4514645e SHA1 cd881a9c2c2f7c0a6fd0d1f9ec1b7010f8daf8c5 SHA256 e9112c5fe83903933a508f8ed87cf69b4226b42806c9b6adf1f28c3bb44f8e1e
+MISC metadata.xml 387 RMD160 24ae6a7aaedb132c13ffdd94fe518f7ddcec6a9e SHA1 24771fa9c7362e5c6ca75ccf0ecce3c5945735e0 SHA256 83e4af4a9dff85e9d5d58a7704abff4dad046540b992c819a8203d529673e6d0
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEARECAAYFAk3cJ7wACgkQVWmRsqeSphNO/gCfT4eGTvvm2WYIWTAAXg+uP480
+liMAn2cxltgIPOwCrOtaaThjElZ8UT4q
+=zi70
+-----END PGP SIGNATURE-----
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-0.6.2.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-0.6.2.ebuild
new file mode 100644
index 000000000000..92f460008d1d
--- /dev/null
+++ b/net-misc/apt-cacher-ng/apt-cacher-ng-0.6.2.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-cacher-ng/apt-cacher-ng-0.6.2.ebuild,v 1.1 2011/05/24 21:48:33 jer Exp $
+
+EAPI="3"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Yet another implementation of an HTTP proxy for Debian/Ubuntu software packages written in C++"
+HOMEPAGE="http://www.unix-ag.uni-kl.de/~bloch/acng/"
+LICENSE="as-is"
+SLOT="0"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fuse"
+
+COMMON_DEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-util/cmake
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-lang/perl
+ fuse? ( sys-fs/fuse )
+"
+
+pkg_setup() {
+ # add new user & group for daemon
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_configure(){
+ mycmakeargs="-DCMAKE_INSTALL_PREFIX=/usr"
+ if use fuse; then
+ mycmakeargs="-DHAVE_FUSE_26=yes ${mycmakeargs}"
+ else
+ mycmakeargs="-DHAVE_FUSE_26=no ${mycmakeargs}"
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ pushd ${CMAKE_BUILD_DIR}
+ dosbin ${PN} || die
+ if use fuse
+ then dobin acngfs || die
+ fi
+ popd
+
+ newinitd "${FILESDIR}"/initd ${PN} || die "Can't add new init.d ${PN}"
+ newconfd "${FILESDIR}"/confd ${PN} || die "Can't add new conf.d ${PN}"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/logrotate ${PN} || die "Can't install new file ${PN} into '/etc/logrotate.d'"
+
+ doman doc/man/${PN}* || die "Can't install mans"
+ if use fuse; then doman doc/man/acngfs* || die "Can't install man pages for fusefs"; fi
+
+ # Documentation
+ dodoc README TODO VERSION INSTALL ChangeLog || die "Can't install common docs"
+ if use doc; then
+ dodoc doc/*.pdf || die "Can't install docs"
+ dohtml doc/html/* || die "Can't install html docs"
+ docinto examples/conf
+ dodoc conf/* || die "Can't install config examples"
+ fi
+
+ # perl daily cron script
+ dosbin expire-caller.pl || die
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/cron.daily ${PN} || die
+
+ # default configuration
+ insinto /etc/${PN}
+ newins conf/acng.conf ${PN}.conf || die
+ newins conf/report.html report.html || die
+ newins conf/deb_mirrors.gz deb_mirrors.gz || die
+ newins conf/debvol_mirrors.gz debvol_mirrors.gz || die
+ newins conf/ubuntu_mirrors ubuntu_mirrors || die
+ newins conf/archlx_mirrors archlx_mirrors || die
+ newins conf/sfnet_mirrors sfnet_mirrors || die
+ newins conf/cygwin_mirrors cygwin_mirrors || die
+ newins conf/security.conf security.conf || die
+ newins conf/maint.html maint.html || die
+ newins conf/userinfo.html userinfo.html || die
+ newins conf/style.css style.css || die
+
+ dodir /var/cache/${PN} || die
+ dodir /var/log/${PN} || die
+ # Some directories must exists
+ keepdir /var/log/${PN}
+ keepdir /var/run/${PN}
+ fowners -R ${PN}:${PN} \
+ /etc/${PN} \
+ /var/log/${PN} \
+ /var/cache/${PN} \
+ /var/run/${PN} || die
+}
diff --git a/net-misc/apt-cacher-ng/files/confd b/net-misc/apt-cacher-ng/files/confd
new file mode 100644
index 000000000000..72e76de133d1
--- /dev/null
+++ b/net-misc/apt-cacher-ng/files/confd
@@ -0,0 +1,2 @@
+# Additional options that are passed to the Daemon.
+DAEMON_OPTS=" -c /etc/apt-cacher-ng "
diff --git a/net-misc/apt-cacher-ng/files/cron.daily b/net-misc/apt-cacher-ng/files/cron.daily
new file mode 100644
index 000000000000..b5ea1436709c
--- /dev/null
+++ b/net-misc/apt-cacher-ng/files/cron.daily
@@ -0,0 +1,15 @@
+#!/bin/sh
+# Run the expire function of apt-cacher-ng non-interactively (unless errors
+# are detected).
+
+# optional, specify hostname to appear in error messages and links
+# HOSTNAME=externallyVisibleHostName
+# export HOSTNAME
+
+# optional, specify IP address to connect to
+# ACNGIP=10.0.1.3
+# export ACNGIP
+
+if test -r /usr/sbin/expire-caller.pl ; then
+ perl /usr/sbin/expire-caller.pl || echo Check error messages in /var/log/apt-cacher-ng/maint_*.log
+fi
diff --git a/net-misc/apt-cacher-ng/files/initd b/net-misc/apt-cacher-ng/files/initd
new file mode 100644
index 000000000000..c7df24365095
--- /dev/null
+++ b/net-misc/apt-cacher-ng/files/initd
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-cacher-ng/files/initd,v 1.1 2011/05/24 21:48:33 jer Exp $
+
+NAME="apt-cacher-ng"
+DAEMON="/usr/sbin/$NAME"
+RUNDIR="/var/run/$NAME"
+PIDFILE="$RUNDIR/$NAME.pid"
+SOCKETFILE="$RUNDIR/$NAME.socket"
+DAEMON_OPTS="$DAEMON_OPTS pidfile=$PIDFILE SocketPath=$SOCKETFILE foreground=0"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting $NAME"
+ start-stop-daemon --start --exec $DAEMON \
+ --chuid $NAME --group $NAME \
+ --pidfile $PIDFILE \
+ -- $DAEMON_OPTS
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping $NAME"
+ start-stop-daemon --stop --retry 15 --exec $DAEMON \
+ --pidfile $PIDFILE
+ rm -f $PIDFILE
+ eend $?
+}
diff --git a/net-misc/apt-cacher-ng/files/logrotate b/net-misc/apt-cacher-ng/files/logrotate
new file mode 100644
index 000000000000..330f2b6b6616
--- /dev/null
+++ b/net-misc/apt-cacher-ng/files/logrotate
@@ -0,0 +1,15 @@
+/var/log/apt-cacher-ng/*.log {
+ size 10M
+ missingok
+ rotate 12
+ compress
+ delaycompress
+ notifempty
+ create
+ postrotate
+ if [ -s /var/run/apt-cacher-ng/apt-cacher-ng.pid ] ; then
+ kill -s USR1 "$(cat /var/run/apt-cacher-ng/apt-cacher-ng.pid)"
+ fi
+ endscript
+}
+
diff --git a/net-misc/apt-cacher-ng/metadata.xml b/net-misc/apt-cacher-ng/metadata.xml
new file mode 100644
index 000000000000..4e3da3eecd45
--- /dev/null
+++ b/net-misc/apt-cacher-ng/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>deb-tools</herd>
+<maintainer>
+<email>jer@gentoo.org</email>
+<name>Jeroen Roovers</name>
+</maintainer>
+<use>
+<flag name="fuse">
+ Install the <pkg>sys-fs/fuse</pkg> based acngfs, to use a userspace
+ filesystem for the apt cache.
+</flag>
+</use>
+</pkgmetadata>