summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/burrow-owl')
-rw-r--r--sci-chemistry/burrow-owl/ChangeLog7
-rw-r--r--sci-chemistry/burrow-owl/burrow-owl-1.5.1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sci-chemistry/burrow-owl/ChangeLog b/sci-chemistry/burrow-owl/ChangeLog
index 39655e33fbac..ef6ef0946133 100644
--- a/sci-chemistry/burrow-owl/ChangeLog
+++ b/sci-chemistry/burrow-owl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/burrow-owl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/ChangeLog,v 1.5 2012/02/14 19:58:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/ChangeLog,v 1.6 2012/02/27 22:50:44 jlec Exp $
+
+*burrow-owl-1.5.1 (27 Feb 2012)
+
+ 27 Feb 2012; Justin Lecher <jlec@gentoo.org> +burrow-owl-1.5.1.ebuild:
+ Version Bump
*burrow-owl-1.5 (14 Feb 2012)
diff --git a/sci-chemistry/burrow-owl/burrow-owl-1.5.1.ebuild b/sci-chemistry/burrow-owl/burrow-owl-1.5.1.ebuild
new file mode 100644
index 000000000000..9021afe8e3f8
--- /dev/null
+++ b/sci-chemistry/burrow-owl/burrow-owl-1.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/burrow-owl-1.5.1.ebuild,v 1.1 2012/02/27 22:50:44 jlec Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Visualize multidimensional nuclear magnetic resonance (NMR) spectra"
+HOMEPAGE="http://burrow-owl.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.gz
+ examples? ( mirror://sourceforge/${PN}/burrow-demos.tar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples static-libs"
+
+RDEPEND="
+ dev-libs/g-wrap
+ dev-libs/glib:2
+ dev-scheme/guile[networking,regex]
+ dev-scheme/guile-cairo
+ dev-scheme/guile-gnome-platform
+ sci-libs/starparse
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/indent
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc doxygen doxygen)
+ )
+ autotools-utils_src_configure
+}
+
+src_test () {
+ autotools-utils_src_compile -C test-suite check
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/api/html/")
+ autotools-utils_src_install
+
+ use examples && \
+ insinto /usr/share/${PN} && \
+ doins -r "${WORKDIR}"/burrow-demos/*
+}