summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/patch')
-rw-r--r--sys-devel/patch/ChangeLog8
-rw-r--r--sys-devel/patch/Manifest5
-rw-r--r--sys-devel/patch/files/2.5.9-deb-cr.patch27
-rw-r--r--sys-devel/patch/files/digest-patch-2.5.9-r11
-rw-r--r--sys-devel/patch/patch-2.5.9-r1.ebuild52
5 files changed, 91 insertions, 2 deletions
diff --git a/sys-devel/patch/ChangeLog b/sys-devel/patch/ChangeLog
index 729830b746c5..a53f7d976b51 100644
--- a/sys-devel/patch/ChangeLog
+++ b/sys-devel/patch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/patch
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.25 2004/07/02 08:42:03 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.26 2004/11/16 07:08:00 vapier Exp $
+
+*patch-2.5.9-r1 (16 Nov 2004)
+
+ 16 Nov 2004; Mike Frysinger <vapier@gentoo.org> +files/2.5.9-deb-cr.patch,
+ +patch-2.5.9-r1.ebuild:
+ Version bump with debian patch #49823 by JoWilly.
02 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
patch-2.5.4-r5.ebuild, patch-2.5.9.ebuild:
diff --git a/sys-devel/patch/Manifest b/sys-devel/patch/Manifest
index a9a30a03f394..29995af0f75d 100644
--- a/sys-devel/patch/Manifest
+++ b/sys-devel/patch/Manifest
@@ -1,6 +1,9 @@
-MD5 458511872d14d7b16fbcaabdc0a1b335 ChangeLog 3441
+MD5 205a259d782ac496e933054878b7cc4c ChangeLog 3624
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 ea3e4de8df930b86d227affc240ef047 patch-2.5.4-r5.ebuild 887
MD5 b65b158dc35ff3457c1d22419a652f1e patch-2.5.9.ebuild 1445
+MD5 4d3cef8bc0d2335dec6b36093a1175a2 patch-2.5.9-r1.ebuild 1440
MD5 d8308835b63cc0644a67523856ef2df8 files/digest-patch-2.5.4-r5 63
MD5 7113f2413944cb06cecdd0c57ab54078 files/digest-patch-2.5.9 63
+MD5 4d1e5f04f223836b5c65c0995abd16ff files/2.5.9-deb-cr.patch 866
+MD5 7113f2413944cb06cecdd0c57ab54078 files/digest-patch-2.5.9-r1 63
diff --git a/sys-devel/patch/files/2.5.9-deb-cr.patch b/sys-devel/patch/files/2.5.9-deb-cr.patch
new file mode 100644
index 000000000000..67cc9b196e94
--- /dev/null
+++ b/sys-devel/patch/files/2.5.9-deb-cr.patch
@@ -0,0 +1,27 @@
+--- patch-2.5.9.orig/pch.c
++++ patch-2.5.9/pch.c
+@@ -366,10 +366,16 @@
+ if (!stars_last_line && strnEQ(s, "*** ", 4))
+ name[OLD] = fetchname (s+4, strippath, &p_timestamp[OLD]);
+ else if (strnEQ(s, "+++ ", 4))
++ {
+ /* Swap with NEW below. */
+ name[OLD] = fetchname (s+4, strippath, &p_timestamp[OLD]);
++ p_strip_trailing_cr = strip_trailing_cr;
++ }
+ else if (strnEQ(s, "Index:", 6))
++ {
+ name[INDEX] = fetchname (s+6, strippath, (time_t *) 0);
++ p_strip_trailing_cr = strip_trailing_cr;
++ }
+ else if (strnEQ(s, "Prereq:", 7)) {
+ for (t = s + 7; ISSPACE ((unsigned char) *t); t++)
+ continue;
+@@ -409,6 +415,7 @@
+ p_timestamp[NEW] = timestamp;
+ p_rfc934_nesting = (t - s) >> 1;
+ }
++ p_strip_trailing_cr = strip_trailing_cr;
+ }
+ }
+ if ((diff_type == NO_DIFF || diff_type == ED_DIFF) &&
diff --git a/sys-devel/patch/files/digest-patch-2.5.9-r1 b/sys-devel/patch/files/digest-patch-2.5.9-r1
new file mode 100644
index 000000000000..ef4595afc25b
--- /dev/null
+++ b/sys-devel/patch/files/digest-patch-2.5.9-r1
@@ -0,0 +1 @@
+MD5 dacfb618082f8d3a2194601193cf8716 patch-2.5.9.tar.gz 201926
diff --git a/sys-devel/patch/patch-2.5.9-r1.ebuild b/sys-devel/patch/patch-2.5.9-r1.ebuild
new file mode 100644
index 000000000000..7a4dc57d89d8
--- /dev/null
+++ b/sys-devel/patch/patch-2.5.9-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9-r1.ebuild,v 1.1 2004/11/16 07:08:00 vapier Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Utility to apply diffs to files"
+HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
+#SRC_URI="mirror://gnu/patch/${P}.tar.gz"
+#Using own mirrors until gnu has md5sum and all packages up2date
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="build static"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-deb-cr.patch
+}
+
+src_compile() {
+ strip-flags
+ append-flags -DLINUX -D_XOPEN_SOURCE=500
+ use static && append-ldflags -static
+
+ # workaround for hardened on amd64, 1st part
+ if use amd64 && is-ldflags -pie; then
+ einfo Stripping "-pie" from LDFLAGS, adding it to Makefile manually
+ filter-ldflags -pie
+ append-flags -fPIC
+ LDFLAGS_PIE="1"
+ fi
+ ac_cv_sys_long_file_names=yes econf || die
+ # workaround for hardened on amd64, 2nd part
+ if [ "${LDFLAGS_PIE}" = "1" ]; then
+ einfo "Patching Makefile..."
+ sed -i -e 's/^LDFLAGS =/& -pie/' Makefile || die "Patching Makefile failed!"
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog NEWS README
+ use build && rm -r "${D}"/usr/share
+}