summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-stdnum')
-rw-r--r--dev-python/python-stdnum/Manifest1
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.9.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/Manifest b/dev-python/python-stdnum/Manifest
index 204c3d7237f8..eddad5ebb3c2 100644
--- a/dev-python/python-stdnum/Manifest
+++ b/dev-python/python-stdnum/Manifest
@@ -1,2 +1,3 @@
DIST python-stdnum-1.7.tar.gz 411134 BLAKE2B 22afadd03c1f9043a68f34dcebcb80f8c053deb550924ae16c8e9b121f47da5422a28578743a6aa3cf1b71bc8fb3b588352ff776a36c78161cb3fd69faab71a6 SHA512 323f5e37087e95143eb59345c4ddb5fb1529a136c234c8e9c957cf9914984e758b256facbfbc5de379000b8939460ea25e8105428d67f7052a23676c334a002a
DIST python-stdnum-1.8.1.tar.gz 421921 BLAKE2B 814e887e15573ef09ee7a050204204474a06b9a65dad6f98a67a029ee4fdb64764dcbe43c491dcc6fdb56a88ea837bfa0b14a3c45dfef6b0aafa47ce70dc6f80 SHA512 02b0f8bc7e2245f780777b3b45db860b6332ad7fedfd6e674a8d67666693107773f5eda02bb241aef950a2409d5ac241b6de8326f80159311f2c22f0d0dc9465
+DIST python-stdnum-1.9.tar.gz 466861 BLAKE2B 31656cb64ab422dd172ee1a9121cf41d18bfd85a98a38a956e499e04e20369115449ed0b4b946e1aa2ce8d41eb24ca20b296aa178151276f3ea1e37153875969 SHA512 ed236e7fa5f64bb812578f019c2286a139f75356073ec7d0b0fc9220092b5e0e5d3b4fd133661e4126ac3f78141457af1793fdbc45a22daa4d36ceaf1535901f
diff --git a/dev-python/python-stdnum/python-stdnum-1.9.ebuild b/dev-python/python-stdnum/python-stdnum-1.9.ebuild
new file mode 100644
index 000000000000..6cc5bf1ad672
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="https://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies test"
+
+RDEPEND="vies? ( || ( dev-python/zeep dev-python/suds ) )"
+DEPEND="${DEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+DOCS=( ChangeLog NEWS README )
+
+python_test() {
+ nosetests -v || die
+}