summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/qutebrowser/Manifest2
-rw-r--r--www-client/qutebrowser/files/qutebrowser-3.1.0-pyqt670-tests.patch73
-rw-r--r--www-client/qutebrowser/files/qutebrowser-3.1.0-qt663-tests.patch12
-rw-r--r--www-client/qutebrowser/metadata.xml1
-rw-r--r--www-client/qutebrowser/qutebrowser-3.1.0-r1.ebuild220
5 files changed, 0 insertions, 308 deletions
diff --git a/www-client/qutebrowser/Manifest b/www-client/qutebrowser/Manifest
index 3421d8c87579..a2e345783187 100644
--- a/www-client/qutebrowser/Manifest
+++ b/www-client/qutebrowser/Manifest
@@ -1,5 +1,3 @@
-DIST qutebrowser-3.1.0.tar.gz 6045747 BLAKE2B d0cca696dd85bb99b8514331a392e1cb54fcbeff32fcf13e058739ef5a20ef1725980fbabef187a226f1cc29be9943784ba1f93275047586827922c3e98d0a64 SHA512 79dff3cf4ff93c75150e5cb9ada835ed5faf0343f03854266c6138fb8e6cceb921c868e1e408432da61b85ebe37e7e1657f634771ff73f1395d1b6e169138d98
-DIST qutebrowser-3.1.0.tar.gz.asc 659 BLAKE2B 023916e83cf2ac084f013ad750acf1ddb02a146197e92f703a96c54bceafcabf9d09a398c43e1679d0e425d54f13726c576c1b2e13707888e097952abef9797b SHA512 f89369b0c61852c0ee22a476fcce0c8fc236920a2c6fbcfb945e010275650bdd133b6714ec2b64c1156789eb3f6f897cbf9a31441e913afcf9f19ea3113611f7
DIST qutebrowser-3.2.0.tar.gz 6054386 BLAKE2B 3f0589dbbc2dc34c4138bc7ea33ea090a6aff4abe087e7b80f0294789a252924fb90b2b0229e1513c96e863a612bf26579b6e895bc0b9b553c1b7439361ee589 SHA512 85980ccbb1982ecfb142a4e3fc0a66b8ac88f73c394a6c936b8f1a541ea30a65ee576abd7e202ac50fd943c85457d75b5ccac7d51ea34ff1b0f7eb8a647aa18d
DIST qutebrowser-3.2.0.tar.gz.asc 659 BLAKE2B 33d88c2d4020535616ee5d8ed8e517aabf24433ab9d712f12aa1f138398a60807a14383d300245ee7873ed027445034ced9c61ce52a54518a2cc240a01f2649f SHA512 895e6d585f4d1d7373544d763663412136ef4b397565ddac24c1bcf16c75e96c8110cc8dea6fa8457799b893a2e3d2fca8979875b8e8423f270a70100d6e57db
DIST qutebrowser-3.2.1.tar.gz 6054942 BLAKE2B 7ddae7333b3ae906adc7811e0e383bb384c2105c59db935b96d165653f9570a249f3fedf9ad98f33d1ae7bd19f8637a3e1ed885f88aa724f4ceb61da4b8046a9 SHA512 753f053a157271806e273b667b656d64277d10d012d6940c5e023125e1f8fab151a32cf4defafe167141fe31461e6bf178d01b2d842f7252fd7405729a0edc68
diff --git a/www-client/qutebrowser/files/qutebrowser-3.1.0-pyqt670-tests.patch b/www-client/qutebrowser/files/qutebrowser-3.1.0-pyqt670-tests.patch
deleted file mode 100644
index 8095c3fa02ce..000000000000
--- a/www-client/qutebrowser/files/qutebrowser-3.1.0-pyqt670-tests.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-https://github.com/qutebrowser/qutebrowser/commit/1ee138b681a590ee500954361eed2cf923b1d8a0
-From: Florian Bruhin <me@the-compiler.org>
-Date: Mon, 25 Mar 2024 23:19:37 +0100
-Subject: [PATCH] qtutils: Handle QDataStream.Status.SizeLimitExceeded
---- a/qutebrowser/utils/qtutils.py
-+++ b/qutebrowser/utils/qtutils.py
-@@ -193,6 +193,15 @@ def check_qdatastream(stream: QDataStream) -> None:
- QDataStream.Status.WriteFailed: ("The data stream cannot write to the "
- "underlying device."),
- }
-+ try:
-+ status_to_str[QDataStream.Status.SizeLimitExceeded] = ( # type: ignore[attr-defined]
-+ "The data stream cannot read or write the data because its size is larger "
-+ "than supported by the current platform."
-+ )
-+ except AttributeError:
-+ # Added in Qt 6.7
-+ pass
-+
- if stream.status() != QDataStream.Status.Ok:
- raise OSError(status_to_str[stream.status()])
-
---- a/tests/unit/utils/test_qtutils.py
-+++ b/tests/unit/utils/test_qtutils.py
-@@ -208,6 +208,18 @@ def test_ensure_valid(obj, raising, exc_reason, exc_str):
- "The data stream has read corrupt data."),
- (QDataStream.Status.WriteFailed, True,
- "The data stream cannot write to the underlying device."),
-+ pytest.param(
-+ getattr(QDataStream.Status, "SizeLimitExceeded", None),
-+ True,
-+ (
-+ "The data stream cannot read or write the data because its size is larger "
-+ "than supported by the current platform."
-+ ),
-+ marks=pytest.mark.skipif(
-+ not hasattr(QDataStream.Status, "SizeLimitExceeded"),
-+ reason="Added in Qt 6.7"
-+ )
-+ ),
- ])
- def test_check_qdatastream(status, raising, message):
- """Test check_qdatastream.
-@@ -226,10 +238,25 @@ def test_check_qdatastream(status, raising, message):
- qtutils.check_qdatastream(stream)
-
-
--def test_qdatastream_status_count():
-- """Make sure no new members are added to QDataStream.Status."""
-- status_vals = testutils.enum_members(QDataStream, QDataStream.Status)
-- assert len(status_vals) == 4
-+def test_qdatastream_status_members():
-+ """Make sure no new members are added to QDataStream.Status.
-+
-+ If this fails, qtutils.check_qdatastream will need to be updated with the
-+ respective error documentation.
-+ """
-+ status_vals = set(testutils.enum_members(QDataStream, QDataStream.Status).values())
-+ expected = {
-+ QDataStream.Status.Ok,
-+ QDataStream.Status.ReadPastEnd,
-+ QDataStream.Status.ReadCorruptData,
-+ QDataStream.Status.WriteFailed,
-+ }
-+ try:
-+ expected.add(QDataStream.Status.SizeLimitExceeded)
-+ except AttributeError:
-+ # Added in Qt 6.7
-+ pass
-+ assert status_vals == expected
-
-
- @pytest.mark.parametrize('color, expected', [
diff --git a/www-client/qutebrowser/files/qutebrowser-3.1.0-qt663-tests.patch b/www-client/qutebrowser/files/qutebrowser-3.1.0-qt663-tests.patch
deleted file mode 100644
index e262623ab1c7..000000000000
--- a/www-client/qutebrowser/files/qutebrowser-3.1.0-qt663-tests.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-6.6.3 and 6.7.0-rc start to emit a new warning that causes:
-test_browsertab.py:13: Failure: Qt messages with level WARNING or above emitted
-
-It still seems(?) to be able to find qutebrowser's installed dictionaries
-fine and spellchecking works. Let's just ignore this warning for now.
---- a/pytest.ini
-+++ b/pytest.ini
-@@ -63,2 +63,4 @@
- Error in contacting registry: "org\.freedesktop\.DBus\.Error\.Disconnected" "Not connected to D-Bus server"
-+ # Qt 6.6.3 and 6.7.0, not looked into but spellchecking still functions
-+ ^Path override failed for key base::DIR_APP_DICTIONARIES and path .*
- xfail_strict = true
diff --git a/www-client/qutebrowser/metadata.xml b/www-client/qutebrowser/metadata.xml
index 224624c5a073..44b66f5f9007 100644
--- a/www-client/qutebrowser/metadata.xml
+++ b/www-client/qutebrowser/metadata.xml
@@ -24,7 +24,6 @@
<use>
<flag name="adblock">Enable Brave's ABP-style adblocker library
for improved adblocking</flag>
- <flag name="qt6">Use Qt6 that provides a newer Chromium version</flag>
<flag name="widevine">Unsupported closed-source DRM capability
(required by Netflix VOD)</flag>
</use>
diff --git a/www-client/qutebrowser/qutebrowser-3.1.0-r1.ebuild b/www-client/qutebrowser/qutebrowser-3.1.0-r1.ebuild
deleted file mode 100644
index 9fd58604459f..000000000000
--- a/www-client/qutebrowser/qutebrowser-3.1.0-r1.ebuild
+++ /dev/null
@@ -1,220 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1 xdg
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/qutebrowser/qutebrowser.git"
-else
- inherit verify-sig
- SRC_URI="
- https://github.com/qutebrowser/qutebrowser/releases/download/v${PV}/${P}.tar.gz
- verify-sig? ( https://github.com/qutebrowser/qutebrowser/releases/download/v${PV}/${P}.tar.gz.asc )
- "
- VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/qutebrowser.gpg
- KEYWORDS="amd64 ~arm64"
-fi
-
-DESCRIPTION="Keyboard-driven, vim-like browser based on Python and Qt"
-HOMEPAGE="https://qutebrowser.org/"
-
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="+adblock pdf +qt6 widevine"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/zipp[${PYTHON_USEDEP}]
- adblock? ( dev-python/adblock[${PYTHON_USEDEP}] )
- qt6? (
- dev-qt/qtbase:6[icu,sqlite]
- dev-python/PyQt6[${PYTHON_USEDEP},dbus,gui,network,opengl,printsupport,qml,sql,widgets]
- dev-python/PyQt6-WebEngine[${PYTHON_USEDEP},widgets]
- pdf? ( <www-plugins/pdfjs-4.1 )
- )
- !qt6? (
- dev-qt/qtcore:5[icu]
- dev-qt/qtgui:5[png]
- dev-qt/qtsql:5[sqlite]
- dev-python/PyQt5[${PYTHON_USEDEP},dbus,declarative,gui,network,opengl,printsupport,sql,widgets]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- pdf? ( <www-plugins/pdfjs-3 )
- )
- widevine? ( www-plugins/chrome-binary-plugins )
- ')
-"
-BDEPEND="
- $(python_gen_cond_dep '
- test? (
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/cheroot[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-bdd[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/pytest-xvfb[${PYTHON_USEDEP}]
- dev-python/tldextract[${PYTHON_USEDEP}]
- qt6? ( dev-python/PyQt6[testlib] )
- !qt6? ( dev-python/PyQt5[testlib] )
- )
- ')
-"
-
-if [[ ${PV} == 9999 ]]; then
- BDEPEND+=" app-text/asciidoc"
-else
- BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-qutebrowser )"
-fi
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-qt663-tests.patch
- "${FILESDIR}"/${P}-pyqt670-tests.patch
-)
-
-src_prepare() {
- distutils-r1_src_prepare
-
- if use pdf; then
- # does not hurt to enable by default if it was explicitly requested
- sed -e '/^content.pdfjs:/,+1s/false/true/' \
- -i ${PN}/config/configdata.yml || die
- fi
-
- # ensure the requested backend is used in case multiple are available
- sed -e "/^_WRAPPER_OVERRIDE =/s/None/\"PyQt$(usex qt6 6 5)\"/" \
- -i qutebrowser/qt/machinery.py || die
-
- # let eclass handle python
- sed -i '/setup.py/d' misc/Makefile || die
-
- if [[ ${PV} == 9999 ]]; then
- # call asciidoc(1) rather than the single target python module
- sed -e '/cmdline = /s/= .*/= ["asciidoc"]/' \
- -i scripts/asciidoc2html.py || die
-
- "${EPYTHON}" scripts/asciidoc2html.py || die
- fi
-
- if use test; then
- # skip unnecessary (for us) pytest plugins, and ignore Qt's
- # warnings that tend to newly appear with new versions
- sed -e '/pytest-benchmark/d' -e 's/--benchmark[^ ]*//' \
- -e '/pytest-instafail/d' -e 's/--instafail//' \
- -e '/qt_log_level_fail/s/WARNING/CRITICAL/' \
- -i pytest.ini || die
-
- if [[ ${PV} == 9999 ]]; then
- # likewise, needs vulture
- rm tests/unit/scripts/test_run_vulture.py || die
- else
- # https://github.com/qutebrowser/qutebrowser/issues/7620
- rm tests/unit/scripts/test_problemmatchers.py || die
- fi
- fi
-}
-
-python_test() {
- local -x PYTEST_QT_API=pyqt$(usex qt6 6 5)
-
- local EPYTEST_DESELECT=(
- # end2end/IPC tests are broken with "Name error" if socket path is over
- # ~108 characters (>124 in /var/tmp/portage) due to Linux limitations,
- # skip rather than bother using /tmp+cleanup over ${T} (end2end tests
- # are important, but the other tests should be enough for downstream)
- tests/end2end
- tests/unit/misc/test_ipc.py
- # python eclasses provide a fake "failing" python2 and trips this test
- tests/unit/misc/test_checkpyver.py::test_old_python
- # not worth running dbus over
- tests/unit/browser/test_notification.py::TestDBus
- # fails in ebuild, seems due to saving fake downloads in the wrong location
- tests/unit/browser/webengine/test_webenginedownloads.py::TestDataUrlWorkaround
- # may fail if environment is very large (bug #819393)
- tests/unit/commands/test_userscripts.py::test_custom_env\[_POSIXUserscriptRunner\]
- # needs _WRAPPER_OVERRIDE = None, but we have changed it
- tests/unit/test_qt_machinery.py::TestSelectWrapper::test_autoselect_by_default
- tests/unit/test_qt_machinery.py::TestInit::test_none_available_{implicit,explicit}
- # may fail if chromium version is unrecognized (aka newer qtwebengine)
- tests/unit/utils/test_version.py
- )
-
- # tests known failing with Qt5 which is considered a 2nd class citizen
- # and, unless completely broken, new tests issues may not be pursued
- use qt6 || EPYTEST_DESELECT+=(
- tests/unit/mainwindow/test_tabwidget.py::TestTabWidget::test_tab_text_not_edlided_for_wide_tabs
- )
-
- local epytestargs=(
- # prefer pytest-xvfb over virtx given same upstream and is expected
- -p xvfb
- # skip warning tests broken by -Wdefault, and benchmarks
- -k 'not _bench and not _matches_tree and not _warning'
- # override eclass' settings, tempdirs are re-used by Qt
- -o tmp_path_retention_policy=all
- )
-
- epytest "${epytestargs[@]}"
-}
-
-python_install_all() {
- emake -f misc/Makefile DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
-
- rm "${ED}"/usr/share/${PN}/scripts/{mkvenv,utils}.py || die
- fperms -x /usr/share/${PN}/{scripts/cycle-inputs.js,userscripts/README.md}
- python_fix_shebang "${ED}"/usr/share/${PN}
-
- einstalldocs
-}
-
-pkg_preinst() {
- xdg_pkg_preinst
-
- has_version "${CATEGORY}/${PN}[qt6]" && QUTEBROWSER_HAD_QT6=
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "Note that optional scripts in ${EROOT}/usr/share/${PN}/{user,}scripts"
- elog "have additional dependencies not covered by this ebuild, for example"
- elog "view_in_mpv needs media-video/mpv[lua] and net-misc/yt-dlp."
- fi
-
- if [[ ! -v QUTEBROWSER_HAD_QT6 && ${REPLACING_VERSIONS} ]] && use qt6; then
- ewarn
- ewarn "Be warned that starting the Qt6 version of ${PN} performs a one-way"
- ewarn "conversion of ~/.local/share/${PN}/webengine to Qt6. There will also"
- ewarn "be a warning on startup, and may optionally want to backup first."
- fi
-
- if use !qt6; then
- ewarn
- ewarn "USE=qt6 is disabled, be warned that Qt5's WebEngine uses an older"
- ewarn "chromium version. While it is relatively maintained for security, it will"
- ewarn "cause issues for sites/features designed with a newer version in mind."
- fi
-
- if { use qt6 && has_version 'dev-qt/qtwebengine:6[bindist]'; } ||
- { use !qt6 && has_version 'dev-qt/qtwebengine:5[bindist]'; }
- then
- ewarn
- ewarn "USE=bindist is set on dev-qt/qtwebengine, be warned that this"
- ewarn "will prevent playback of proprietary media formats (e.g. h264)."
- fi
-}