aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/soltrack/soltrack-2.2-r1.ebuild')
-rw-r--r--sci-astronomy/soltrack/soltrack-2.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-astronomy/soltrack/soltrack-2.2-r1.ebuild b/sci-astronomy/soltrack/soltrack-2.2-r1.ebuild
new file mode 100644
index 0000000..a339fc0
--- /dev/null
+++ b/sci-astronomy/soltrack/soltrack-2.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+CMAKE_MAKEFILE_GENERATOR=emake
+inherit cmake
+
+DESCRIPTION="A simple, free, fast and accurate routine to compute the position of the Sun"
+HOMEPAGE="http://soltrack.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DCREATE_STATICLIB="$(usex static-libs)"
+ )
+ cmake_src_configure
+}