aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Sell <quarkyalice@disroot.org>2022-07-07 13:04:48 -0700
committerAlice Sell <quarkyalice@disroot.org>2022-07-07 13:08:00 -0700
commit8ac2e455c466f3fc136da27a15a66069ac3e48fc (patch)
tree548234a333b9695ffc6152978b2d8390d584d804 /app-pda
downloadalicela1n-8ac2e455c466f3fc136da27a15a66069ac3e48fc.tar.gz
alicela1n-8ac2e455c466f3fc136da27a15a66069ac3e48fc.tar.bz2
alicela1n-8ac2e455c466f3fc136da27a15a66069ac3e48fc.zip
initial commit
Signed-off-by: Alice Sell <quarkyalice@disroot.org>
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/idevicerestore/Manifest3
-rw-r--r--app-pda/idevicerestore/idevicerestore-1.0.0.ebuild54
-rw-r--r--app-pda/idevicerestore/idevicerestore-9999.ebuild54
-rw-r--r--app-pda/libirecovery/Manifest3
-rw-r--r--app-pda/libirecovery/libirecovery-1.0.0.ebuild30
-rw-r--r--app-pda/libirecovery/libirecovery-9999.ebuild35
6 files changed, 179 insertions, 0 deletions
diff --git a/app-pda/idevicerestore/Manifest b/app-pda/idevicerestore/Manifest
new file mode 100644
index 0000000..827c653
--- /dev/null
+++ b/app-pda/idevicerestore/Manifest
@@ -0,0 +1,3 @@
+DIST idevicerestore-1.0.0.tar.bz2 361654 BLAKE2B 7d10a85cf8ba11c75313ff71a14bb5ae49f6fafcad08de350078c26ac87a3c7e40b27fb26d44866c823785b02af3e5d11cdc77b5890315c0b32c7bb0457aa46c SHA512 d62bd498fd12cacc0cd531a31b39255ee71e082a47de234a1d7bfc270745aec3ed18479fd67aeb2ccdc80e09980b98820e62b284c770e092fe24b96f3fca71a2
+EBUILD idevicerestore-1.0.0.ebuild 1255 BLAKE2B 0bdd812d7277e5e2e3ff884137d03da7347254b3cbd0a70a484005f9ca5c6cf9581df44057a0f4c74a0128873c74c9d3a5c759da1f3d7e9cd45d6fb85771dc52 SHA512 58cb6e5751f569fe9049e6f1792f12605215abf7ea3f4c07102bc52528e22f84fd6d99c14de4b3a40cab214e53125ee3a713bd3d146293f93a6a7dc71b5ee103
+EBUILD idevicerestore-9999.ebuild 1255 BLAKE2B 6580bc55357ae130134431f7bf967aa548d0c39bd6a1fb7003d51d48567960a91749eca3b1447a5880415b3bd66bd22ebb738e04ab6dc728e159a6dc5316efcc SHA512 e0a06537a87e7ae913d5019851b42c063aa0ffedbe096e829f0de528c00ef9ea9d2eab1fa02333175fbbf1b32655fb18220a85ad458722ce158cc891f0d7206d
diff --git a/app-pda/idevicerestore/idevicerestore-1.0.0.ebuild b/app-pda/idevicerestore/idevicerestore-1.0.0.ebuild
new file mode 100644
index 0000000..747c091
--- /dev/null
+++ b/app-pda/idevicerestore/idevicerestore-1.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="A cross-platform tool to restore Apple devices from IPSW files."
+HOMEPAGE="http://libimobiledevice.org"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/libimobiledevice/${PN}"
+else
+ RESTRICT="mirror"
+ SRC_URI="https://github.com/libimobiledevice/${PN}/releases/download/${PV}/${P}.tar.bz2"
+fi
+
+S="${WORKDIR}/idevicerestore-${PV}"
+
+LICENSE="GPL-3 LGPL-3.0"
+KEYWORDS="~amd64 ~x86 ~arm ~arm64"
+SLOT="0/6"
+KEYWORDS=""
+
+RESTRICT="mirror"
+
+RDEPEND=">=app-pda/libirecovery-1.0.0
+ >=app-pda/libimobiledevice-1.3.0
+ app-pda/libplist
+ >=dev-libs/libzip-0.8.0
+ >=net-misc/curl-7.0.0
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS INSTALL NEWS README TODO )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # the software's configure.ac doesn't handle things quite correctly,
+ # pass -pthread and -lpthread to solve the issue
+ append-flags "-pthread"
+ append-ldflags "-lpthread"
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman docs/idevicerestore.1
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-pda/idevicerestore/idevicerestore-9999.ebuild b/app-pda/idevicerestore/idevicerestore-9999.ebuild
new file mode 100644
index 0000000..2c4dab1
--- /dev/null
+++ b/app-pda/idevicerestore/idevicerestore-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="A cross-platform tool to restore Apple devices from IPSW files."
+HOMEPAGE="http://libimobiledevice.org"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/libimobiledevice/${PN}"
+else
+ RESTRICT="mirror"
+ SRC_URI="https://github.com/libimobiledevice/${PN}/releases/download/${PV}/${P}.tar.bz2"
+fi
+
+S="${WORKDIR}/idevicerestore-${PV}"
+
+LICENSE="GPL-3 LGPL-3.0"
+KEYWORDS="~amd64 ~x86 ~arm ~arm64"
+SLOT="0/6"
+KEYWORDS=""
+
+RESTRICT="mirror"
+
+RDEPEND=">=app-pda/libirecovery-1.0.1
+ >=app-pda/libimobiledevice-1.3.0
+ app-pda/libplist
+ >=dev-libs/libzip-0.8.0
+ >=net-misc/curl-7.0.0
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS INSTALL NEWS README TODO )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # the software's configure.ac doesn't handle things quite correctly,
+ # pass -pthread and -lpthread to solve the issue
+ append-flags "-pthread"
+ append-ldflags "-lpthread"
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman docs/idevicerestore.1
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-pda/libirecovery/Manifest b/app-pda/libirecovery/Manifest
new file mode 100644
index 0000000..e5dd512
--- /dev/null
+++ b/app-pda/libirecovery/Manifest
@@ -0,0 +1,3 @@
+DIST libirecovery-1.0.0.tar.bz2 340010 BLAKE2B f7b754e7661f4a132482efc3250ef5879ee6d8aad03896483dbdc204be0fd201f9bf22c353afca071d942eca2d2cdb42e42ace8324706913df49186a5297a39b SHA512 7e6f53766c85c714c2d4088e880f56486bcb4d198a9da1108d31f8f1a2444f45ac319a90a4706d00a24cbddc0af9ce8dddf267ba458fe3fa225cc14ea7150797
+EBUILD libirecovery-1.0.0.ebuild 612 BLAKE2B e7b25d3f10ce0fb31b4a2bca8acfb35a8cfbd4a895ac35c3906e7acf007c0a3b729dec11e455a9e7adc8f11d8ee9b453162f2dff4c9721dfc28a6cdbee6e0984 SHA512 331eb6e64955052cce38968aa853bbe686945eb24ab72e93df5161cea6ddba81e433fb71c9d00d2667165154a82b8d1bdc598de801e16fdf1f7a799a5aa128b1
+EBUILD libirecovery-9999.ebuild 717 BLAKE2B 7e35a7f3315559a42d307900f5b5ca766a5c50cec41cea82f957e79d93f839f3c58ab0dec227aaa5ec457238adfbfc241712a866f682494c9a9463ca332a8291 SHA512 e5bcad6480247870e9cded805e1115df57d7b057ed6933977424febf3a0e8dd31ca55e18b819a2d0f4574195adbcd44d528ada4894f0531d810c6a76166c5aa3
diff --git a/app-pda/libirecovery/libirecovery-1.0.0.ebuild b/app-pda/libirecovery/libirecovery-1.0.0.ebuild
new file mode 100644
index 0000000..d644125
--- /dev/null
+++ b/app-pda/libirecovery/libirecovery-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Library and utility to talk to iBoot/iBSS via USB."
+HOMEPAGE="https://github.com/libimobiledevice/libirecovery"
+SRC_URI="https://github.com/libimobiledevice/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm ~arm64"
+IUSE="udev"
+
+RESTRICT="mirror"
+
+DEPEND="sys-libs/readline
+ virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ myconf=$(use_with udev)
+ econf "${myconf}"
+}
diff --git a/app-pda/libirecovery/libirecovery-9999.ebuild b/app-pda/libirecovery/libirecovery-9999.ebuild
new file mode 100644
index 0000000..83f961c
--- /dev/null
+++ b/app-pda/libirecovery/libirecovery-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Library and utility to talk to iBoot/iBSS via USB."
+HOMEPAGE="https://github.com/libimobiledevice/libirecovery"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/libimobiledevice/libirecovery"
+else
+ RESTRICT="mirror"
+ SRC_URI="https://github.com/libimobiledevice/${PN}/releases/download/${PV}/${P}.tar.bz2"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="udev"
+
+RESTRICT="mirror"
+
+DEPEND="sys-libs/readline
+ virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ myconf=$(use_with udev)
+ econf "${myconf}"
+}