summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2023-07-03 11:20:10 +0200
committerMartin Väth <martin@mvath.de>2023-07-03 11:20:10 +0200
commit420314a7c66c1ddca071d7af9a6d7d9ffe0aab0e (patch)
tree11fab6d69d423e2608e3fd337a044a9ab8097252
parentsys-kernel/kernel: Version bump (diff)
downloadmv-420314a7c66c1ddca071d7af9a6d7d9ffe0aab0e.tar.gz
mv-420314a7c66c1ddca071d7af9a6d7d9ffe0aab0e.tar.bz2
mv-420314a7c66c1ddca071d7af9a6d7d9ffe0aab0e.zip
sys-fs/encfs: Add patched alpha version which uses fuse:3
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--metadata/pkg_desc_index1
-rw-r--r--sys-fs/encfs/Manifest1
-rw-r--r--sys-fs/encfs/encfs-1.9.6_alpha0.ebuild51
-rw-r--r--sys-fs/encfs/metadata.xml20
4 files changed, 73 insertions, 0 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index f202e345..a0ac539e 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -109,6 +109,7 @@ sys-block/parted 2.4-r3: Create, destroy, resize, check, copy partitions and fil
sys-block/zram-init 11.1-r2: Scripts to support compressed swap devices or ramdisks with zRAM
sys-boot/grub-cfg-mv 1.8: A grub.cfg library/example for GRUB2
sys-fs/emount 3.0.5: mount/unmount create/remove dm-crypt filesystems according to your /etc/fstab
+sys-fs/encfs 1.9.6_alpha0: An implementation of encrypted filesystem in user-space using FUSE
sys-fs/squash_dir 13.14-r1: Keep directories compressed with squashfs. Useful for portage tree, texmf-dist
sys-fs/squashfs-tools 99999999: Tool for creating compressed filesystem type squashfs
sys-fs/squashfuse 0.1.104: FUSE filesystem to mount squashfs archives
diff --git a/sys-fs/encfs/Manifest b/sys-fs/encfs/Manifest
new file mode 100644
index 00000000..43ac1124
--- /dev/null
+++ b/sys-fs/encfs/Manifest
@@ -0,0 +1 @@
+DIST encfs-1.9.6_alpha0.tar.gz 2686723 BLAKE2B c11623de81354031b547660106c7babd43b7571f7764f805b846a048454ba739816add45243d4eaf5e2a20b111834d4d520e6ed949febb9b3f04e0ec40af1feb SHA512 89198650fafe2d2f5427ff01f59443861620ad5be59fcb80b53c5cc79fe90caf252f5c1be3a98edcb725ee82e3ddea786dd831ab78adcce2cbb540e8556f1a67
diff --git a/sys-fs/encfs/encfs-1.9.6_alpha0.ebuild b/sys-fs/encfs/encfs-1.9.6_alpha0.ebuild
new file mode 100644
index 00000000..ac1b9806
--- /dev/null
+++ b/sys-fs/encfs/encfs-1.9.6_alpha0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+RESTRICT="mirror"
+
+inherit cmake
+
+DESCRIPTION="An implementation of encrypted filesystem in user-space using FUSE"
+HOMEPAGE="https://vgough.github.io/encfs/"
+case ${PV} in
+*alpha*)
+ EGIT_COMMIT="c5e5651f02b8aa7a5acd1737253780decf71636c"
+ SRC_URI="https://github.com/doj/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+*)
+ SRC_URI="https://github.com/vgough/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+esac
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 arm ~ppc64 ~sparc x86"
+IUSE="nls"
+
+RDEPEND="dev-libs/openssl:=
+ dev-libs/tinyxml2:=
+ sys-fs/fuse:3=
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+# Build dir is hardcoded in test suite, but we restrict them
+# because they can lead to false negatives, bug #630486
+RESTRICT="test"
+
+BUILD_DIR="${S}/build"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_NLS="$(usex nls)"
+ -DUSE_INTERNAL_TINYXML=OFF
+ -DBUILD_UNIT_TESTS=OFF
+ -DBUILD_SHARED_LIBS=ON
+ # Needed with BUILD_SHARED_LIBS=ON
+ -DINSTALL_LIBENCFS=ON
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+ cmake_src_configure
+}
diff --git a/sys-fs/encfs/metadata.xml b/sys-fs/encfs/metadata.xml
new file mode 100644
index 00000000..e85e2351
--- /dev/null
+++ b/sys-fs/encfs/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>zoltan@sinustrom.info</email>
+ <name>Zoltan Puskas</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>ceamac@gentoo.org</email>
+ <name>Viorel Munteanu</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">encfs</remote-id>
+ <remote-id type="github">vgough/encfs</remote-id>
+ </upstream>
+</pkgmetadata>