summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2023-10-16 21:41:14 +0200
committerMartin Väth <martin@mvath.de>2023-10-16 21:41:14 +0200
commitd9ffe9b7ccf80451bfe7a3187ecbb625af724fd6 (patch)
tree68571da69653ed36328b40c5eb54d8e9077e2e7b
parentgui-wm/wayfire, gui-libs/wf-config, gui-apps/wf-shell: Version bump (diff)
downloadmv-d9ffe9b7ccf80451bfe7a3187ecbb625af724fd6.tar.gz
mv-d9ffe9b7ccf80451bfe7a3187ecbb625af724fd6.tar.bz2
mv-d9ffe9b7ccf80451bfe7a3187ecbb625af724fd6.zip
gui-wm/wayfire: fix manpage, debugging. gui-apps/wcm: add for version bump
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--gui-apps/wcm/Manifest1
-rw-r--r--gui-apps/wcm/metadata.xml13
-rw-r--r--gui-apps/wcm/wcm-0.8.0.ebuild35
-rw-r--r--gui-wm/wayfire/wayfire-0.8.0.ebuild14
-rw-r--r--metadata/pkg_desc_index1
5 files changed, 59 insertions, 5 deletions
diff --git a/gui-apps/wcm/Manifest b/gui-apps/wcm/Manifest
new file mode 100644
index 00000000..d76c7232
--- /dev/null
+++ b/gui-apps/wcm/Manifest
@@ -0,0 +1 @@
+DIST wcm-0.8.0.tar.xz 430960 BLAKE2B 4d845edc631bda6b3fbee181d64897b366f4e73af7fef0e912f0a5dc9c7db4dc731319b6c25ce3e2206cc05c908ee402e01ed914cba4ccc63b0d52b9980b7414 SHA512 43d863cfd44dc10874f6ac0c511cd07d84721c53955315fb6eed54ba5f6ac9ebcdcf19e515639deafb333d8e45d95ce8e5222ce1d3344fc7d72f09b018bf517e
diff --git a/gui-apps/wcm/metadata.xml b/gui-apps/wcm/metadata.xml
new file mode 100644
index 00000000..4aa1e1a3
--- /dev/null
+++ b/gui-apps/wcm/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+ GUI front end to the wayfire config manager.
+ Allows to reload changes on the fly without
+ needing to restart wayfire.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">WayfireWM/wcm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/wcm/wcm-0.8.0.ebuild b/gui-apps/wcm/wcm-0.8.0.ebuild
new file mode 100644
index 00000000..d9c12a2d
--- /dev/null
+++ b/gui-apps/wcm/wcm-0.8.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+RESTRICT="mirror"
+
+inherit meson xdg
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wcm/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ >=gui-wm/wayfire-${PV%.*}
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
diff --git a/gui-wm/wayfire/wayfire-0.8.0.ebuild b/gui-wm/wayfire/wayfire-0.8.0.ebuild
index 9c979dc4..add22ec6 100644
--- a/gui-wm/wayfire/wayfire-0.8.0.ebuild
+++ b/gui-wm/wayfire/wayfire-0.8.0.ebuild
@@ -68,18 +68,21 @@ src_configure() {
sed -e "s:@EPREFIX@:${EPREFIX}:" \
"${FILESDIR}"/wayfire-session.desktop > "${T}"/wayfire-session.desktop || die
sed -i -e 's/git\.found[(][)]/false/' "${S}/meson.build"
- local i
- for i in grid wm-actions scale single_plugins; do
- sed -i -e 's:, json::' "${S}/plugins/${i}/meson.build"
- done
+ if ! use debug; then
+ # These patches are necessary with -Ddebug_ipc=false
+ local i
+ for i in grid wm-actions scale single_plugins; do
+ sed -i -e 's:, json::' "${S}/plugins/${i}/meson.build"
+ done
+ fi
local emesonargs=(
$(meson_feature system-wfconfig use_system_wfconfig)
$(meson_feature system-wlroots use_system_wlroots)
$(meson_feature X xwayland)
$(meson_use gles enable_gles32)
+ $(meson_use debug debug_ipc)
$(usex debug --buildtype=debug "")
$(usex debug -Db_sanitize=address,undefined "")
- -Ddebug_ipc=false
)
# Clang will fail to link without this
@@ -90,6 +93,7 @@ src_configure() {
src_install() {
meson_src_install
+ rm -rf "${ED}"/usr/man || die
dobin "${T}"/wayfire-session
insinto "/usr/share/wayland-sessions/"
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index acf09de2..c475b4ff 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -75,6 +75,7 @@ games-engines/freesci 0.6.4-r2: Sierra script interpreter for your old Sierra ad
games-rpg/aklabeth 1.0-r1: A remake of Richard C. Garriott's Ultima prequel
games-rpg/dsa-stats 1.1: calculate stat probabalities for the role playing game DSA - Das schwarze Auge
games-rpg/m5figur-mv 4.2.2: LaTeX2e character sheet layout for the Midgard Role Playing Game (Edition M5)
+gui-apps/wcm 0.8.0: Wayfire Config Manager
gui-apps/wf-shell 0.8.0: Compiz like 3D wayland compositor
gui-libs/wf-config 0.8.0: library for managing wayfire configuration files
gui-wm/wayfire 0.8.0: compiz like 3D wayland compositor