summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2014-08-10 13:45:05 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:12 +0200
commit350c5b0185e7950631d999924fcc0f6c7fcd2dc0 (patch)
tree95695be49ccb9f5eec898364c71adcb46535fbad /app-shells
parentBump pyrep (diff)
downloadmv-350c5b0185e7950631d999924fcc0f6c7fcd2dc0.tar.gz
mv-350c5b0185e7950631d999924fcc0f6c7fcd2dc0.tar.bz2
mv-350c5b0185e7950631d999924fcc0f6c7fcd2dc0.zip
Update zsh from main tree
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/ChangeLog23
-rw-r--r--app-shells/zsh/zsh-99999999.ebuild8
2 files changed, 17 insertions, 14 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 4bab7bd3..4376e883 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -4,16 +4,19 @@
*zsh-5.0.5 (09 Jan 2014)
+ 10 Oct 2014; Martin Väth <martin@mvath.de>:
+ Update KEYWORDS and some trivial changes from main tree
+
24 Jan 2014; Martin Väth <martin@mvath.de>:
Avoid duplicate installation
09 Jan 2014; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zsh-5.0.4 (20 Dec 2013)
20 Dec 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zsh-5.0.3 (15 Dec 2013)
@@ -25,12 +28,12 @@
*zsh-99999999 (29 May 2013)
16 Nov 2013; Martin Väth <martin@mvath.de>:
- Remove necessity for USE=custom-ctype.
+ Remove necessity for USE=custom-ctype
13 Nov 2013; Martin Väth <martin@mvath.de>:
Fix HELPDIR path. Revision bump to force change. Do not use-enable compile.
I submitted help installation upstream; this is used unconditionally if
- available (currently only in the live ebuild).
+ available (currently only in the live ebuild)
12 Nov 2013; Martin Väth <martin@mvath.de>:
Live version: Fix paths, remove IUSE=doc.
@@ -56,15 +59,15 @@
29 May 2013; Martin Väth <martin@mvath.de>:
Use upstream patches for texinfo-5 and fix-parameter-modifier crash,
- as in the main gentoo tree. Print messages conditionally as far as possible.
+ as in the main gentoo tree. Print messages conditionally as far as possible
*zsh-5.0.2-r2 (15 Apr 2013)
29 Apr 2013; Martin Väth <martin@mvath.de>:
- Honour EPREFIX. Remove redundant link of binary before installing.
+ Honour EPREFIX. Remove redundant link of binary before installing
15 Apr 2013; Martin Väth <martin@mvath.de>:
- Override LC_CTYPE, using some heuristics, unless USE=custom-ctype is chosen.
+ Override LC_CTYPE, using some heuristics, unless USE=custom-ctype is chosen
*zsh-5.0.2-r2 (03 Apr 2013)
@@ -74,12 +77,12 @@
*zsh-5.0.2-r1 (13 Jan 2013)
13 Jan 2013; Martin Väth <martin@mvath.de>:
- Fix run-help generation by forcing width 80. Install run-help completion.
+ Fix run-help generation by forcing width 80. Install run-help completion
*zsh-5.0.2 (25 Dec 2012)
25 Dec 2012; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zsh-5.0.0 (13 Aug 2012)
@@ -92,4 +95,4 @@
13 Aug 2012; Martin Väth <martin@mvath.de>:
Copy from the portage tree to add support for run-help and for removal of
unrequested completion functions (in particular, do not put them in $fpath).
- Clear previous ChangeLog.
+ Clear previous ChangeLog
diff --git a/app-shells/zsh/zsh-99999999.ebuild b/app-shells/zsh/zsh-99999999.ebuild
index 431b0e5c..3ac7616c 100644
--- a/app-shells/zsh/zsh-99999999.ebuild
+++ b/app-shells/zsh/zsh-99999999.ebuild
@@ -56,7 +56,7 @@ case ${PV} in
*)
SRC_URI="${ZSH_URI}
doc? ( ${ZSH_DOC_URI} )"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="alpha amd64 arm hppa ia64 ~ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
DEPEND=""
LIVE=false;;
esac
@@ -184,10 +184,10 @@ src_configure() {
--bindir="${EPREFIX}"/bin \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
--enable-etcdir="${EPREFIX}"/etc/zsh \
+ --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PVPATH}/help \
--enable-fndir="${EPREFIX}"/usr/share/zsh/${PVPATH}/functions \
--enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
--enable-function-subdirs \
- --with-term-lib="ncursesw ncurses" \
--with-tcsetpgrp \
$(use_enable maildir maildir-support) \
$(use_enable pcre) \
@@ -217,9 +217,9 @@ src_compile() {
}
src_test() {
- local i
addpredict /dev/ptmx
- for i in C02cond.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
+ local i
+ for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
rm "${S}"/Test/${i} || die
done
emake check