summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2011-01-31 00:13:08 +0100
committerSardem FF7 <sardemff7.pub@gmail.com>2011-01-31 00:13:08 +0100
commit3aea8f0cc77297edf17d298832801afa62a54676 (patch)
treee1380e55ee956f1894a1d200b0cea5d76d33dd2a
parentAdd GS-Theme-Selector (diff)
downloadsardemff7-3aea8f0cc77297edf17d298832801afa62a54676.tar.gz
sardemff7-3aea8f0cc77297edf17d298832801afa62a54676.tar.bz2
sardemff7-3aea8f0cc77297edf17d298832801afa62a54676.zip
Add some Gnome-Shell themes
-rw-r--r--x11-themes/gnome-shell-dark-glass/Manifest3
-rw-r--r--x11-themes/gnome-shell-dark-glass/files/metadata.json4
-rw-r--r--x11-themes/gnome-shell-dark-glass/gnome-shell-dark-glass-2010.01.09.ebuild36
-rw-r--r--x11-themes/gnome-shell-elementary/Manifest3
-rw-r--r--x11-themes/gnome-shell-elementary/files/metadata.json4
-rw-r--r--x11-themes/gnome-shell-elementary/gnome-shell-elementary-2010.01.12.ebuild36
6 files changed, 86 insertions, 0 deletions
diff --git a/x11-themes/gnome-shell-dark-glass/Manifest b/x11-themes/gnome-shell-dark-glass/Manifest
new file mode 100644
index 0000000..2dad0d3
--- /dev/null
+++ b/x11-themes/gnome-shell-dark-glass/Manifest
@@ -0,0 +1,3 @@
+AUX metadata.json 51 RMD160 6c1ea5342bc5d2a824a94f9b0bfc3a1c61a5bdd5 SHA1 714b7982823446f9709749801a839ec7fb009381 SHA256 74606e4b7c15feb1618a0d396ab1ed3c435a0f5413a8456377018967be6629e1
+EBUILD gnome-shell-dark-glass-2010.01.09.ebuild 819 RMD160 08ba8a88bde885adb4bd64b1d000023267e764fb SHA1 70839540ee286b9e2a293d55300b3b9a1e1f0c3b SHA256 0f3634a87e0e35426bd53ce317e5c326ac169665aa49d9f245eae6b062b07398
+DIST gnome-shell-dark-glass.zip 36564 RMD160 8a18db44497a4c33ef6c7b3cbd61fc51be3d6635 SHA1 5fbe69f530ad315d9fc16822bbd245282f468746 SHA256 11c8cab6c4f035010890509f9ba3ba651c32d54c0b4d8db7a49eb5543fb8cf09
diff --git a/x11-themes/gnome-shell-dark-glass/files/metadata.json b/x11-themes/gnome-shell-dark-glass/files/metadata.json
new file mode 100644
index 0000000..95b44fb
--- /dev/null
+++ b/x11-themes/gnome-shell-dark-glass/files/metadata.json
@@ -0,0 +1,4 @@
+{
+ "title": "Elementary",
+ "author": "Half-Left"
+}
diff --git a/x11-themes/gnome-shell-dark-glass/gnome-shell-dark-glass-2010.01.09.ebuild b/x11-themes/gnome-shell-dark-glass/gnome-shell-dark-glass-2010.01.09.ebuild
new file mode 100644
index 0000000..0e02d70
--- /dev/null
+++ b/x11-themes/gnome-shell-dark-glass/gnome-shell-dark-glass-2010.01.09.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+inherit base
+
+MY_PN="Dark-Glass"
+DESCRIPTION="Dark Glass Theme for Gnome-Shell"
+HOMEPAGE="http://half-left.deviantart.com/art/GNOME-Shell-Dark-Glass-Git-192828345"
+SRC_URI="${PN}.zip"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="fetch"
+
+RDEPEND="~gnome-base/gnome-shell-9999"
+DEPEND="app-arch/unzip"
+
+pkg_nofetch() {
+ einfo "Please download the ${SRC_URI} from"
+ einfo "${HOMEPAGE}"
+ einfo "and place it in ${DISTDIR}"
+}
+
+src_install() {
+ pushd "${WORKDIR}" &>/dev/null
+ mv theme ${MY_PN}
+ insinto /usr/share/gnome-shell/themes
+ doins -r ${MY_PN} || die "doins failed"
+ insinto /usr/share/gnome-shell/themes/${MY_PN}
+ doins "${FILESDIR}"/metadata.json
+ popd &>/dev/null
+}
diff --git a/x11-themes/gnome-shell-elementary/Manifest b/x11-themes/gnome-shell-elementary/Manifest
new file mode 100644
index 0000000..9ce53a9
--- /dev/null
+++ b/x11-themes/gnome-shell-elementary/Manifest
@@ -0,0 +1,3 @@
+AUX metadata.json 51 RMD160 6c1ea5342bc5d2a824a94f9b0bfc3a1c61a5bdd5 SHA1 714b7982823446f9709749801a839ec7fb009381 SHA256 74606e4b7c15feb1618a0d396ab1ed3c435a0f5413a8456377018967be6629e1
+EBUILD gnome-shell-elementary-2010.01.12.ebuild 819 RMD160 320f47f4995950c33ea905034be5332552abf7f8 SHA1 bd0844246725e32dded129809829083918ce87d9 SHA256 aa694104ce99797fabdbaa21ea790f4702c838e82182c8de0451e4cca0cb73a2
+DIST gnome-shell-elementary.zip 40020 RMD160 08118c203eaddffcb63b9b1750d9e2851b0dc59a SHA1 458c8d2e783ba9b761477f6845a60b22ac30b94f SHA256 f48faf138ab64afcda8c7492055a9998f561419c7405d453a88aee372a49ad95
diff --git a/x11-themes/gnome-shell-elementary/files/metadata.json b/x11-themes/gnome-shell-elementary/files/metadata.json
new file mode 100644
index 0000000..95b44fb
--- /dev/null
+++ b/x11-themes/gnome-shell-elementary/files/metadata.json
@@ -0,0 +1,4 @@
+{
+ "title": "Elementary",
+ "author": "Half-Left"
+}
diff --git a/x11-themes/gnome-shell-elementary/gnome-shell-elementary-2010.01.12.ebuild b/x11-themes/gnome-shell-elementary/gnome-shell-elementary-2010.01.12.ebuild
new file mode 100644
index 0000000..c682ea2
--- /dev/null
+++ b/x11-themes/gnome-shell-elementary/gnome-shell-elementary-2010.01.12.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+inherit base
+
+MY_PN="Elementary"
+DESCRIPTION="Elementary Theme for Gnome-Shell"
+HOMEPAGE="http://half-left.deviantart.com/art/GNOME-Shell-Elementary-Git-193232931"
+SRC_URI="${PN}.zip"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="fetch"
+
+RDEPEND="~gnome-base/gnome-shell-9999"
+DEPEND="app-arch/unzip"
+
+pkg_nofetch() {
+ einfo "Please download the ${SRC_URI} from"
+ einfo "${HOMEPAGE}"
+ einfo "and place it in ${DISTDIR}"
+}
+
+src_install() {
+ pushd "${WORKDIR}" &>/dev/null
+ mv theme ${MY_PN}
+ insinto /usr/share/gnome-shell/themes
+ doins -r ${MY_PN} || die "doins failed"
+ insinto /usr/share/gnome-shell/themes/${MY_PN}
+ doins "${FILESDIR}"/metadata.json
+ popd &>/dev/null
+}