summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-10-17 22:43:12 +0000
committerMichael Imhof <tantive@gentoo.org>2003-10-17 22:43:12 +0000
commit004e0b73c32d1e4b84e87bca945b5fc628d3e66a (patch)
tree760362f35f4829c2c16bc677982ae74969f8fd97
parentInitial release. Closes #30565 (diff)
downloadgentoo-2-004e0b73c32d1e4b84e87bca945b5fc628d3e66a.tar.gz
gentoo-2-004e0b73c32d1e4b84e87bca945b5fc628d3e66a.tar.bz2
gentoo-2-004e0b73c32d1e4b84e87bca945b5fc628d3e66a.zip
Initial release. Closes #30565
-rw-r--r--sys-cluster/mpiexec/ChangeLog9
-rw-r--r--sys-cluster/mpiexec/Manifest4
-rw-r--r--sys-cluster/mpiexec/files/digest-mpiexec-0.741
-rw-r--r--sys-cluster/mpiexec/metadata.xml6
-rw-r--r--sys-cluster/mpiexec/mpiexec-0.74.ebuild56
5 files changed, 75 insertions, 1 deletions
diff --git a/sys-cluster/mpiexec/ChangeLog b/sys-cluster/mpiexec/ChangeLog
new file mode 100644
index 000000000000..036da103ed64
--- /dev/null
+++ b/sys-cluster/mpiexec/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-admin/openmosixview
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpiexec/ChangeLog,v 1.1 2003/10/17 22:43:04 tantive Exp $
+
+*mpiexec-0.74 (18 Oct 2003)
+
+ 18 Oct 2003; Michael Imhof <tantive@gentoo.org>
+ Initial release. Ebuild submitted by Joseph Spadavecchia
+ <j.spadavecchia@ed.ac.uk>. Closes #30565.
diff --git a/sys-cluster/mpiexec/Manifest b/sys-cluster/mpiexec/Manifest
index 06fd6e375f9b..e4f0a472e162 100644
--- a/sys-cluster/mpiexec/Manifest
+++ b/sys-cluster/mpiexec/Manifest
@@ -1,2 +1,4 @@
-MD5 9b2d7074d196ac0018c6d04f57ad5872 mpiexec-0.74.ebuild 1256
+MD5 e93126d617085052ec7688390d150fbe metadata.xml 205
+MD5 374b0083b04f459f6cc1b34da17e265d ChangeLog 408
+MD5 e7f962c79512547231a1044efa9c20f0 mpiexec-0.74.ebuild 1366
MD5 198cb9770776b7a212c6c89bcf266e60 files/digest-mpiexec-0.74 61
diff --git a/sys-cluster/mpiexec/files/digest-mpiexec-0.74 b/sys-cluster/mpiexec/files/digest-mpiexec-0.74
new file mode 100644
index 000000000000..3a1e5766507d
--- /dev/null
+++ b/sys-cluster/mpiexec/files/digest-mpiexec-0.74
@@ -0,0 +1 @@
+MD5 abf896c85951072029c97f9ca05299d8 mpiexec-0.74.tgz 110386
diff --git a/sys-cluster/mpiexec/metadata.xml b/sys-cluster/mpiexec/metadata.xml
new file mode 100644
index 000000000000..0a32fdeb7a0f
--- /dev/null
+++ b/sys-cluster/mpiexec/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cluster</herd>
+<!-- <longdescription></longdescription> -->
+</pkgmetadata>
diff --git a/sys-cluster/mpiexec/mpiexec-0.74.ebuild b/sys-cluster/mpiexec/mpiexec-0.74.ebuild
new file mode 100644
index 000000000000..3a62104f5305
--- /dev/null
+++ b/sys-cluster/mpiexec/mpiexec-0.74.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpiexec/mpiexec-0.74.ebuild,v 1.1 2003/10/17 22:43:04 tantive Exp $
+
+S=${WORKDIR}/mpiexec-${PV}
+DESCRIPTION="Mpiexec is a replacement program for the script mpirun,
+which is part of the mpich package. It bridges the gap between mpich
+and PBS. It is used to initialize a parallel job from within a PBS
+batch or interactive environment."
+SRC_URI="http://www.osc.edu/~pw/mpiexec/mpiexec-0.74.tgz"
+HOMEPAGE="http://www.osc.edu/~pw/mpiexec/"
+IUSE=""
+
+DEPEND="virtual/glibc
+ sys-cluster/openpbs
+ sys-cluster/mpich"
+RDEPEND="net-misc/openssh"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# Do we have a SMP enabled kernel?
+if [ ! -z "`uname -v | grep SMP`" ]
+then
+ export SMP=1
+else
+ export SMP=0
+fi
+
+src_compile() {
+ cd ${S}
+
+ #for SMP machines, disable the use of mpich/p4 shared memory
+ if [ "${SMP}" = 1 ]; then
+ myconf="--disable-p4-shmem"
+ fi
+
+ # mpich-p4 is the best default
+ ./configure --mandir=/usr/share/man \
+ --prefix=/usr \
+ --with-pbs=/usr \
+ --with-default-comm=mpich-p4 \
+ ${myconf} || die
+ make || die
+}
+
+src_install() {
+ dodir /usr/sbin
+ dodir /usr/local/bin
+
+ make install prefix=${D}/usr mandir=${D}/usr/share/man
+infodir=/usr/share/infoinstall || die
+
+ dodoc LICENSE README
+}