summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-12-13 15:49:01 +0000
committerBen de Groot <yngwin@gentoo.org>2009-12-13 15:49:01 +0000
commit00979936e9fc07ccb49ea82972ee4a846eb59dc9 (patch)
treedbf7f1284b5040144374eac77e17432b89548804
parentStable on alpha, bug #284824 (diff)
downloadgentoo-2-00979936e9fc07ccb49ea82972ee4a846eb59dc9.tar.gz
gentoo-2-00979936e9fc07ccb49ea82972ee4a846eb59dc9.tar.bz2
gentoo-2-00979936e9fc07ccb49ea82972ee4a846eb59dc9.zip
Remove obsolete versions. Pin 4.5.4 on correct sip and Qt versions. Remove
qt3support useflag description from metadata, as it is no longer in use. (Portage version: 2.2_rc56/cvs/Linux x86_64)
-rw-r--r--dev-python/PyQt4/ChangeLog9
-rw-r--r--dev-python/PyQt4/PyQt4-4.4.4-r2.ebuild60
-rw-r--r--dev-python/PyQt4/PyQt4-4.4.4-r5.ebuild111
-rw-r--r--dev-python/PyQt4/PyQt4-4.5.2.ebuild120
-rw-r--r--dev-python/PyQt4/PyQt4-4.5.4-r3.ebuild154
-rw-r--r--dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild30
-rw-r--r--dev-python/PyQt4/PyQt4-4.6.1-r1.ebuild156
-rw-r--r--dev-python/PyQt4/PyQt4-4.6.1.ebuild155
-rw-r--r--dev-python/PyQt4/PyQt4-4.6.2.ebuild4
-rw-r--r--dev-python/PyQt4/metadata.xml1
10 files changed, 25 insertions, 775 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index e278e7db59a4..1d58b91bb429 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.97 2009/11/30 07:30:22 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.98 2009/12/13 15:49:01 yngwin Exp $
+
+ 13 Dec 2009; Ben de Groot <yngwin@gentoo.org> -PyQt4-4.4.4-r2.ebuild,
+ -PyQt4-4.4.4-r5.ebuild, -PyQt4-4.5.2.ebuild, -PyQt4-4.5.4-r3.ebuild,
+ PyQt4-4.5.4-r4.ebuild, -PyQt4-4.6.1.ebuild, -PyQt4-4.6.1-r1.ebuild,
+ PyQt4-4.6.2.ebuild, metadata.xml:
+ Remove obsolete versions. Pin 4.5.4 on correct sip and Qt versions. Remove
+ qt3support useflag description from metadata, as it is no longer in use.
30 Nov 2009; Joseph Jezak <josejx@gentoo.org> PyQt4-4.5.4-r4.ebuild:
Marked ppc64 stable.
diff --git a/dev-python/PyQt4/PyQt4-4.4.4-r2.ebuild b/dev-python/PyQt4/PyQt4-4.4.4-r2.ebuild
deleted file mode 100644
index 9e1e57f269dd..000000000000
--- a/dev-python/PyQt4/PyQt4-4.4.4-r2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.4.4-r2.ebuild,v 1.7 2009/06/09 20:45:17 hwoarang Exp $
-
-EAPI=1
-
-inherit distutils qt4
-
-MY_P=PyQt-x11-gpl-${PV}
-
-DESCRIPTION="A set of Python bindings for the Qt toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/PyQt4/${MY_P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="dbus debug doc examples opengl qt3support svg webkit X"
-
-RDEPEND="~dev-python/sip-4.7.9
- >=x11-libs/qt-core-4.4.2:4
- dbus? ( dev-python/dbus-python
- >=x11-libs/qt-dbus-4.4.2:4 )
- opengl? ( >=x11-libs/qt-opengl-4.4.2:4 )
- svg? ( >=x11-libs/qt-svg-4.4.2:4 )
- qt3support? ( >=x11-libs/qt-qt3support-4.4.2:4 )
- webkit? ( >=x11-libs/qt-webkit-4.4.2:4 )
- X? ( >=x11-libs/qt-gui-4.4.2:4 )"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s:^[ \t]*check_license():# check_license():" "${S}"/configure.py
- sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" "${S}"/configure.py
- sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" "${S}"/configure.py
- sed -i -e "s:\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib/qt4\":g" "${S}"/configure.py
-}
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin -v /usr/share/sip"
- use debug && myconf="${myconf} -u"
-
- "${python}" configure.py ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "install failed"
- dodoc ChangeLog NEWS README THANKS
- use doc && dohtml -r doc/html/*
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/PyQt4/PyQt4-4.4.4-r5.ebuild b/dev-python/PyQt4/PyQt4-4.4.4-r5.ebuild
deleted file mode 100644
index d5971ecfb46c..000000000000
--- a/dev-python/PyQt4/PyQt4-4.4.4-r5.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.4.4-r5.ebuild,v 1.13 2009/08/16 13:30:42 gentoofan23 Exp $
-
-EAPI="2"
-
-inherit distutils qt4
-
-MY_P=PyQt-x11-gpl-${PV}
-QTVER="4.4.2"
-
-DESCRIPTION="A set of Python bindings for the Qt toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 hppa ia64 ppc ~ppc64 sparc x86 ~x86-fbsd"
-IUSE="X assistant +dbus debug doc examples kde opengl phonon sql svg webkit xmlpatterns"
-
-DEPEND="~dev-python/sip-4.7.9
- >=x11-libs/qt-core-${QTVER}:4
- >=x11-libs/qt-script-${QTVER}:4
- >=x11-libs/qt-test-${QTVER}:4
- X? ( >=x11-libs/qt-gui-${QTVER}:4[dbus?] )
- assistant? ( >=x11-libs/qt-assistant-${QTVER}:4 )
- dbus? (
- >=dev-python/dbus-python-0.80
- >=x11-libs/qt-dbus-${QTVER}:4
- )
- opengl? ( >=x11-libs/qt-opengl-${QTVER}:4 )
- phonon? (
- !kde? ( || ( >=x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
- kde? ( media-sound/phonon )
- )
- sql? ( >=x11-libs/qt-sql-${QTVER}:4 )
- svg? ( >=x11-libs/qt-svg-${QTVER}:4 )
- webkit? ( >=x11-libs/qt-webkit-${QTVER}:4 )
- xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QTVER}:4 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/configure.py.patch"
- "${FILESDIR}/${P}-qgraphicsproxywidget-avoid-event-callback-loop.patch"
- "${FILESDIR}/fix_license_check.patch"
-)
-
-pyqt4_use_enable() {
- use $1 && echo "--enable=${2:-$1}"
-}
-
-src_prepare() {
- if ! use dbus; then
- sed -i -e 's,^\([[:blank:]]\+\)check_dbus(),\1pass,' \
- "${S}"/configure.py || die
- fi
- qt4_src_prepare
-}
-
-src_configure() {
- distutils_python_version
-
- local myconf="${python} configure.py
- --confirm-license
- --bindir=/usr/bin
- --destdir=/usr/$(get_libdir)/python${PYVER}/site-packages
- --sipdir=/usr/share/sip
- $(use debug && echo '--debug')
- --enable=QtCore
- --enable=QtNetwork
- --enable=QtScript
- --enable=QtTest
- --enable=QtXml
- $(pyqt4_use_enable X QtGui)
- $(pyqt4_use_enable X QtDesigner)
- $(pyqt4_use_enable assistant QtAssistant)
- $(pyqt4_use_enable assistant QtHelp)
- $(pyqt4_use_enable opengl QtOpenGL)
- $(pyqt4_use_enable phonon)
- $(pyqt4_use_enable sql QtSql)
- $(pyqt4_use_enable svg QtSvg)
- $(pyqt4_use_enable webkit QtWebKit)
- $(pyqt4_use_enable xmlpatterns QtXmlPatterns)"
- echo ${myconf}
- ${myconf} || die "configuration failed"
-
- # Fix insecure runpath
- if use X ; then
- sed -i -e "/^LFLAGS/s:-Wl,-rpath,${S}/qpy/QtDesigner::" \
- "${S}"/QtDesigner/Makefile || die
- fi
-}
-
-src_install() {
- # INSTALL_ROOT is needed for the QtDesigner module,
- # the other Makefiles use DESTDIR.
- emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "installation failed"
-
- dodoc ChangeLog NEWS THANKS || die
-
- if use doc; then
- dohtml -r doc/html/* || die
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-}
diff --git a/dev-python/PyQt4/PyQt4-4.5.2.ebuild b/dev-python/PyQt4/PyQt4-4.5.2.ebuild
deleted file mode 100644
index be7cde0dee6d..000000000000
--- a/dev-python/PyQt4/PyQt4-4.5.2.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.2.ebuild,v 1.1 2009/07/14 19:29:14 hwoarang Exp $
-
-EAPI="2"
-
-inherit distutils python qt4
-
-MY_P=PyQt-x11-gpl-${PV}
-QTVER="4.5.1"
-
-DESCRIPTION="A set of Python bindings for the Qt toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( GPL-2 GPL-3 )"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="X assistant +dbus debug doc examples kde opengl phonon sql svg webkit xmlpatterns"
-
-DEPEND=">=dev-python/sip-4.8.1
- >=x11-libs/qt-core-${QTVER}:4
- >=x11-libs/qt-script-${QTVER}:4
- >=x11-libs/qt-test-${QTVER}:4
- X? ( >=x11-libs/qt-gui-${QTVER}:4[dbus?] )
- assistant? ( >=x11-libs/qt-assistant-${QTVER}:4 )
- dbus? (
- >=dev-python/dbus-python-0.80
- >=x11-libs/qt-dbus-${QTVER}:4
- )
- opengl? ( >=x11-libs/qt-opengl-${QTVER}:4 )
- phonon? (
- !kde? ( || ( >=x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
- kde? ( media-sound/phonon )
- )
- sql? ( >=x11-libs/qt-sql-${QTVER}:4 )
- svg? ( >=x11-libs/qt-svg-${QTVER}:4 )
- webkit? ( >=x11-libs/qt-webkit-${QTVER}:4 )
- xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QTVER}:4 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/configure.py.patch"
-)
-
-pyqt4_use_enable() {
- use $1 && echo "--enable=${2:-$1}"
-}
-
-src_prepare() {
- if ! use dbus; then
- sed -i -e 's,^\([[:blank:]]\+\)check_dbus(),\1pass,' \
- "${S}"/configure.py || die
- fi
- qt4_src_prepare
-
- # Remove this code after removing Python 2 from the tree.
- python_version
- if [[ "${PYVER:0:1}" == "3" ]]; then
- rm -fr pyuic/uic/port_v2
- else
- rm -fr pyuic/uic/port_v3
- fi
-}
-
-src_configure() {
- distutils_python_version
-
- local myconf="${python} configure.py
- --confirm-license
- --bindir=/usr/bin
- --destdir=$(python_get_sitedir)
- --sipdir=/usr/share/sip
- $(use debug && echo '--debug')
- --enable=QtCore
- --enable=QtNetwork
- --enable=QtScript
- --enable=QtTest
- --enable=QtXml
- $(pyqt4_use_enable X QtGui)
- $(pyqt4_use_enable X QtDesigner)
- $(pyqt4_use_enable assistant QtAssistant)
- $(pyqt4_use_enable assistant QtHelp)
- $(pyqt4_use_enable opengl QtOpenGL)
- $(pyqt4_use_enable phonon)
- $(pyqt4_use_enable sql QtSql)
- $(pyqt4_use_enable svg QtSvg)
- $(pyqt4_use_enable webkit QtWebKit)
- $(pyqt4_use_enable xmlpatterns QtXmlPatterns)"
- echo ${myconf}
- ${myconf} || die "configuration failed"
-
- # Fix insecure runpath
- if use X ; then
- for pkg in QtDesigner QtGui QtCore; do
- sed -i -e "/^LFLAGS/s:-Wl,-rpath,${S}/qpy/${pkg}::" \
- "${S}"/${pkg}/Makefile || die "failed to fix rpath issues"
- done
- fi
-}
-
-src_install() {
- python_need_rebuild
- # INSTALL_ROOT is needed for the QtDesigner module,
- # the other Makefiles use DESTDIR.
- emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "installation failed"
-
- dodoc ChangeLog NEWS THANKS || die
-
- if use doc; then
- dohtml -r doc/html/* || die
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-}
diff --git a/dev-python/PyQt4/PyQt4-4.5.4-r3.ebuild b/dev-python/PyQt4/PyQt4-4.5.4-r3.ebuild
deleted file mode 100644
index 083b8715b601..000000000000
--- a/dev-python/PyQt4/PyQt4-4.5.4-r3.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4-r3.ebuild,v 1.1 2009/08/12 08:58:25 hwoarang Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python qt4 toolchain-funcs
-
-MY_P=PyQt-x11-gpl-${PV}
-QTVER="4.5.1"
-
-DESCRIPTION="A set of Python bindings for the Qt toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( GPL-2 GPL-3 )"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="X assistant +dbus debug doc examples kde opengl phonon sql svg webkit xmlpatterns"
-
-DEPEND=">=dev-python/sip-4.8.2
- >=x11-libs/qt-core-${QTVER}:4
- >=x11-libs/qt-script-${QTVER}:4
- >=x11-libs/qt-test-${QTVER}:4
- X? ( >=x11-libs/qt-gui-${QTVER}:4[dbus?] )
- assistant? ( >=x11-libs/qt-assistant-${QTVER}:4 )
- dbus? (
- >=dev-python/dbus-python-0.80
- >=x11-libs/qt-dbus-${QTVER}:4
- )
- opengl? ( >=x11-libs/qt-opengl-${QTVER}:4 )
- phonon? (
- !kde? ( || ( >=x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
- kde? ( media-sound/phonon )
- )
- sql? ( >=x11-libs/qt-sql-${QTVER}:4 )
- svg? ( >=x11-libs/qt-svg-${QTVER}:4 )
- webkit? ( >=x11-libs/qt-webkit-${QTVER}:4 )
- xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QTVER}:4 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/configure.py.patch"
- # Remember to remove this patch since it is already on PyQt4-4.6
- "${FILESDIR}/${P}-qgraphicslinearlayout-fix.patch"
-)
-
-src_prepare() {
- if ! use dbus; then
- sed -i -e 's,^\([[:blank:]]\+\)check_dbus(),\1pass,' \
- "${S}"/configure.py || die
- fi
- qt4_src_prepare
-
- python_copy_sources
-
- preparation() {
- if [[ "${PYTHON_ABI:0:1}" == "3" ]]; then
- rm -fr pyuic/uic/port_v2
- else
- rm -fr pyuic/uic/port_v3
- fi
- }
- python_execute_function -s preparation
-}
-
-pyqt4_use_enable() {
- use $1 && echo "--enable=${2:-$1}"
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --confirm-license
- --bindir=/usr/bin
- --destdir=$(python_get_sitedir)
- --sipdir=/usr/share/sip
- $(use debug && echo '--debug')
- --enable=QtCore
- --enable=QtNetwork
- --enable=QtScript
- --enable=QtTest
- --enable=QtXml
- $(pyqt4_use_enable X QtGui)
- $(pyqt4_use_enable X QtDesigner)
- $(pyqt4_use_enable assistant QtAssistant)
- $(pyqt4_use_enable assistant QtHelp)
- $(pyqt4_use_enable opengl QtOpenGL)
- $(pyqt4_use_enable phonon)
- $(pyqt4_use_enable sql QtSql)
- $(pyqt4_use_enable svg QtSvg)
- $(pyqt4_use_enable webkit QtWebKit)
- $(pyqt4_use_enable xmlpatterns QtXmlPatterns)
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}' LFLAGS='${LDFLAGS}'"
- echo ${myconf}
- eval ${myconf} || return 1
-
- # Fix insecure runpath.
- for mod in QtCore $(use X && echo 'QtDesigner QtGui'); do
- # Run eqmake4 to inside the qpy subdirs to prevent
- # stripping and many QA issues
- pushd qpy/${mod} > /dev/null || die
- eqmake4 $(ls w_qpy*.pro)
- popd > /dev/null || die
- sed -i -e "/^LFLAGS/s:-Wl,-rpath,${BUILDDIR}/qpy/${mod}::" ${mod}/Makefile || die "Failed to fix rpath issues"
- done
-
- # Fix pre-stripping of libpythonplugin.so
- if use X; then
- cd "${BUILDDIR}"/designer
- eqmake4 python.pro
- fi
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- python_execute_function -d -s
-}
-
-src_install() {
- python_need_rebuild
-
- installation() {
- # INSTALL_ROOT is needed for the QtDesigner module,
- # the other Makefiles use DESTDIR.
- emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
- }
- python_execute_function -s installation
-
- dodoc ChangeLog doc/pyqt4ref.txt NEWS THANKS || die
-
- if use doc; then
- dohtml -r doc/* || die
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize PyQt4
-}
-
-pkg_postrm() {
- python_mod_cleanup PyQt4
-}
diff --git a/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild b/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild
index b07665ff851d..0464a0414ded 100644
--- a/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild,v 1.8 2009/11/30 07:30:22 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild,v 1.9 2009/12/13 15:49:01 yngwin Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -8,7 +8,7 @@ SUPPORT_PYTHON_ABIS="1"
inherit python qt4 toolchain-funcs
MY_P=PyQt-x11-gpl-${PV}
-QTVER="4.5.1"
+QTVER="4.5*"
DESCRIPTION="A set of Python bindings for the Qt toolkit"
HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
@@ -19,25 +19,25 @@ LICENSE="|| ( GPL-2 GPL-3 )"
KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="X assistant +dbus debug doc examples kde opengl phonon sql svg webkit xmlpatterns"
-DEPEND=">=dev-python/sip-4.8.2
- >=x11-libs/qt-core-${QTVER}:4
- >=x11-libs/qt-script-${QTVER}:4
- >=x11-libs/qt-test-${QTVER}:4
- X? ( >=x11-libs/qt-gui-${QTVER}:4[dbus?] )
- assistant? ( >=x11-libs/qt-assistant-${QTVER}:4 )
+DEPEND="=dev-python/sip-4.8*
+ =x11-libs/qt-core-${QTVER}:4
+ =x11-libs/qt-script-${QTVER}:4
+ =x11-libs/qt-test-${QTVER}:4
+ X? ( =x11-libs/qt-gui-${QTVER}:4[dbus?] )
+ assistant? ( =x11-libs/qt-assistant-${QTVER}:4 )
dbus? (
>=dev-python/dbus-python-0.80
- >=x11-libs/qt-dbus-${QTVER}:4
+ =x11-libs/qt-dbus-${QTVER}:4
)
- opengl? ( >=x11-libs/qt-opengl-${QTVER}:4 )
+ opengl? ( =x11-libs/qt-opengl-${QTVER}:4 )
phonon? (
- !kde? ( || ( >=x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
+ !kde? ( || ( =x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
kde? ( media-sound/phonon )
)
- sql? ( >=x11-libs/qt-sql-${QTVER}:4 )
- svg? ( >=x11-libs/qt-svg-${QTVER}:4 )
- webkit? ( >=x11-libs/qt-webkit-${QTVER}:4 )
- xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QTVER}:4 )"
+ sql? ( =x11-libs/qt-sql-${QTVER}:4 )
+ svg? ( =x11-libs/qt-svg-${QTVER}:4 )
+ webkit? ( =x11-libs/qt-webkit-${QTVER}:4 )
+ xmlpatterns? ( =x11-libs/qt-xmlpatterns-${QTVER}:4 )"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/PyQt4/PyQt4-4.6.1-r1.ebuild b/dev-python/PyQt4/PyQt4-4.6.1-r1.ebuild
deleted file mode 100644
index fd6abb214ada..000000000000
--- a/dev-python/PyQt4/PyQt4-4.6.1-r1.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.6.1-r1.ebuild,v 1.1 2009/11/05 07:59:34 wired Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python qt4 toolchain-funcs
-
-MY_P="PyQt-x11-gpl-${PV/_pre/-snapshot-}"
-QTVER="4.5.1"
-
-DESCRIPTION="A set of Python bindings for the Qt toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( GPL-2 GPL-3 )"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="X assistant +dbus debug doc examples kde opengl phonon sql svg webkit xmlpatterns"
-
-DEPEND=">=dev-python/sip-4.9
- >=x11-libs/qt-core-${QTVER}:4
- >=x11-libs/qt-script-${QTVER}:4
- >=x11-libs/qt-test-${QTVER}:4
- X? ( >=x11-libs/qt-gui-${QTVER}:4[dbus?] )
- assistant? ( >=x11-libs/qt-assistant-${QTVER}:4 )
- dbus? (
- >=dev-python/dbus-python-0.80
- >=x11-libs/qt-dbus-${QTVER}:4
- )
- opengl? ( >=x11-libs/qt-opengl-${QTVER}:4 )
- phonon? (
- !kde? ( || ( >=x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
- kde? ( media-sound/phonon )
- )
- sql? ( >=x11-libs/qt-sql-${QTVER}:4 )
- svg? ( >=x11-libs/qt-svg-${QTVER}:4 )
- webkit? ( >=x11-libs/qt-webkit-${QTVER}:4 )
- xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QTVER}:4 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/configure-${PV}.py.patch"
- "${FILESDIR}/${P}-configure-multilib.patch"
-)
-
-src_prepare() {
- if ! use dbus; then
- sed -i -e 's,^\([[:blank:]]\+\)check_dbus(),\1pass,' \
- "${S}"/configure.py || die
- fi
- qt4_src_prepare
-
- python_copy_sources
-
- preparation() {
- if [[ "${PYTHON_ABI:0:1}" == "3" ]]; then
- rm -fr pyuic/uic/port_v2
- else
- rm -fr pyuic/uic/port_v3
- fi
- }
- python_execute_function -s preparation
-}
-
-pyqt4_use_enable() {
- use $1 && echo "--enable=${2:-$1}"
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --confirm-license
- --bindir=/usr/bin
- --destdir=$(python_get_sitedir)
- --sipdir=/usr/share/sip
- $(use debug && echo '--debug')
- --enable=QtCore
- --enable=QtNetwork
- --enable=QtScript
- --enable=QtTest
- --enable=QtXml
- $(pyqt4_use_enable X QtGui)
- $(pyqt4_use_enable X QtDesigner)
- $(pyqt4_use_enable X QtScriptTools)
- $(pyqt4_use_enable assistant QtAssistant)
- $(pyqt4_use_enable assistant QtHelp)
- $(pyqt4_use_enable opengl QtOpenGL)
- $(pyqt4_use_enable phonon)
- $(pyqt4_use_enable sql QtSql)
- $(pyqt4_use_enable svg QtSvg)
- $(pyqt4_use_enable webkit QtWebKit)
- $(pyqt4_use_enable xmlpatterns QtXmlPatterns)
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}' LFLAGS='${LDFLAGS}'"
- echo ${myconf}
- eval ${myconf} || return 1
-
- for mod in QtCore $(use X && echo 'QtDesigner QtGui'); do
- # Run eqmake4 inside the qpy subdirs to prevent
- # stripping and many other QA issues
- pushd qpy/${mod} > /dev/null || die
- eqmake4 $(ls w_qpy*.pro)
- popd > /dev/null || die
-
- # Fix insecure runpaths
- sed -i -e "/^LFLAGS/s:-Wl,-rpath,${BUILDDIR}/qpy/${mod}::" \
- ${mod}/Makefile || die "failed to fix rpath issues"
- done
-
- # Fix pre-stripping of libpythonplugin.so
- if use X; then
- cd "${BUILDDIR}"/designer
- eqmake4 python.pro
- fi
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- python_execute_function -d -s
-}
-
-src_install() {
- python_need_rebuild
-
- installation() {
- # INSTALL_ROOT is needed for the QtDesigner module,
- # the other Makefiles use DESTDIR.
- emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
- }
- python_execute_function -s installation
-
- dodoc ChangeLog doc/pyqt4ref.txt NEWS THANKS || die
-
- if use doc; then
- dohtml -r doc/* || die
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize PyQt4
-}
-
-pkg_postrm() {
- python_mod_cleanup PyQt4
-}
diff --git a/dev-python/PyQt4/PyQt4-4.6.1.ebuild b/dev-python/PyQt4/PyQt4-4.6.1.ebuild
deleted file mode 100644
index 069289a52df1..000000000000
--- a/dev-python/PyQt4/PyQt4-4.6.1.ebuild
+++ /dev/null
@@ -1,155 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.6.1.ebuild,v 1.1 2009/10/28 15:49:19 hwoarang Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python qt4 toolchain-funcs
-
-MY_P="PyQt-x11-gpl-${PV/_pre/-snapshot-}"
-QTVER="4.5.1"
-
-DESCRIPTION="A set of Python bindings for the Qt toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( GPL-2 GPL-3 )"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="X assistant +dbus debug doc examples kde opengl phonon sql svg webkit xmlpatterns"
-
-DEPEND=">=dev-python/sip-4.9
- >=x11-libs/qt-core-${QTVER}:4
- >=x11-libs/qt-script-${QTVER}:4
- >=x11-libs/qt-test-${QTVER}:4
- X? ( >=x11-libs/qt-gui-${QTVER}:4[dbus?] )
- assistant? ( >=x11-libs/qt-assistant-${QTVER}:4 )
- dbus? (
- >=dev-python/dbus-python-0.80
- >=x11-libs/qt-dbus-${QTVER}:4
- )
- opengl? ( >=x11-libs/qt-opengl-${QTVER}:4 )
- phonon? (
- !kde? ( || ( >=x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
- kde? ( media-sound/phonon )
- )
- sql? ( >=x11-libs/qt-sql-${QTVER}:4 )
- svg? ( >=x11-libs/qt-svg-${QTVER}:4 )
- webkit? ( >=x11-libs/qt-webkit-${QTVER}:4 )
- xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QTVER}:4 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/configure-${PV}.py.patch"
-)
-
-src_prepare() {
- if ! use dbus; then
- sed -i -e 's,^\([[:blank:]]\+\)check_dbus(),\1pass,' \
- "${S}"/configure.py || die
- fi
- qt4_src_prepare
-
- python_copy_sources
-
- preparation() {
- if [[ "${PYTHON_ABI:0:1}" == "3" ]]; then
- rm -fr pyuic/uic/port_v2
- else
- rm -fr pyuic/uic/port_v3
- fi
- }
- python_execute_function -s preparation
-}
-
-pyqt4_use_enable() {
- use $1 && echo "--enable=${2:-$1}"
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --confirm-license
- --bindir=/usr/bin
- --destdir=$(python_get_sitedir)
- --sipdir=/usr/share/sip
- $(use debug && echo '--debug')
- --enable=QtCore
- --enable=QtNetwork
- --enable=QtScript
- --enable=QtTest
- --enable=QtXml
- $(pyqt4_use_enable X QtGui)
- $(pyqt4_use_enable X QtDesigner)
- $(pyqt4_use_enable X QtScriptTools)
- $(pyqt4_use_enable assistant QtAssistant)
- $(pyqt4_use_enable assistant QtHelp)
- $(pyqt4_use_enable opengl QtOpenGL)
- $(pyqt4_use_enable phonon)
- $(pyqt4_use_enable sql QtSql)
- $(pyqt4_use_enable svg QtSvg)
- $(pyqt4_use_enable webkit QtWebKit)
- $(pyqt4_use_enable xmlpatterns QtXmlPatterns)
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}' LFLAGS='${LDFLAGS}'"
- echo ${myconf}
- eval ${myconf} || return 1
-
- for mod in QtCore $(use X && echo 'QtDesigner QtGui'); do
- # Run eqmake4 inside the qpy subdirs to prevent
- # stripping and many other QA issues
- pushd qpy/${mod} > /dev/null || die
- eqmake4 $(ls w_qpy*.pro)
- popd > /dev/null || die
-
- # Fix insecure runpaths
- sed -i -e "/^LFLAGS/s:-Wl,-rpath,${BUILDDIR}/qpy/${mod}::" \
- ${mod}/Makefile || die "failed to fix rpath issues"
- done
-
- # Fix pre-stripping of libpythonplugin.so
- if use X; then
- cd "${BUILDDIR}"/designer
- eqmake4 python.pro
- fi
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- python_execute_function -d -s
-}
-
-src_install() {
- python_need_rebuild
-
- installation() {
- # INSTALL_ROOT is needed for the QtDesigner module,
- # the other Makefiles use DESTDIR.
- emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
- }
- python_execute_function -s installation
-
- dodoc ChangeLog doc/pyqt4ref.txt NEWS THANKS || die
-
- if use doc; then
- dohtml -r doc/* || die
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize PyQt4
-}
-
-pkg_postrm() {
- python_mod_cleanup PyQt4
-}
diff --git a/dev-python/PyQt4/PyQt4-4.6.2.ebuild b/dev-python/PyQt4/PyQt4-4.6.2.ebuild
index c8b243ceeace..a7d8410f26d0 100644
--- a/dev-python/PyQt4/PyQt4-4.6.2.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.6.2.ebuild,v 1.1 2009/11/20 16:27:04 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.6.2.ebuild,v 1.2 2009/12/13 15:49:01 yngwin Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -8,7 +8,7 @@ SUPPORT_PYTHON_ABIS="1"
inherit python qt4 toolchain-funcs
MY_P="PyQt-x11-gpl-${PV/_pre/-snapshot-}"
-QTVER="4.5.1"
+QTVER="4.5.3"
DESCRIPTION="A set of Python bindings for the Qt toolkit"
HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/ http://pypi.python.org/pypi/PyQt"
diff --git a/dev-python/PyQt4/metadata.xml b/dev-python/PyQt4/metadata.xml
index 10ead50bd11a..31cbfe12c86c 100644
--- a/dev-python/PyQt4/metadata.xml
+++ b/dev-python/PyQt4/metadata.xml
@@ -11,7 +11,6 @@
</flag>
<flag name='opengl'>Build the QtOpenGL module</flag>
<flag name='phonon'>Build the phonon module</flag>
- <flag name='qt3support'>Enable the Qt3Support libraries for Qt4</flag>
<flag name='sql'>Build the QtSql module</flag>
<flag name='svg'>Build the QtSvg module</flag>
<flag name='webkit'>Build the QtWebKit module</flag>