summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2013-04-28 15:42:21 +0000
committerAndrey Grozin <grozin@gentoo.org>2013-04-28 15:42:21 +0000
commit00a70db0c0d6b55bb7719aabbc42b28c34e46cdb (patch)
tree993f2d6823b62131a1f8dcddf7b8a24e417ac505
parentFix broken Manifest entry for guacamole-auth-mysql-0.8.0.tar.gz. (diff)
downloadgentoo-2-00a70db0c0d6b55bb7719aabbc42b28c34e46cdb.tar.gz
gentoo-2-00a70db0c0d6b55bb7719aabbc42b28c34e46cdb.tar.bz2
gentoo-2-00a70db0c0d6b55bb7719aabbc42b28c34e46cdb.zip
Upstream patch to fix #417667
(Portage version: 2.2.0_alpha173/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
-rw-r--r--media-libs/vigra/ChangeLog6
-rw-r--r--media-libs/vigra/files/vigra-1.8.0-doxygen.patch57
-rw-r--r--media-libs/vigra/vigra-1.8.0-r1.ebuild5
3 files changed, 65 insertions, 3 deletions
diff --git a/media-libs/vigra/ChangeLog b/media-libs/vigra/ChangeLog
index b0cb1f913ff5..5f153d269298 100644
--- a/media-libs/vigra/ChangeLog
+++ b/media-libs/vigra/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/vigra
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/ChangeLog,v 1.59 2013/04/12 08:14:47 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/ChangeLog,v 1.60 2013/04/28 15:42:20 grozin Exp $
+
+ 28 Apr 2013; Andrey Grozin <grozin@gentoo.org> vigra-1.8.0-r1.ebuild,
+ +files/vigra-1.8.0-doxygen.patch:
+ Upstream patch to fix #417667
12 Apr 2013; Samuli Suominen <ssuominen@gentoo.org>
-files/1.7.1-automagicness.patch, -files/1.7.1-fix-nosetest.patch,
diff --git a/media-libs/vigra/files/vigra-1.8.0-doxygen.patch b/media-libs/vigra/files/vigra-1.8.0-doxygen.patch
new file mode 100644
index 000000000000..c264a67c0172
--- /dev/null
+++ b/media-libs/vigra/files/vigra-1.8.0-doxygen.patch
@@ -0,0 +1,57 @@
+From a8fd9ff8062152ccdcec7d63f2d5075f29ee2429 Mon Sep 17 00:00:00 2001
+From: Ullrich Koethe <ullrich.koethe@iwr.uni-heidelberg.de>
+Date: Wed, 21 Dec 2011 16:31:56 +0100
+Subject: [PATCH] adapted regular expressions for doxygen 1.7.6.1
+
+---
+ docsrc/makeFunctionIndex.py | 4 ++--
+ docsrc/post.py | 6 +++---
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/docsrc/makeFunctionIndex.py b/docsrc/makeFunctionIndex.py
+index 55e74bc..06300e2 100644
+--- a/docsrc/makeFunctionIndex.py
++++ b/docsrc/makeFunctionIndex.py
+@@ -119,8 +119,8 @@ def generateFunctionIndex(functionList):
+ text = open(path + "/namespaces.html").read()
+ if text.find('</h1>') > -1: # up to doxygen 1.7.1
+ header = text[:text.find('</h1>')+5]
+- else: # for doxygen 1.7.4
+- header = text[:re.search(r'<div class="title">[^<]*</div>\s*</div>\s*</div>\n<div class="contents">',text).end()]
++ else: # for doxygen 1.7.4 to 1.7.6.1
++ header = text[:re.search(r'<div class="title">[^<]*</div>\s*</div>\s*</div>(?:<!--header-->)?\n<div class="contents">',text).end()]
+ footer = re.search(r'(?s)(<!-- footer.html -->.*)', text).group(1)
+
+ text = re.sub(r'Namespace List', r'Function Index', header)
+diff --git a/docsrc/post.py b/docsrc/post.py
+index a8836d5..fc51f8d 100644
+--- a/docsrc/post.py
++++ b/docsrc/post.py
+@@ -51,13 +51,13 @@
+ </div>
+ <div class="contents">''')
+
+-# tested with doxygen 1.7.5.1
++# tested with doxygen 1.7.5.1 and 1.7.6.1
+ mainHeading4 = re.compile(r'''(<!-- Generated by Doxygen .+ -->
+ </div>)
+ (<div class="header">
+ <div class="headertitle">
+ )<div class="title">(.*)</div> </div>(.*)()
+-</div>
++</div>(?:<!--header-->)?
+ <div class="contents">''')
+
+ mainHeadingReplacement = '''\\1
+@@ -149,7 +149,7 @@ def processFile(fileName):
+ f.close()
+
+ files = glob.glob(path + '/*.html') # use given path to files
+-#files = glob.glob('../doc/vigra/index.html')
++#files = glob.glob(path + '/index.html')
+
+ for file in files:
+ processFile(file)
+--
+1.8.1.6
+
diff --git a/media-libs/vigra/vigra-1.8.0-r1.ebuild b/media-libs/vigra/vigra-1.8.0-r1.ebuild
index 595eb13d8034..dcafc2e233fc 100644
--- a/media-libs/vigra/vigra-1.8.0-r1.ebuild
+++ b/media-libs/vigra/vigra-1.8.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/vigra-1.8.0-r1.ebuild,v 1.1 2013/04/12 07:52:53 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/vigra-1.8.0-r1.ebuild,v 1.2 2013/04/28 15:42:20 grozin Exp $
EAPI=5
@@ -56,7 +56,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-automagicness.patch \
"${FILESDIR}"/${P}-numpy_doc.patch \
- "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-doxygen.patch
# Don't build nor install API docs when not requested
use doc || { sed -i -e '/ADD_SUBDIRECTORY(docsrc)/d' CMakeLists.txt || die; }