summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2013-10-09 19:58:00 +0000
committerMatti Bickel <mabi@gentoo.org>2013-10-09 19:58:00 +0000
commit023c1c1d9c4c8d720f9e8211ff0b9989937ceacb (patch)
treee600b13c9a379408d195fa4cf14b4f0942037e9e
parentlink to ncurses explicitly to avoid breaking reverse deps (diff)
downloadgentoo-2-023c1c1d9c4c8d720f9e8211ff0b9989937ceacb.tar.gz
gentoo-2-023c1c1d9c4c8d720f9e8211ff0b9989937ceacb.tar.bz2
gentoo-2-023c1c1d9c4c8d720f9e8211ff0b9989937ceacb.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x4849EC6C)
-rw-r--r--x11-libs/fxscintilla/ChangeLog9
-rw-r--r--x11-libs/fxscintilla/fxscintilla-3.3.5.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/x11-libs/fxscintilla/ChangeLog b/x11-libs/fxscintilla/ChangeLog
index ccb7458953b1..2dd9a71e6fa5 100644
--- a/x11-libs/fxscintilla/ChangeLog
+++ b/x11-libs/fxscintilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/fxscintilla
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/ChangeLog,v 1.53 2012/08/13 16:07:07 mabi Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/ChangeLog,v 1.54 2013/10/09 19:58:00 mabi Exp $
+
+*fxscintilla-3.3.5 (09 Oct 2013)
+
+ 09 Oct 2013; Matti Bickel <mabi@gentoo.org> +fxscintilla-3.3.5.ebuild:
+ version bump
13 Aug 2012; Matti Bickel <mabi@gentoo.org> fxscintilla-2.28.0.ebuild:
remove dohtml call left over from version 1.7 (bug #430542)
diff --git a/x11-libs/fxscintilla/fxscintilla-3.3.5.ebuild b/x11-libs/fxscintilla/fxscintilla-3.3.5.ebuild
new file mode 100644
index 000000000000..4c1e88b5c07a
--- /dev/null
+++ b/x11-libs/fxscintilla/fxscintilla-3.3.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/fxscintilla-3.3.5.ebuild,v 1.1 2013/10/09 19:58:00 mabi Exp $
+
+EAPI=4
+
+inherit autotools eutils multilib
+
+MY_PV=${PV//\./_}
+
+DESCRIPTION="A free source code editing component for the FOX-Toolkit"
+HOMEPAGE="http://www.nongnu.org/fxscintilla/"
+SRC_URI="https://github.com/yetanothergeek/fxscintilla/archive/FXSCINTILLA-${MY_PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="|| ( x11-libs/fox:1.6 x11-libs/fox:1.7 )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-FXSCINTILLA-${MY_PV}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf --libdir=/usr/$(get_libdir) --enable-shared
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ dodoc README ChangeLog
+ use doc && dohtml doc/*
+}
+
+pkg_postinst() {
+ elog "FXScintilla is now built only against the highest available"
+ elog "FOX-version you have installed."
+}