summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2003-07-12 23:03:19 +0000
committerLisa M. Seelye <lisa@gentoo.org>2003-07-12 23:03:19 +0000
commit04cc9183dca05a332ecef3466dbc5e6bd6deafd6 (patch)
treea187103bde911d502fdee523dfd2a659645a02ab
parentChanged `gtk2' to just `gtk' (thanks Spider!) (diff)
downloadgentoo-2-04cc9183dca05a332ecef3466dbc5e6bd6deafd6.tar.gz
gentoo-2-04cc9183dca05a332ecef3466dbc5e6bd6deafd6.tar.bz2
gentoo-2-04cc9183dca05a332ecef3466dbc5e6bd6deafd6.zip
Changed `gtk2' to just `gtk' (thanks Spider!)
-rw-r--r--sys-devel/distcc/ChangeLog6
-rw-r--r--sys-devel/distcc/Manifest4
-rw-r--r--sys-devel/distcc/distcc-2.8-r2.ebuild116
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.8-r21
4 files changed, 124 insertions, 3 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 92a35cc22647..f7e0eb5a95b3 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.53 2003/07/12 19:57:46 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.54 2003/07/12 23:02:52 lisa Exp $
*distcc-2.8 (09 Jul 2003)
10 Jul 2003: Lisa Marie Seelye <lisa@gentoo.org> :
@@ -10,6 +10,10 @@
Changed the USE flags from 'gnome' to 'gtk2' since distccmon-gnome was
changed to use gtk instead of gnome libraries.
+ 12 Jul 2003: Lisa Marie Seelye <lisa@gentoo.org> :
+ Oops. :) `gtk' is preferred over `gtk2'. Thanks Spider for the
+ heads up!
+
*distcc-2.7.1 (01 Jul 2003)
10 Jul 2003; Lisa Marie Seelye <lisa@gentoo.org> :
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 252d5dfecb4c..d3b215610a5d 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,11 +1,11 @@
-MD5 99a265522cbca775dc20f61cafedd61c distcc-2.8-r2.ebuild 3610
+MD5 f88e71a9f3df4a83c36838a36714d4ad distcc-2.8-r2.ebuild 3610
MD5 433082661e66dcd83cd0630ae2108503 distcc-2.8.ebuild 3623
MD5 7b08a44d08561a7ff5ddb161bc661419 distcc-2.5-r1.ebuild 3176
MD5 c958bfeb956960d4b15ebab2df7a6d86 distcc-2.5.ebuild 2702
MD5 b1dfe93f71045eb226d74ceb93959c65 distcc-2.8-r1.ebuild 3613
MD5 0b8da22979cd451f59bd17baabd4a121 distcc-2.7.ebuild 3451
MD5 ddb22cb3df08802286ef0139263ff899 distcc-2.7.1.ebuild 3870
-MD5 cace867a9f31dd8c126cef836077206c ChangeLog 9483
+MD5 df1f6bd6f04c13d8b3e349a9e19ef13d ChangeLog 9483
MD5 e1ecfcc1aad7c385cf3c41966277cda7 files/digest-distcc-2.5 63
MD5 5826ae3f83bd02bda94fa0e9343ef3fe files/digest-distcc-2.7 63
MD5 56fd1ac60c1b8402e1632da62f32a890 files/digest-distcc-2.8 63
diff --git a/sys-devel/distcc/distcc-2.8-r2.ebuild b/sys-devel/distcc/distcc-2.8-r2.ebuild
new file mode 100644
index 000000000000..5ec18145cb88
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.8-r2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.8-r2.ebuild,v 1.1 2003/07/12 23:02:53 lisa Exp $
+
+inherit eutils gcc flag-o-matic
+[ `gcc-major-version` -eq 2 ] && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+IUSE="gtk"
+
+DEPEND=">=sys-apps/portage-2.0.46-r11
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow
+ dev-libs/popt"
+
+RDEPEND="gtk? ( >=x11-libs/gtk+-2.2.1 )"
+
+src_unpack() {
+ unpack ${A}
+
+ #this patch fixes the problem with portage reassigning $TMPDIR
+ #and rendering the monitor programs useless, unless a rather
+ #icky hack is used. now sudo -u portage distccmon-{gnome,text}
+ #will work. - Lisa
+ cd ${S}/src
+ epatch ${FILESDIR}/${PV}/001*.gz
+}
+
+src_compile() {
+ local myconf
+ use gtk && myconf="--enable-gnome"
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${PV}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PV}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PV}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}" ${ROOT}usr/bin/distcc-config --set-hosts \
+ $(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install-user
+ /usr/bin/distcc-config --install-links
+ /usr/bin/distcc-config --install-links "${CHOST}"
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "To use distcc with **non-Portage** C compiling, add"
+ einfo "/usr/lib/distcc/bin to your path before /usr/bin. If you're"
+ einfo "combining this with ccache, put the ccache path BEFORE distcc."
+ einfo "Portage 2.0.46-r11+ will take advantage of distcc if you put"
+ einfo "distcc into the FEATURES setting in make.conf and use"
+ einfo "distcc-config --set-hosts. Do NOT set CC=distcc or similar."
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " sudo -H -u portage distccmon-text OR sudo -H -u portage distccmon-gnome"
+}
diff --git a/sys-devel/distcc/files/digest-distcc-2.8-r2 b/sys-devel/distcc/files/digest-distcc-2.8-r2
new file mode 100644
index 000000000000..9943b1256d40
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.8-r2
@@ -0,0 +1 @@
+MD5 da86497ab23f34a8630a2758d3c1b8cc distcc-2.8.tar.bz2 235859