summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-04-10 17:44:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-04-10 17:44:22 +0000
commit05a800ec557a85d4bd6214501e8f3de9ed3aa28c (patch)
treea21f30519e42c3e0b66334304ff123d398c001e2
parentppc stable, bug #216887 (diff)
downloadgentoo-2-05a800ec557a85d4bd6214501e8f3de9ed3aa28c.tar.gz
gentoo-2-05a800ec557a85d4bd6214501e8f3de9ed3aa28c.tar.bz2
gentoo-2-05a800ec557a85d4bd6214501e8f3de9ed3aa28c.zip
Rev bump: bashism in /bin/sh script fix by Martin Väth <vaeth@mathematik.uni-wuerzburg.de>, bug #216216. Backport a 'fix' from upstream to build with recent ffmpegs, bug #214520. Dont mess up fps type which fixes an issue of a/v sync fix by Ollie Wild <aloysius.wild@gmail.com>, bug #211242. Allow building with new ffmpeg headers layout fix by me.
(Portage version: 2.1.5_rc2)
-rw-r--r--media-libs/mlt/ChangeLog17
-rw-r--r--media-libs/mlt/files/mlt-0.2.4-avdevice.patch13
-rw-r--r--media-libs/mlt/files/mlt-0.2.4-bashism.patch11
-rw-r--r--media-libs/mlt/files/mlt-0.2.4-double-fps.patch16
-rw-r--r--media-libs/mlt/files/mlt-0.2.4-ffmpegheaders.patch24
-rw-r--r--media-libs/mlt/mlt-0.2.4-r2.ebuild100
6 files changed, 179 insertions, 2 deletions
diff --git a/media-libs/mlt/ChangeLog b/media-libs/mlt/ChangeLog
index d29ec5b660f2..71221af46f17 100644
--- a/media-libs/mlt/ChangeLog
+++ b/media-libs/mlt/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for media-libs/mlt
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.17 2007/11/23 10:36:17 drac Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.18 2008/04/10 17:44:22 aballier Exp $
+
+*mlt-0.2.4-r2 (10 Apr 2008)
+
+ 10 Apr 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/mlt-0.2.4-avdevice.patch, +files/mlt-0.2.4-bashism.patch,
+ +files/mlt-0.2.4-double-fps.patch, +files/mlt-0.2.4-ffmpegheaders.patch,
+ +mlt-0.2.4-r2.ebuild:
+ Rev bump: bashism in /bin/sh script fix by Martin Väth
+ <vaeth@mathematik.uni-wuerzburg.de>, bug #216216. Backport a 'fix' from
+ upstream to build with recent ffmpegs, bug #214520. Dont mess up fps type
+ which fixes an issue of a/v sync fix by Ollie Wild
+ <aloysius.wild@gmail.com>, bug #211242. Allow building with new ffmpeg
+ headers layout fix by me.
*mlt-0.2.4-r1 (23 Nov 2007)
diff --git a/media-libs/mlt/files/mlt-0.2.4-avdevice.patch b/media-libs/mlt/files/mlt-0.2.4-avdevice.patch
new file mode 100644
index 000000000000..82611aac150c
--- /dev/null
+++ b/media-libs/mlt/files/mlt-0.2.4-avdevice.patch
@@ -0,0 +1,13 @@
+Index: mlt-0.2.4/src/modules/avformat/producer_avformat.c
+===================================================================
+--- mlt-0.2.4.orig/src/modules/avformat/producer_avformat.c
++++ mlt-0.2.4/src/modules/avformat/producer_avformat.c
+@@ -203,7 +203,7 @@ static int producer_open( mlt_producer t
+ params->width = 640;
+ params->height = 480;
+ params->time_base= (AVRational){1,25};
+- params->device = file;
++ //params->device = file;
+ params->channels = 2;
+ params->sample_rate = 48000;
+ }
diff --git a/media-libs/mlt/files/mlt-0.2.4-bashism.patch b/media-libs/mlt/files/mlt-0.2.4-bashism.patch
new file mode 100644
index 000000000000..0f01aab2a139
--- /dev/null
+++ b/media-libs/mlt/files/mlt-0.2.4-bashism.patch
@@ -0,0 +1,11 @@
+--- src/modules/lumas/create_lumas
++++ src/modules/lumas/create_lumas
+@@ -10,7 +10,7 @@
+ mkdir -p $i
+ rm -f $i/*.pgm $i/*.png
+
+- [ "$i" == "PAL" ] && h=576 || h=480
++ [ "$i" = "PAL" ] && h=576 || h=480
+ ./luma -h $h -bpp $bpp > $i/luma01.pgm
+ ./luma -h $h -bpp $bpp -bands $h > $i/luma02.pgm
+ ./luma -h $h -bpp $bpp -hmirror 1 > $i/luma03.pgm
diff --git a/media-libs/mlt/files/mlt-0.2.4-double-fps.patch b/media-libs/mlt/files/mlt-0.2.4-double-fps.patch
new file mode 100644
index 000000000000..01da74de3fea
--- /dev/null
+++ b/media-libs/mlt/files/mlt-0.2.4-double-fps.patch
@@ -0,0 +1,16 @@
+This fixes an audio synchronization bug when exporting videos from
+kdenlive. See http://www.kdenlive.org/mantis/view.php?id=28.
+
+Ollie Wild <aloysius.wild@gmail.com>
+
+--- mlt-0.2.4/src/modules/avformat/consumer_avformat.c.orig 2008-02-24 01:20:25.000000000 -0800
++++ mlt-0.2.4/src/modules/avformat/consumer_avformat.c 2008-02-24 01:20:38.000000000 -0800
+@@ -623,7 +623,7 @@
+ struct timeval ante;
+
+ // Get the frame rate
+- int fps = mlt_properties_get_double( properties, "fps" );
++ double fps = mlt_properties_get_double( properties, "fps" );
+
+ // Get width and height
+ int width = mlt_properties_get_int( properties, "width" );
diff --git a/media-libs/mlt/files/mlt-0.2.4-ffmpegheaders.patch b/media-libs/mlt/files/mlt-0.2.4-ffmpegheaders.patch
new file mode 100644
index 000000000000..6fc641ae4a55
--- /dev/null
+++ b/media-libs/mlt/files/mlt-0.2.4-ffmpegheaders.patch
@@ -0,0 +1,24 @@
+Index: mlt-0.2.4/src/modules/avformat/configure
+===================================================================
+--- mlt-0.2.4.orig/src/modules/avformat/configure
++++ mlt-0.2.4/src/modules/avformat/configure
+@@ -130,12 +130,19 @@ else
+ echo "CFLAGS+=-I$shared_ffmpeg/include/ffmpeg " >> config.mak
+ echo "LDFLAGS+=-L$shared_ffmpeg/$LIBDIR" >> config.mak
+ [ "$swscale" != "" ] && echo "SWSCALE=1" >> config.mak
++ else if [ -d "$shared_ffmpeg/include/libavformat" -a -d "$shared_ffmpeg/include/libswscale" -a -f "$shared_ffmpeg/$LIBDIR/libavformat$avformat_suffix$LIBSUF" ]
++ then
++ echo "CFLAGS+=-I$shared_ffmpeg/include/libavformat " >> config.mak
++ echo "LDFLAGS+=-L$shared_ffmpeg/$LIBDIR" >> config.mak
++ [ "$swscale" != "" ] && echo "SWSCALE=1" >> config.mak
++ [ "$swscale" != "" ] && echo "CFLAGS+=-I$shared_ffmpeg/include/libswscale " >> config.mak
+ else
+ echo "avformat: No build environment found. "
+ echo " Try configuring mlt with --avformat-svn."
+ touch ../disable-avformat
+ exit 0
+ fi
++ fi
+ fi
+
+ echo "EXTRA_LIBS=$extra_libs" >> config.mak
diff --git a/media-libs/mlt/mlt-0.2.4-r2.ebuild b/media-libs/mlt/mlt-0.2.4-r2.ebuild
new file mode 100644
index 000000000000..dc1266cba21d
--- /dev/null
+++ b/media-libs/mlt/mlt-0.2.4-r2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.2.4-r2.ebuild,v 1.1 2008/04/10 17:44:22 aballier Exp $
+
+inherit eutils toolchain-funcs qt3
+
+DESCRIPTION="MLT is an open source multimedia framework, designed and developed
+for television broadcasting"
+HOMEPAGE="http://mlt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mlt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="dv xml jack gtk sdl vorbis sox quicktime mmx lame xine lame ogg theora
+xine ffmpeg libsamplerate qt3"
+
+DEPEND="ffmpeg? ( media-video/ffmpeg )
+ dv? ( >=media-libs/libdv-0.104 )
+ xml? ( >=dev-libs/libxml2-2.5 )
+ ogg? ( >=media-libs/libogg-1.1.3 )
+ vorbis? ( >=media-libs/libvorbis-1.1.2 )
+ sdl? ( >=media-libs/libsdl-1.2.10
+ >=media-libs/sdl-image-1.2.4 )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )
+ jack? ( media-sound/jack-audio-connection-kit
+ media-libs/ladspa-sdk
+ >=dev-libs/libxml2-2.5 )
+ gtk? ( >=x11-libs/gtk+-2
+ x11-libs/pango )
+ sox? ( media-sound/sox )
+ quicktime? ( media-libs/libquicktime )
+ xine? ( >=media-libs/xine-lib-1.1.2_pre20060328-r7 )
+ lame? ( >=media-sound/lame-3.97_beta2 )
+ qt3? ( $(qt_min_version 3) )
+ theora? ( >=media-libs/libtheora-1.0_alpha5 )"
+RDEPEND=${DEPEND}
+
+pkg_setup() {
+ local fail="USE sox needs also USE libsamplerate enabled."
+
+ if use sox && ! use libsamplerate; then
+ eerror "${fail}"
+ die "${fail}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/mlt-0.2.2-motion-est-nonx86.patch
+ epatch "${FILESDIR}"/mlt-0.2.3-nostrip.patch
+ epatch "${FILESDIR}"/${P}-sox1400.patch
+ epatch "${FILESDIR}"/${P}-ffmpegheaders.patch
+ epatch "${FILESDIR}"/${P}-avdevice.patch
+ epatch "${FILESDIR}"/${P}-bashism.patch
+ epatch "${FILESDIR}"/${P}-double-fps.patch
+}
+
+src_compile() {
+ tc-export CC
+
+ local myconf=" --enable-gpl --enable-shared
+ --enable-pp --enable-shared-pp
+ --enable-motion-est
+ $(use_enable dv)
+ $(use_enable mmx)
+ $(use_enable gtk gtk2)
+ $(use_enable vorbis)
+ $(use_enable ogg)
+ $(use_enable sdl)
+ $(use_enable jack jackrack)
+ $(use_enable sox)
+ $(use_enable theora)
+ $(use_enable lame mp3lame)
+ $(use_enable ffmpeg avformat)
+ $(use_enable libsamplerate resample)
+ $(use_enable qt3 qimage)
+ $(use_enable xml westley)
+ $(use_enable xine)"
+
+ use ffmpeg && has_version ">=media-video/ffmpeg-0.4.9_p20070616-r1" &&
+ myconf="${myconf} --avformat-swscale"
+
+ (use quicktime || use dv) || myconf="${myconf} --disable-kino"
+
+ econf ${myconf} || die "econf failed"
+ sed -i -e s/^OPT/#OPT/ "${S}/config.mak"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc docs/*.txt ChangeLog README docs/TODO
+
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins -r demo
+}