summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-31 21:23:45 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-31 21:23:45 +0000
commit05b6005e469caeac5358af25bf1a927ff1842892 (patch)
tree3b1d4ace925dd2571e339154d36208cbb603e667
parentReorder package.use.mask (diff)
downloadgentoo-2-05b6005e469caeac5358af25bf1a927ff1842892.tar.gz
gentoo-2-05b6005e469caeac5358af25bf1a927ff1842892.tar.bz2
gentoo-2-05b6005e469caeac5358af25bf1a927ff1842892.zip
bump to r1, add patch to handle uris, bug #229745.
(Portage version: 2.2_rc3/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
-rw-r--r--media-sound/sound-juicer/ChangeLog9
-rw-r--r--media-sound/sound-juicer/files/sound-juicer-2.22.0-sj-handle-uri.patch61
-rw-r--r--media-sound/sound-juicer/sound-juicer-2.22.0-r1.ebuild69
3 files changed, 138 insertions, 1 deletions
diff --git a/media-sound/sound-juicer/ChangeLog b/media-sound/sound-juicer/ChangeLog
index c1b6a8982efa..4e1b7dd2ffc1 100644
--- a/media-sound/sound-juicer/ChangeLog
+++ b/media-sound/sound-juicer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/sound-juicer
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sound-juicer/ChangeLog,v 1.142 2008/07/30 22:02:13 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sound-juicer/ChangeLog,v 1.143 2008/07/31 21:23:45 eva Exp $
+
+*sound-juicer-2.22.0-r1 (31 Jul 2008)
+
+ 31 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/sound-juicer-2.22.0-sj-handle-uri.patch,
+ +sound-juicer-2.22.0-r1.ebuild:
+ bump to r1, add patch to handle uris, bug #229745.
30 Jul 2008; Brent Baude <ranger@gentoo.org> sound-juicer-2.22.0.ebuild:
Marking sound-juicer-2.22.0 ppc stable for bug 229709
diff --git a/media-sound/sound-juicer/files/sound-juicer-2.22.0-sj-handle-uri.patch b/media-sound/sound-juicer/files/sound-juicer-2.22.0-sj-handle-uri.patch
new file mode 100644
index 000000000000..80026e5f63a7
--- /dev/null
+++ b/media-sound/sound-juicer/files/sound-juicer-2.22.0-sj-handle-uri.patch
@@ -0,0 +1,61 @@
+Index: src/sj-main.c
+===================================================================
+--- src/sj-main.c (revision 2168)
++++ src/sj-main.c (working copy)
+@@ -1576,12 +1576,13 @@
+ GnomeProgram *program;
+ GError *error = NULL;
+ GtkTreeSelection *selection;
+- char *device = NULL;
++ char *device = NULL, **uris = NULL;
+ GOptionContext *ctx;
+ const GOptionEntry entries[] = {
+ { "auto-start", 'a', 0, G_OPTION_ARG_NONE, &autostart, N_("Start extracting immediately"), NULL },
+ { "play", 'p', 0, G_OPTION_ARG_NONE, &autoplay, N_("Start playing immediately"), NULL},
+ { "device", 'd', 0, G_OPTION_ARG_FILENAME, &device, N_("What CD device to read"), N_("DEVICE") },
++ { G_OPTION_REMAINING, '\0', 0, G_OPTION_ARG_FILENAME_ARRAY, &uris, N_("URI to the CD device to read"), NULL },
+ { NULL }
+ };
+
+@@ -1803,10 +1804,26 @@
+ eject_changed_cb (gconf_client, -1, gconf_client_get_entry (gconf_client, GCONF_EJECT, NULL, TRUE, NULL), NULL);
+ open_changed_cb (gconf_client, -1, gconf_client_get_entry (gconf_client, GCONF_OPEN, NULL, TRUE, NULL), NULL);
+ audio_volume_changed_cb (gconf_client, -1, gconf_client_get_entry (gconf_client, GCONF_AUDIO_VOLUME, NULL, TRUE, NULL), NULL);
+- if (device == NULL) {
++ if (device == NULL && uris == NULL) {
+ device_changed_cb (gconf_client, -1, gconf_client_get_entry (gconf_client, GCONF_DEVICE, NULL, TRUE, NULL), GINT_TO_POINTER (TRUE));
+ } else {
+- set_device (device, TRUE);
++ if (device)
++ set_device (device, TRUE);
++ else {
++ char *d;
++
++ /* Mash up the CDDA URIs into a device path */
++ if (g_str_has_prefix (uris[0], "cdda://")) {
++ guint len;
++ d = g_strdup_printf ("/dev/%s", uris[0] + strlen ("cdda://"));
++ len = strlen (d);
++ d[len - 1] = '\0';
++ set_device (d, TRUE);
++ g_free (d);
++ } else {
++ device_changed_cb (gconf_client, -1, gconf_client_get_entry (gconf_client, GCONF_DEVICE, NULL, TRUE, NULL), GINT_TO_POINTER (TRUE));
++ }
++ }
+ }
+
+ if (sj_extractor_supports_encoding (&error) == FALSE) {
+Index: data/sound-juicer.desktop.in.in
+===================================================================
+--- data/sound-juicer.desktop.in.in (revision 2168)
++++ data/sound-juicer.desktop.in.in (working copy)
+@@ -2,7 +2,7 @@
+ Encoding=UTF-8
+ _Name=Audio CD Extractor
+ _Comment=Copy music from your CDs
+-Exec=sound-juicer
++Exec=sound-juicer %u
+ Icon=sound-juicer
+ StartupNotify=true
+ MimeType=x-content/audio-cdda;
diff --git a/media-sound/sound-juicer/sound-juicer-2.22.0-r1.ebuild b/media-sound/sound-juicer/sound-juicer-2.22.0-r1.ebuild
new file mode 100644
index 000000000000..a41af42f269e
--- /dev/null
+++ b/media-sound/sound-juicer/sound-juicer-2.22.0-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sound-juicer/sound-juicer-2.22.0-r1.ebuild,v 1.1 2008/07/31 21:23:45 eva Exp $
+
+EAPI="1"
+
+inherit eutils gnome2
+
+DESCRIPTION="CD ripper for GNOME 2"
+HOMEPAGE="http://www.burtonini.com/blog/computers/sound-juicer/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=gnome-extra/nautilus-cd-burner-2.15.3
+ >=x11-libs/gtk+-2.8
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2.13
+ >=gnome-base/gnome-vfs-2.9
+ dev-libs/dbus-glib
+ >=media-libs/gstreamer-0.10.5
+ >=gnome-extra/gnome-media-2.11.91
+ >=media-libs/musicbrainz-2.1.3:1
+ >=dev-libs/libcdio-0.70
+ media-libs/taglib
+ >=media-libs/gst-plugins-base-0.10
+ >=media-plugins/gst-plugins-gconf-0.10
+ >=media-plugins/gst-plugins-gnomevfs-0.10
+ || (
+ >=media-plugins/gst-plugins-cdparanoia-0.10
+ >=media-plugins/gst-plugins-cdio-0.10
+ )
+
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ >=app-text/scrollkeeper-0.3.5
+ app-text/gnome-doc-utils
+ test? ( ~app-text/docbook-xml-dtd-4.3 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+# needed to get around some sandboxing checks
+export GST_INSPECT=/bin/true
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-scrollkeeper"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Handle uris, bug #229745
+ epatch "${FILESDIR}/${P}-sj-handle-uri.patch"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ ewarn
+ ewarn "If ${PN} does not rip to some music format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+}