summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 16:08:02 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 16:08:02 +0000
commit0638500649f080e18a033c5df580a8332b7c9255 (patch)
treeb38a6ba48df426e464dc2eaa9a735fbc476c6553
parentneed eutils for epatch (diff)
downloadgentoo-2-0638500649f080e18a033c5df580a8332b7c9255.tar.gz
gentoo-2-0638500649f080e18a033c5df580a8332b7c9255.tar.bz2
gentoo-2-0638500649f080e18a033c5df580a8332b7c9255.zip
need eutils for epatch
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.6.ebuild30
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.8.ebuild24
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.2.ebuild32
-rw-r--r--dev-games/cel/cel-20030413-r2.ebuild4
-rw-r--r--dev-java/bcel/bcel-5.1.ebuild16
-rw-r--r--dev-java/commons-dbcp/commons-dbcp-1.0-r2.ebuild18
-rw-r--r--dev-java/xerces/xerces-2.3.0-r1.ebuild14
-rw-r--r--dev-java/xerces/xerces-2.3.0.ebuild11
8 files changed, 78 insertions, 71 deletions
diff --git a/dev-db/unixODBC/unixODBC-2.0.6.ebuild b/dev-db/unixODBC/unixODBC-2.0.6.ebuild
index c3242334a391..1e777a9f55c0 100644
--- a/dev-db/unixODBC/unixODBC-2.0.6.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.0.6.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.6.ebuild,v 1.17 2003/07/18 21:29:29 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.6.ebuild,v 1.18 2003/08/05 16:05:00 vapier Exp $
inherit gnuconfig
-IUSE="qt"
-
-S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
+HOMEPAGE="http://www.unixodbc.org/"
SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
-HOMEPAGE="http://www.unixodbc.org"
+
LICENSE="GPL-2"
-KEYWORDS="x86 ppc hppa sparc alpha ~amd64"
SLOT="0"
+KEYWORDS="x86 ppc hppa sparc alpha ~amd64"
+IUSE="qt"
+
DEPEND="virtual/glibc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
@@ -26,8 +26,8 @@ src_unpack() {
cp configure.in configure.orig
sed -e "s:AC_CHECK_LIB *( *c *,:AC_CHECK_FUNC(:" configure.orig >configure.in
cd gODBCConfig
- libtoolize
- aclocal
+ libtoolize
+ aclocal
cd ..
libtoolize
aclocal
@@ -47,21 +47,21 @@ src_compile() {
fi
export QTDIR=/usr/qt/2
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/unixODBC \
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
${myconf} || die
make || die
}
-src_install () {
- mkdir -p ${D}/etc/unixODBC
+src_install() {
+ dodir /etc/unixODBC
make DESTDIR=${D} sysconfdir=${D}/etc/unixODBC install || die
rm -r ${D}/var
dodoc AUTHORS COPYING ChangeLog NEWS README*
- cp -a doc ${D}/usr/share/doc/${PF}/html
- find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ find doc/ -name "Makefile*" -exec rm '{}' \;
+ dohtml doc/*
prepalldocs
}
diff --git a/dev-db/unixODBC/unixODBC-2.0.8.ebuild b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
index fa3f7473654e..1b6e3e56b458 100644
--- a/dev-db/unixODBC/unixODBC-2.0.8.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.15 2003/06/19 17:28:12 wwoods Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.16 2003/08/05 16:05:00 vapier Exp $
-IUSE="qt"
-
-S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
+HOMEPAGE="http://www.unixodbc.org/"
SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
-HOMEPAGE="http://www.unixodbc.org"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~hppa ~alpha"
+IUSE="qt"
+
DEPEND="virtual/glibc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
qt? ( =x11-libs/qt-2.3* )"
-SLOT="0"
src_unpack() {
unpack ${A}
@@ -34,19 +34,19 @@ src_compile() {
fi
export QTDIR=/usr/qt/2
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/unixODBC \
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
${myconf} || die
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog NEWS README*
- cp -a doc ${D}/usr/share/doc/${PF}/html
- find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ find doc/ -name "Makefile*" -exec rm '{}' \;
+ dohtml doc/*
prepalldocs
}
diff --git a/dev-db/unixODBC/unixODBC-2.2.2.ebuild b/dev-db/unixODBC/unixODBC-2.2.2.ebuild
index 1036ed01f04e..8af2d49a7782 100644
--- a/dev-db/unixODBC/unixODBC-2.2.2.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.2.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.2.ebuild,v 1.11 2003/07/31 19:36:23 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.2.ebuild,v 1.12 2003/08/05 16:05:00 vapier Exp $
-IUSE="qt"
-
-S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
+HOMEPAGE="http://www.unixodbc.org/"
SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
-HOMEPAGE="http://www.unixodbc.org"
-DEPEND="virtual/glibc
- >=sys-libs/readline-4.1
- >=sys-libs/ncurses-5.2
- qt? ( >=x11-libs/qt-3.0* )"
+
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~hppa ~alpha amd64"
SLOT="0"
+KEYWORDS="~x86 ~ppc ~hppa ~alpha amd64"
+IUSE="qt"
+
+DEPEND="virtual/glibc
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ qt? ( >=x11-libs/qt-3.0* )"
src_unpack() {
unpack ${A}
@@ -36,19 +36,19 @@ src_compile() {
myconf="--enable-gui=no"
fi
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/unixODBC \
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
${myconf} || die
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog NEWS README*
- cp -a doc ${D}/usr/share/doc/${PF}/html
- find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ find doc/ -name "Makefile*" -exec rm '{}' \;
+ dohtml doc/*
prepalldocs
}
diff --git a/dev-games/cel/cel-20030413-r2.ebuild b/dev-games/cel/cel-20030413-r2.ebuild
index fb8c64b2c192..e53af596db09 100644
--- a/dev-games/cel/cel-20030413-r2.ebuild
+++ b/dev-games/cel/cel-20030413-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/cel-20030413-r2.ebuild,v 1.4 2003/07/15 23:58:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/cel-20030413-r2.ebuild,v 1.5 2003/08/05 16:05:20 vapier Exp $
+
+inherit eutils
DESCRIPTION="A game entity layer based on Crystal Space"
HOMEPAGE="http://cel.sourceforge.net/"
diff --git a/dev-java/bcel/bcel-5.1.ebuild b/dev-java/bcel/bcel-5.1.ebuild
index e8a546fa8a2a..d63e50a8e200 100644
--- a/dev-java/bcel/bcel-5.1.ebuild
+++ b/dev-java/bcel/bcel-5.1.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bcel/bcel-5.1.ebuild,v 1.1 2003/05/15 06:58:30 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcel/bcel-5.1.ebuild,v 1.2 2003/08/05 16:08:02 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
-S=${WORKDIR}/${P}
-DESCRIPTION="The Byte Code Engineering Library: analyze, create, manipulate Java class files."
-SRC_URI="http://jakarta.apache.org/builds/jakarta-bcel/release/v${PV}/${PN}-${PV}-src.tar.gz"
+DESCRIPTION="The Byte Code Engineering Library: analyze, create, manipulate Java class files"
HOMEPAGE="http://jakarta.apache.org/bcel/"
-KEYWORDS="x86 ppc sparc alpha mips hppa arm"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-bcel/release/v${PV}/${PN}-${PV}-src.tar.gz"
+
LICENSE="Apache-1.1"
SLOT="0"
+KEYWORDS="x86 ppc sparc alpha mips hppa arm"
+IUSE="doc jikes"
+
DEPEND=""
RDEPEND=">=virtual/jdk-1.2
>=dev-java/regexp-1.2
jikes? ( dev-java/jikes )"
-IUSE="doc jikes"
DEP_APPEND="regexp"
src_compile() {
@@ -36,4 +37,3 @@ src_install() {
dodoc LICENSE.txt
java-pkg_dojar bin/bcel.jar
}
-
diff --git a/dev-java/commons-dbcp/commons-dbcp-1.0-r2.ebuild b/dev-java/commons-dbcp/commons-dbcp-1.0-r2.ebuild
index bf3cdaae3a22..e35e39b5a8fe 100644
--- a/dev-java/commons-dbcp/commons-dbcp-1.0-r2.ebuild
+++ b/dev-java/commons-dbcp/commons-dbcp-1.0-r2.ebuild
@@ -1,24 +1,26 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-dbcp/commons-dbcp-1.0-r2.ebuild,v 1.3 2003/04/26 05:36:58 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-dbcp/commons-dbcp-1.0-r2.ebuild,v 1.4 2003/08/05 16:08:02 vapier Exp $
-inherit jakarta-commons
+inherit jakarta-commons eutils
S=${WORKDIR}/${PN}-${PV}-src
DESCRIPTION="Jakarta component providing database connection pooling API"
HOMEPAGE="http://jakarta.apache.org/commons/dbcp.html"
SRC_URI="mirror://apache/jakarta/commons/dbcp/source/dbcp-${PV}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4
- >=dev-java/commons-collections-2.0
- >=dev-java/commons-pool-1.0.1"
-RDEPEND=">=virtual/jre-1.3
- >=dev-java/commons-pool-1.0.1"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ppc sparc"
IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ >=dev-java/commons-collections-2.0
+ >=dev-java/commons-pool-1.0.1"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/commons-pool-1.0.1"
+
src_compile() {
epatch ${FILESDIR}/${PN}-${PV}-gentoo.diff
echo "commons-collections.jar=`java-config --classpath=commons-collections`" > build.properties
diff --git a/dev-java/xerces/xerces-2.3.0-r1.ebuild b/dev-java/xerces/xerces-2.3.0-r1.ebuild
index 952c3b0876d2..dcc16c4df2c8 100644
--- a/dev-java/xerces/xerces-2.3.0-r1.ebuild
+++ b/dev-java/xerces/xerces-2.3.0-r1.ebuild
@@ -1,21 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xerces/xerces-2.3.0-r1.ebuild,v 1.1 2003/05/26 09:36:45 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xerces/xerces-2.3.0-r1.ebuild,v 1.2 2003/08/05 16:08:02 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
S=${WORKDIR}/xerces-${PV//./_}
DESCRIPTION="The next generation of high performance, fully compliant XML parsers in the Apache Xerces family"
+HOMEPAGE="http://xml.apache.org/xerces2-j/index.html"
SRC_URI="http://xml.apache.org/dist/xerces-j/Xerces-J-src.${PV}.tar.gz
http://xml.apache.org/dist/xerces-j/Xerces-J-tools.${PV}.tar.gz"
-HOMEPAGE="http://xml.apache.org/xerces2-j/index.html"
-DEPEND=">=dev-java/ant-1.5.2"
-RDEPEND=">=virtual/jdk-1.3"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ppc sparc ~alpha"
IUSE="doc"
+DEPEND=">=dev-java/ant-1.5.2"
+RDEPEND=">=virtual/jdk-1.3"
+
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-gentoo.diff
@@ -30,7 +32,7 @@ src_compile() {
fi
}
-src_install () {
+src_install() {
java-pkg_dojar build/x*.jar
dodoc TODO STATUS README LICENSE ISSUES
dohtml Readme.html
diff --git a/dev-java/xerces/xerces-2.3.0.ebuild b/dev-java/xerces/xerces-2.3.0.ebuild
index 8074c47b06e4..1f9ca02c7dd9 100644
--- a/dev-java/xerces/xerces-2.3.0.ebuild
+++ b/dev-java/xerces/xerces-2.3.0.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xerces/xerces-2.3.0.ebuild,v 1.3 2003/04/06 08:19:27 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xerces/xerces-2.3.0.ebuild,v 1.4 2003/08/05 16:08:02 vapier Exp $
S=${WORKDIR}/xerces-${PV//./_}
DESCRIPTION="The next generation of high performance, fully compliant XML parsers in the Apache Xerces family"
+HOMEPAGE="http://xml.apache.org/xerces2-j/index.html"
SRC_URI="http://xml.apache.org/dist/xerces-j/Xerces-J-src.${PV}.tar.gz
http://xml.apache.org/dist/xerces-j/Xerces-J-tools.${PV}.tar.gz"
-HOMEPAGE="http://xml.apache.org/xerces2-j/index.html"
-DEPEND=">=virtual/jdk-1.3"
-RDEPEND=">=virtual/jdk-1.3"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ppc sparc"
-IUSE=""
+
+DEPEND=">=virtual/jdk-1.3"
+RDEPEND=">=virtual/jdk-1.3"
src_unpack() {
unpack ${A}